Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DHCP wont run on 877W-M

i have a 2nd hand 877W-M, updated the bootloader and iOS to the latest.

and now im trying to configure the DHCP, as it looks to me, that is done now, and should be 'working'.

but i dont get any ip's given, and the weird part is that it trows an error right after the 'write' command.

i also have resetted the router to 'conf-register 0x2101' but when it reloads it goes to 36** something.

as for the error it trows in after 'write' its '% IP addresses may not be configured on L2 links.'

here's the version on how its running now:

Using 3350 out of 131072 bytes

!

! Last configuration change at 07:45:46 UTC Sat Mar 27 2010

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 877W-M

!

boot-start-marker

boot bootstrap tftp system 255.255.255.255

boot system flash:c870-advipservicesk9-mz.151-4.M6.bin

boot system flash c870-advipservicesk9-mz.151-4.M6 <i will remove this tonight, i just saw it here>

boot system flash

boot-end-marker

!

!

enable secret 5 *****

enable password *****

!

no aaa new-model

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-2740876176

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2740876176

revocation-check none

rsakeypair TP-self-signed-2740876176

!

!

crypto pki certificate chain TP-self-signed-2740876176

certificate self-signed 01

  *****

        quit

dot11 syslog

ip source-route

no ip routing

!

!

ip dhcp excluded-address 192.168.2.0 192.168.2.20

!

ip dhcp pool lan.local

network 192.168.2.0 255.255.255.0

default-router 192.168.2.3

dns-server 192.168.2.3

!

!

ip dhcp update dns

!

no ip cef

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

archive

log config

  hidekeys

username cisco password 0 cisco

!

!

!

!

!

!

!

!

!

interface ATM0

no ip address

no ip route-cache

shutdown

no atm ilmi-keepalive

cdp enable

!

interface FastEthernet0 <interface im wating to use for the ip, 192.168.2.3>

no ip address

!

interface FastEthernet1

no ip address

shutdown

!

interface FastEthernet2

no ip address

shutdown

!

interface FastEthernet3

no ip address

shutdown

!

interface Dot11Radio0

no ip address

no ip route-cache

shutdown

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

54.0

station-role root

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

!

!

!

!

!

!

!

!

control-plane

!

!

line con 0

exec-timeout 0 0

no modem enable

speed 115200

line aux 0

line vty 0 4

password *****

login

transport input all

!

scheduler max-task-time 5000

end

im guessing im overlooking something simple, but i dont have the experience with router yet, thats why i have bought this type

Don't forget to rate helpful posts.
Everyone's tags (3)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Purple

DHCP wont run on 877W-M

Hi,

-reenable ip routing:

config t

ip routing

-As Paolo stated if you want to use both the ethernet and wireless you'll have to bridge them:

bridge 1 protocol ieee

bridge irb

bridge 1 route ip

int bvi1

ip add 192.168.2.3 255.255.255.0

int vlan 1

bridge-group 1

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Re: DHCP wont run on 877W-M

In the first example, in the dhcp pool, you have the network defined. In the second example, you don't. Put the network statement into the dhcp pool.

Sent from Cisco Technical Support iPad App

5 REPLIES
Hall of Fame Super Gold

Re: DHCP wont run on 877W-M

You configure everything under vlan 1, but if you want to use wireless, bridge it and vlan 1,configure BVI 1 instead.

Note, a self-generate certificate is not sensitve information. Nobody can do anything it.

Purple

DHCP wont run on 877W-M

Hi,

-reenable ip routing:

config t

ip routing

-As Paolo stated if you want to use both the ethernet and wireless you'll have to bridge them:

bridge 1 protocol ieee

bridge irb

bridge 1 route ip

int bvi1

ip add 192.168.2.3 255.255.255.0

int vlan 1

bridge-group 1

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Re: DHCP wont run on 877W-M

The router is not going to hand a dhcp address to one of its own interfaces. Hard code the address on the fa address and leave the dhcp for the clients.

Sent from Cisco Technical Support iPad App

New Member

DHCP wont run on 877W-M

okay, i will leave it for the clients, but i ran into a issue regarding the clients.

when i connect to the ssid, with client dhcp, i get an 255.255.0.0 masked ip, and when i assing a static ip, dns, ect to the client and connect then with the ssid, i get the notice that that is working.

im using the ip's in the dhcp pool, because i wanted to use the reserved ip's for other hardware.

this is the config that i have been getting to run thanks to you and cadet

and i found the SDM 2.5, but i actually wanted to learn do it first from the cli, instead of using a 'next, next' gui feature

877W-M>show                    enable

Password:

877W-M#show running c      -config

Building configuration...

Current configuration : 3728 bytes

!

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 877W-M

!

boot-start-marker

boot-end-marker

!

!

enable secret 4 *****

enable password *****

!

no aaa new-model

!

clock timezone GMT 1 0

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-2740876176

--More--                            enrollment selfsigned

subject-name cn=IOS-Self-Signf-signed-2740876176

!

!

crypto pki certificate chain TP-self-signed-2740876176

certificate self-signed 01

  *****

            quit

dot11 syslog

!

dot11 ssid C-TEC-877W

vlan 1

authentication open

authentication key-management wpa

guest-mode

wpa-psk ascii 0 53+gdg12

!

ip source-route

!

!

ip dhcp remember

ip dhcp excluded-address 192.168.2.0 192.168.2.20

!

ip dhcp pool lan.local

default-router 192.168.2.3

dns-server 192.168.2.3

!

!

ip dhcp update dns

!

ip cef

ip address-pool dhcp-pool

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

username management privilege 15 password 0 15104

!

!

!

!

!

!

bridge irb

!

!

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

         !

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface Dot11Radio0

no ip address

!

encryption vlan 1 mode ciphers aes-ccm

!

ssid C-TEC-877W

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

world-mode dot11d country NL outdoor

          !

interface Dot11Radio0.1

encapsulation dot1Q 1 native

ip virtual-reassembly in

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

no ip address

ip virtual-reassembly in

bridge-group 1

!

interface BVI1

ip address 192.168.2.3 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

ip forward-protocol nd

ip http server

ip http authentication local

         ip http secure-server

!

!

!

!

!

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

exec-timeout 0 0

no modem enable

speed 115200

line aux 0

line vty 0 4

exec-timeout 40 0

privilege level 15

login local

transport input telnet ssh

!

end

Don't forget to rate helpful posts.

Re: DHCP wont run on 877W-M

In the first example, in the dhcp pool, you have the network defined. In the second example, you don't. Put the network statement into the dhcp pool.

Sent from Cisco Technical Support iPad App

353
Views
4
Helpful
5
Replies