Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Dividing Subnets on Cisco 1700

I currently have a Cisco 1700 with the configuration below.

I would like to divide one of the subnets on FA0 : ip address 216.17.190.1 255.255.254.0.

What do I need to do to divide that into two equal subnets.

hostname stdshersteambocomdfrtra

!

aaa new-model

aaa authentication login default local

enable secret 5 $1$YMlo$30YilvB4w29dKa8Zivhbm1

!

username Sh3rstsp password 7 10691D4C544643524D

username admin privilege 15 password 7 07062F584B1B4F564240

memory-size iomem 25

ip subnet-zero

!

ip audit notify log

ip audit po max-events 100

!

!

!

!

interface FastEthernet0

description **** to IP3 outside ****

ip address 204.10.250.57 255.255.255.252 secondary

ip address 216.17.190.1 255.255.254.0

no ip redirects

no ip unreachables

speed 100

full-duplex

!

interface Serial0

no ip address

encapsulation frame-relay IETF

frame-relay lmi-type ansi

!

interface Serial0.1 point-to-point

description **** to SpringSips.com - Ckt#24/HCGX/805484 ****

ip address 204.10.250.30 255.255.255.252

frame-relay interface-dlci 104

!

ip classless

ip route 0.0.0.0 0.0.0.0 204.10.250.29

ip route 66.151.160.0 255.255.254.0 204.10.250.58

ip http server

!

!

6 REPLIES

Re: Dividing Subnets on Cisco 1700

The problem that I immediately see is that your mask wouldn't match up to the providers mask any longer, and you might lose connection.

Theoretically, you could change your private primary address to a 24 bit mask (255.255.255.0) and then your next network would be:

216.17.191.0/24

So you would set up 216.17.191.1 as a secondary address.

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Dividing Subnets on Cisco 1700

So could I remove the current:

ip address 216.17.190.1 255.255.254.0

and replace it with:

ip address 216.17.190.1 255.255.255.0

ip address 216.17.191.1 255.255.255.0

Now I would have two fully functional Class C subnets?

Re: Dividing Subnets on Cisco 1700

"Now I would have two fully functional Class C subnets?"

Yes, but I'd warn you that you might lose connection to your provider. Theoretically it should work, but it might not.

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Dividing Subnets on Cisco 1700

What would I want to do to make sure I would not lose connectivity?

Re: Dividing Subnets on Cisco 1700

I would call the provider and ask them to split them up for you. Then schedule downtime to make the change.

Since I don't see your topology, I'm assuming that the interface you want to change does connect to an ISP. If so, then I would call them and tell them the change that you want to make.

Are you local to the router, or are you remote? If you want to try to make the change without calling the ISP, then you can telnet into the Serial interface, and make your changes on the interface that you want to change. I would get a ping going to the address that's on the interface you want to change, and I'd ping both .1s from both "new" subnets to make sure they were routing correctly through your providers network after the change.

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Dividing Subnets on Cisco 1700

Thanks!

302
Views
0
Helpful
6
Replies