Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

DMVPN / EIGRP issue

Hi,

I have an interesting issue with a DMVPN configuration I'm working on. The hub site is a 2851 running 12.4(10b) and the remote is an 871 running 12.4(11)XW3. In my tunnel configuration on the remote site - if I specify tunnel destination x.x.x.x, instead of using tunnel mode gre multipoint - Everything works. NHRP looks good and I receive EIGRP routes from the hub.

However - when I switch to tunnel mode gre multipoint - NHRP seems to be ok, but I can never establish an EIGRP peer relationship with the hub.

Below is my hub and remote tunnel config:

Hub:

interface Tunnel0

bandwidth 80000

ip address 10.254.0.1 255.255.255.0

no ip redirects

ip mtu 1400

no ip next-hop-self eigrp 101

ip nhrp authentication dmvpn1

ip nhrp map multicast dynamic

ip nhrp network-id 100099

ip nhrp holdtime 300

ip tcp adjust-mss 1360

no ip split-horizon eigrp 101

delay 1000

qos pre-classify

tunnel source GigabitEthernet0/1

tunnel mode gre multipoint

tunnel key XXXXXX

tunnel protection ipsec profile vpn-dmvpn

end

Remote Tunnel Config :

interface Tunnel0

bandwidth 1000

ip address 10.254.0.10 255.255.255.0

no ip redirects

ip mtu 1400

ip pim sparse-dense-mode

ip nhrp authentication dmvpn1

ip nhrp map multicast dynamic

ip nhrp map 10.254.0.1 a.b.c.d

ip nhrp map multicast 10.254.0.1

ip nhrp network-id 100099

ip nhrp holdtime 300

ip nhrp nhs 10.254.0.1

ip tcp adjust-mss 1360

delay 1000

qos pre-classify

tunnel source FastEthernet4

tunnel mode gre multipoint

tunnel key XXXXXX

tunnel protection ipsec profile vpn-dmvpn

end

In this scenario listed above nhrp appears good - however EIGRP never peers:

spoke01-871#sh dmvpn

Legend: Attrb --> S - Static, D - Dynamic, I - Incompletea

N - NATed, L - Local, X - No Socket

# Ent --> Number of NHRP entries with same NBMA peer

Tunnel0, Type:Spoke, NHRP Peers:1,

# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb

----- --------------- --------------- ----- -------- -----

1 a.b.c.d 10.254.0.1 UP 00:05:41 S

EIGRP:

spoke01-871#sh ip eigrp nei det

IP-EIGRP neighbors for process 101

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 10.254.0.1 Tu0 14 00:00:47 1 5000 2 0

Version 12.4/1.2, Retrans: 10, Retries: 10, Waiting for Init, Waiting for Init Ack

UPDATE seq 1148 ser 0-0 Sent 47880 Init Sequenced

UPDATE seq 1149 ser 1-162 Sequenced

However - if I run these commands on the remote:

conf t

int tu0

no tunnel mode gre multipoint

tunnel dest a.b.c.d

POOF! EIGRP works:

spoke01-871#sh ip eigrp nei det

IP-EIGRP neighbors for process 101

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 10.254.0.1 Tu0 10 00:00:27 76 684 0 37

Version 12.4/1.2, Retrans: 1, Retries: 0, Prefixes: 79

Any ideas? Thanks!

Brad

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: DMVPN / EIGRP issue

on your multipoint tunnel change this line:

ip nhrp map multicast 10.254.0.1

to

ip nhrp map multicast a.b.c.d

where a.b.c.d is your hub's public ip, this should be done for each spoke.

2 REPLIES
New Member

Re: DMVPN / EIGRP issue

on your multipoint tunnel change this line:

ip nhrp map multicast 10.254.0.1

to

ip nhrp map multicast a.b.c.d

where a.b.c.d is your hub's public ip, this should be done for each spoke.

New Member

Re: DMVPN / EIGRP issue

Thanks for the help. That fixed the issue straight away!

1016
Views
0
Helpful
2
Replies
CreatePlease to create content