Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

DMVPN + EIGRP neighbor not found

Hello

Moving from LAB to production and I cannot get the HUB router to participate in EIGRP.  I see in the logs neighbor not found (10.1.2.192) which is the spoke's tunnel interface.

HUB:

interface Tunnel1

ip address 10.1.2.1 255.255.255.0

no ip redirects

ip mtu 1400

no ip next-hop-self eigrp 3111

no ip split-horizon eigrp 3111

ip nhrp authentication TEST

ip nhrp map multicast dynamic

ip nhrp network-id 1

ip nhrp holdtime 300

ip tcp adjust-mss 1360

tunnel source GigabitEthernet0/0

tunnel mode gre multipoint

tunnel key 123

tunnel protection ipsec profile TEST-DMVPN shared

...........

router eigrp 3111

network 10.0.0.0

eigrp router-id 10.120.0.10

............

r4-2911-HUB#show ip eigrp neighbors

EIGRP-IPv4 Neighbors for AS(3111)

........

Sep  3 23:18:21.264: EIGRP: Neighbor(10.1.2.192) not yet found

................

SPOKE:

interface Tunnel1

ip address 10.1.2.192 255.255.255.0

no ip redirects

ip mtu 1400

ip nhrp authentication TEST

ip nhrp map 10.1.2.1 205.234.20.11

ip nhrp network-id 1

ip nhrp holdtime 300

ip nhrp nhs 10.1.2.1

ip tcp adjust-mss 1360

tunnel source GigabitEthernet0/1

tunnel mode gre multipoint

tunnel key 123

tunnel protection ipsec profile TEST-DMVPN shared

.........

router eigrp 3111

network 10.0.0.0

eigrp stub connected

..........

EIGRP-IPv4 Neighbors for AS(3111)

H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq

                                                   (sec)         (ms)       Cnt Num

1   10.1.2.1                Tu1                      13 00:00:10    1  5000  1  0

2   10.192.11.1             Gi0/0.1                  14 00:07:05   16   100  0  39

0   10.192.2.1              Gi0/0.2                  14 00:07:06  148   888  0  36

.......

*Sep  3 23:19:18.675: Going down: Peer 10.1.2.1 total=2 stub 0, iidb-stub=0 iid-all=0

*Sep  3 23:19:18.675: EIGRP: Handle deallocation failure [1]

*Sep  3 23:19:18.675: EIGRP: Neighbor 10.1.2.1 went down on Tunnel1.

*Sep  3 23:19:22.943: EIGRP: New peer 10.1.2.1.

*Sep  3 23:19:22.943: %DUAL-5-NBRCHANGE: EIGRP-IPv4 3111: Neighbor 10.1.2.1 (Tunnel1) is up: new adjacency...

Can someone help me out?  I for the life of me cannot figure out why the spoke can peer but the HUB cannot. 

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

DMVPN + EIGRP neighbor not found

Hello,

Usually, the spoke is configured also with the ip nhrp map multicast 205.234.20.11 on its mGRE interface. I do not see this line in your spoke's configuration - would you mind adding it?

Also, do you happen to use any neighbor command in your EIGRP configuration either on the spoke or on the hub?

Best regards,

Peter

4 REPLIES
Cisco Employee

DMVPN + EIGRP neighbor not found

Hello,

Usually, the spoke is configured also with the ip nhrp map multicast 205.234.20.11 on its mGRE interface. I do not see this line in your spoke's configuration - would you mind adding it?

Also, do you happen to use any neighbor command in your EIGRP configuration either on the spoke or on the hub?

Best regards,

Peter

New Member

DMVPN + EIGRP neighbor not found

Thanks Paul that is exactly what it was, once that was added it was able to form. 

I don't use any neighbor commands at all. 

New Member

Hi guys, just wanted to add

Hi guys, just wanted to add my solution to the problem. I had the same symptoms:EIGRP neighbor not found on a DynamicMultipoint VPN.

My setup was slightly different, because I also had defined the ip nhrp map multicast destination on the spokes:

ip nhrp map multicast x.x.x.x  

Adding the eigrp neigbour did not solve my problem.

I found that I had misconfigured ip nhrp map multicast x.x.x.x : I had used the GRE address of the hub, but that should have been the interface IP of the hub. Once I had changed that, neigbourships were formed immediately :)

New Member

Thanks Peter. I incorrectly

Thanks Peter. I incorrectly mapped spoke nhrp multicast to hub DMVPN tunnel interface IP. The result is EIGRP neighbor comes up on spoke but flaps (retry limit exceeded) because Q cnt never became 0. DMVPN hub never saw spokes in EIGRP neighbor.

When dmvpn multicast come ni tunnel interface (encapsulated) rather than tunnel source, it gets discarded?

4001
Views
25
Helpful
4
Replies
CreatePlease to create content