Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

DMVPN OSPF hello packet not received

Dear all,

     Wonder if anyone encounter same situation of me.

     I build a Dual Hub Dual DMVPN with OSPF and I observed that the ospf hello packet are not arriving hub from spoke.

     Thus my ospf neighbor periodically up/down while the timer exceeed.

     I tried to add static neighbor on spoke and I observe the hub start receiving ospf hello from spoke but it's still not work.

     My DMVPN & OSPF configuration as below

[Hub1]

!

interface Tunnel31

ip address 10.231.0.251 255.255.0.0

no ip redirects

ip nhrp map multicast dynamic

ip nhrp map 10.231.0.252 10.100.2.254

ip nhrp map multicast 10.231.0.252

ip nhrp network-id 231

ip nhrp holdtime 600

ip ospf network point-to-multipoint

ip ospf mtu-ignore

ip ospf 1 area 3510

tunnel source GigabitEthernet0/1

tunnel mode gre multipoint

tunnel key 231

tunnel protection ipsec profile DMVPN-1 shared

!        

router ospf 1

router-id 10.0.254.1

area 3510 stub no-summary

area 3520 stub no-summary

area 3600 stub no-summary

redistribute static subnets route-map static->ospf

!

[Hub2]

!

interface Tunnel32

ip address 10.232.0.252 255.255.0.0

no ip redirects

ip nhrp map multicast dynamic

ip nhrp map 10.232.0.251 10.100.1.254

ip nhrp map multicast 10.232.0.251

ip nhrp network-id 232

ip nhrp holdtime 600

ip ospf network point-to-multipoint

ip ospf mtu-ignore

ip ospf 1 area 3520

tunnel source GigabitEthernet0/1

tunnel mode gre multipoint

tunnel key 232

tunnel protection ipsec profile DMVPN-1 shared

!

router ospf 1

router-id 10.0.254.2

area 3510 stub no-summary

area 3520 stub no-summary

area 3600 stub no-summary

redistribute static subnets route-map static->ospf

!

[Spoke]

!

interface Tunnel31

ip address 10.231.64.1 255.255.0.0

no ip redirects

ip nhrp map 10.231.0.251 10.100.1.254

ip nhrp map multicast 10.231.0.251

ip nhrp map 10.231.0.252 10.100.2.254

ip nhrp map multicast 10.231.0.252

ip nhrp network-id 231

ip nhrp holdtime 600

ip nhrp nhs 10.231.0.251

ip nhrp nhs 10.231.0.252

ip ospf network point-to-multipoint

ip ospf mtu-ignore

ip ospf 1 area 3510

tunnel source GigabitEthernet0/0

tunnel mode gre multipoint

tunnel key 231

tunnel protection ipsec profile DMVPN

!

router ospf 1

router-id 10.0.64.1

area 3510 stub no-summary

neighbor 10.0.254.2 cost 20

neighbor 10.0.254.1

Spoke#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface

10.0.254.2        0   FULL/  -        00:01:34    10.231.0.252    Tunnel31

10.0.254.1        0   FULL/  -        00:01:53    10.231.0.251    Tunnel31

Hub2#sh log | inc 10.0.64.1

*Aug  5 17:58:15: %OSPF-5-ADJCHG: Process 1, Nbr 10.0.64.1 on Tunnel31 from FULL to DOWN, Neighbor Down: Dead timer expired

*Aug  5 17:58:26: OSPF-1 HELLO Tu31: Rcv hello from 10.0.64.1 area 3510 10.231.64.1

*Aug  5 17:58:26: OSPF-1 HELLO Tu31: Send immediate hello to nbr 10.0.64.1, src address 10.231.64.1

*Aug  5 17:58:26: %OSPF-5-ADJCHG: Process 1, Nbr 10.0.64.1 on Tunnel31 from LOADING to FULL, Loading Done

*Aug  5 18:00:37: %OSPF-5-ADJCHG: Process 1, Nbr 10.0.64.1 on Tunnel31 from FULL to DOWN, Neighbor Down: Dead timer expired

*Aug  5 18:00:53: OSPF-1 HELLO Tu31: Rcv hello from 10.0.64.1 area 3510 10.231.64.1

*Aug  5 18:00:53: OSPF-1 HELLO Tu31: Send immediate hello to nbr 10.0.64.1, src address 10.231.64.1

*Aug  5 18:00:53: %OSPF-5-ADJCHG: Process 1, Nbr 10.0.64.1 on Tunnel31 from LOADING to FULL, Loading Done

*Aug  5 18:02:55: %OSPF-5-ADJCHG: Process 1, Nbr 10.0.64.1 on Tunnel31 from FULL to DOWN, Neighbor Down: Dead timer expired

*Aug  5 18:03:15: OSPF-1 HELLO Tu31: Rcv hello from 10.0.64.1 area 3510 10.231.64.1

*Aug  5 18:03:15: OSPF-1 HELLO Tu31: Send immediate hello to nbr 10.0.64.1, src address 10.231.64.1

*Aug  5 18:03:15: %OSPF-5-ADJCHG: Process 1, Nbr 10.0.64.1 on Tunnel31 from LOADING to FULL, Loading Done

*Aug  5 18:05:16: %OSPF-5-ADJCHG: Process 1, Nbr 10.0.64.1 on Tunnel31 from FULL to DOWN, Neighbor Down: Dead timer expired

*Aug  5 18:05:40: OSPF-1 HELLO Tu31: Rcv hello from 10.0.64.1 area 3510 10.231.64.1

*Aug  5 18:05:40: OSPF-1 HELLO Tu31: Send immediate hello to nbr 10.0.64.1, src address 10.231.64.1

*Aug  5 18:05:40: %OSPF-5-ADJCHG: Process 1, Nbr 10.0.64.1 on Tunnel31 from LOADING to FULL, Loading Done

*Aug  5 18:07:43: %OSPF-5-ADJCHG: Process 1, Nbr 10.0.64.1 on Tunnel31 from FULL to DOWN, Neighbor Down: Dead timer expired

*Aug  5 18:08:05: OSPF-1 HELLO Tu31: Rcv hello from 10.0.64.1 area 3510 10.231.64.1

*Aug  5 18:08:05: OSPF-1 HELLO Tu31: Send immediate hello to nbr 10.0.64.1, src address 10.231.64.1

*Aug  5 18:08:05: %OSPF-5-ADJCHG: Process 1, Nbr 10.0.64.1 on Tunnel31 from LOADING to FULL, Loading Done

*Aug  5 18:10:07: %OSPF-5-ADJCHG: Process 1, Nbr 10.0.64.1 on Tunnel31 from FULL to DOWN, Neighbor Down: Dead timer expired

*Aug  5 18:10:27: OSPF-1 HELLO Tu31: Rcv hello from 10.0.64.1 area 3510 10.231.64.1

*Aug  5 18:10:27: OSPF-1 HELLO Tu31: Send immediate hello to nbr 10.0.64.1, src address 10.231.64.1

*Aug  5 18:10:28: %OSPF-5-ADJCHG: Process 1, Nbr 10.0.64.1 on Tunnel31 from LOADING to FULL, Loading Done

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Silver

DMVPN OSPF hello packet not received

Hello Peter,

OSPF Network type point-to-multipoint uses multicasts address 224.0.0.5. You have configured neighbor statements and this would be the case for using OSPF network type point-to-multipoint non-broadcast, so, for this to work with neighbor statements first you should change the network type to point-to-multipoint non-broadcast. However, I would solve the multicast issue, remove the neighbor statements, and maintain the network to point-to-multipoint.

I see that you are doing the multicast mappings to the tunnel addreses, you should do to the physical addresses:

ip nhrp map 10.231.0.252 10.100.2.254

ip nhrp map multicast 10.100.2.254

Best Regards,

Jose.

2 REPLIES
Silver

DMVPN OSPF hello packet not received

Hello Peter,

OSPF Network type point-to-multipoint uses multicasts address 224.0.0.5. You have configured neighbor statements and this would be the case for using OSPF network type point-to-multipoint non-broadcast, so, for this to work with neighbor statements first you should change the network type to point-to-multipoint non-broadcast. However, I would solve the multicast issue, remove the neighbor statements, and maintain the network to point-to-multipoint.

I see that you are doing the multicast mappings to the tunnel addreses, you should do to the physical addresses:

ip nhrp map 10.231.0.252 10.100.2.254

ip nhrp map multicast 10.100.2.254

Best Regards,

Jose.

New Member

DMVPN OSPF hello packet not received

Hi Jose,

        Problem solved. Thank you.

1406
Views
0
Helpful
2
Replies
CreatePlease to create content