Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

DNS not working at all

Hey everybody,

I've got a case where a DNS is not working in the router, I have read some things found on google but I still can't make it work... that's why I'm here and hope you could help.

I issued a debug ip udp to check how the conversion was being made and it seems that the DNS server responds but still does not resolve to the router, I just want to know if it's the DNS or the Router (or both) who are doing this weird behavior.

Here's the output generated with a ping

MGCAM_CEN_90713#ping yahoo.com

Translating "yahoo.com"...domain server (200.35.65.3) (200.35.65.4) (200.44.32.12)

*Jun 30 13:09:50.710: UDP: rcvd src=10.10.16.79(68), dst=255.255.255.255(67), length=308

*Jun 30 13:09:50.710: UDP: rcvd src=10.10.16.12(67), dst=255.255.255.255(68), length=308

*Jun 30 13:09:51.566: UDP: Random local port generated 56573, network 1

*Jun 30 13:09:51.566: Reserved port 56573 in Transport Port Agent for UDP IP type 1

*Jun 30 13:09:51.566: UDP: sent src=10.18.121.242(56573), dst=200.35.65.3(53), length=35

*Jun 30 13:09:51.650: UDP: rcvd src=200.35.65.3(53), dst=10.18.121.242(56573), length=35

*Jun 30 13:09:51.650: Released port 56573 in Transport Port Agent for IP type 1

(This is where It seems that the DNS responds to the router but still gives me error at the end)

*Jun 30 13:09:51.650: UDP: Random local port generated 52775, network 1

*Jun 30 13:09:51.650: Reserved port 52775 in Transport Port Agent for UDP IP type 1

*Jun 30 13:09:51.650: UDP: sent src=10.18.121.242(52775), dst=200.35.65.4(53), length=35

*Jun 30 13:09:51.694: UDP: rcvd src=200.35.65.4(53), dst=10.18.121.242(52775), length=35

*Jun 30 13:09:51.694: Released port 52775 in Transport Port Agent for IP type 1

*Jun 30 13:09:51.694: UDP: Random local port generated 59654, network 1

*Jun 30 13:09:51.694: Reserved port 59654 in Transport Port Agent for UDP IP type 1

*Jun 30 13:09:51.698: UDP: sent src=10.18.121.242(59654), dst=200.44.32.12(53), length=35

*Jun 30 13:09:51.822: UDP: rcvd src=0.0.0.0(68), dst=255.255.255.255(67), length=556

*Jun 30 13:09:51.822: UDP: rcvd src=10.10.16.12(67), dst=255.255.255.255(68), length=319

*Jun 30 13:09:54.218: UDP: rcvd src=10.10.16.84(68), dst=255.255.255.255(67), length=308

*Jun 30 13:09:54.218: UDP: rcvd src=10.10.16.12(67), dst=255.255.255.255(68), length=308

*Jun 30 13:09:54.218: UDP: rcvd src=0.0.0.0(68), dst=255.255.255.255(67), length=556

*Jun 30 13:09:54.222: UDP: rcvd src=10.10.16.12(67), dst=255.255.255.255(68), length=319

*Jun 30 13:09:54.698: UDP: sent src=10.18.121.242(59654), dst=200.44.32.12(53), length=35

*Jun 30 13:09:56.198: UDP: rcvd src=0.0.0.0(68), dst=255.255.255.255(67), length=556

*Jun 30 13:09:56.198: UDP: rcvd src=10.10.16.12(67), dst=255.255.255.255(68), length=319

*Jun 30 13:09:57.698: UDP: sent src=10.18.121.242(59654), dst=200.44.32.12(53), length=35 (4.2.2.2)

*Jun 30 13:09:59.222: UDP: rcvd src=200.71.149.93(137), dst=200.71.149.95(137), length=58

*Jun 30 13:09:59.974: UDP: rcvd src=200.71.149.93(137), dst=200.71.149.95(137), length=58

*Jun 30 13:10:00.698: Released port 59654 in Transport Port Agent for IP type 1

*Jun 30 13:10:00.698: UDP: Random local port generated 52659, network 1

*Jun 30 13:10:00.698: Reserved port 52659 in Transport Port Agent for UDP IP type 1

*Jun 30 13:10:00.698: UDP: sent src=10.18.121.242(52659), dst=4.2.2.2(53), length=35

*Jun 30 13:10:00.722: UDP: rcvd src=200.71.149.93(137), dst=200.71.149.95(137), length=58

*Jun 30 13:10:03.698: UDP: sent src=10.18.121.242(52659), dst=4.2.2.2(53), length=35

*Jun 30 13:10:06.698: UDP: sent src=10.18.121.242(52659), dst=4.2.2.2(53), length=35

% Unrecognized host or address, or protocol not running.

And here's the sh run (edited of course):

MGCAM_CEN_90713#sh run
Building configuration...

Current configuration : 2687 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname MGCAM_CEN_90713
!
boot-start-marker
boot-end-marker
!
enable secret 5
!
no aaa new-model
ip cef
!
!
!
!
ip name-server 200.35.65.3
ip name-server 200.35.65.4
ip name-server 4.2.2.2
!
!
!
!
interface FastEthernet0/0
description CONEXION LAN
ip address
no ip redirects
no ip unreachables
no ip mroute-cache
speed 100
full-duplex
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
description CONEXION A INTERNET MOVISTAR
no ip address
encapsulation frame-relay IETF
no ip route-cache cef
no ip route-cache
frame-relay lmi-type cisco
!
interface Serial0/0/0.16 point-to-point
ip address 10.18.121.242 255.255.255.252
no ip route-cache
frame-relay interface-dlci 16  
!
interface Serial0/1/0
no ip address
encapsulation frame-relay IETF
no ip route-cache cef
no ip route-cache
frame-relay lmi-type cisco
!
interface Serial0/1/0.20 point-to-point
description CONEXION MG MOTORES
ip address 10.10.10.6 255.255.255.252
no ip route-cache
no ip mroute-cache
frame-relay interface-dlci 20 IETF  
!
router eigrp 1
network 10.0.0.0
network 128.180.0.0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.18.121.241
!
ip http server
!
!
control-plane
!
!
line con 0
password 7
login
line aux 0
line vty 0 4
password 7
login
!
scheduler allocate 20000 1000
end

Any help would be extremeley appreciated.

Thank You

Antonio Hurtado

1 REPLY

Re: DNS not working at all

Hi

Can you check the below thing :

1] This Frame Relay is an internet connection , But i wont see any natting config & In the IP address that you used is Private IP address range.

Please check with SP that were natting is configured. As the logs are showing that you source IP is 10.18.121.242 & Yahoo server won't have the route for

this.

Jun 30 13:09:51.566: UDP: sent src=10.18.121.242(56573), dst=200.35.65.3(53), length=35

*Jun 30 13:09:51.650: UDP: rcvd src=200.35.65.3(53), dst=10.18.121.242(56573), length=35

Please clear you config if above won't work.

1] were the natting is configured.

2] the Ip addres is private range need to translate. ( If SP is configured the natting please confirm)

3] Or Else check weather you can ping IP i.e 4.2.2.2.

Regards

Chetan Kumar


274
Views
0
Helpful
1
Replies
CreatePlease to create content