Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DNS

Hi,

Can someone point me in the right direction,thanks in advance for any help!!

I'm not getting DNS resovled and I can ping from inside 10.0.0.2 to a WAN IP.

One think that is also puzzling me is that I can ping a WAN IP from a workstation(10.0.0.2), but the router will not ping the same WAN IP.

Also on the lookup get this error Unrecognized host or address, or protocol not running.

This is not a live network just studding for my certs.

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

!

ip subnet-zero

ip name-server 172.16.0.222

ip name-server 19*.12*.2*.**

!

!

!

interface Ethernet0/0

ip address 172.16.0.117 255.255.252.0

ip access-group 101 in

ip access-group 101 out

no ip directed-broadcast

ip nat outside

interface Ethernet0/1

ip address 10.0.0.1 255.0.0.0

ip access-group 102 in

ip access-group 102 out

no ip directed-broadcast

ip nat inside

!

ip default-gateway 172.16.0.212

ip nat inside source static 10.0.0.2 172.16.0.117

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.0.212

!

access-list 101 permit ip any any

access-list 102 permit ip any any

!

line con 0

transport input none

line aux 0

line vty 0 4

1 REPLY
Hall of Fame Super Silver

Re: DNS

Richard

There are a couple of things that I would comment about your question.

First it is not clear whether the issue about not resolving DNS is a symptom on the router or a symptom on the PC on the LAN interface of the router. I am assuming that it is an issue on the PC. Therefore we would need to know how the PC is configured. In particular we need to know what the PC has configured for DNS server (the PC will not use the name servers configured on the router - unless the same name servers are configured on the PC).

Second if this is not a live network but something that you are using to study for certs, are the name servers that are configured really functioning as name servers.

Third you talk about being able to ping WAN IP but are not clear whether the address you are pinging is the address of the name server or some other WAN address.

Fourth the reason that you can ping from the PC but not from the router may have to do with the fact that you have done address translation for the PC address making it the same as the router interface address. Since there will be an entry in the translation table when a response is received from the outside with destination address of 172.16.0.117 the router is probably translating that address and forwarding it to the PC. Try changing the static translation to be 172.16.0.115 and see if it works better.

HTH

Rick

234
Views
0
Helpful
1
Replies
CreatePlease to create content