Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Does GLBP work for this?

I have traffic coming into a 4948 switch with 2 ports going to 2 different 7200 routers.

There is traffic flowing from multiple VLANS.  One of these uses L2TPv3 tunneling to get to a far-end gateway router.

Each 7200 has a DS3 which connect to two other 7200s which connect to a 4948 on the far end.

Also connected to the far-end 4948 is the WAN traffic gateway 7200.

We are using OSPF within the network so the routers can learn where the Loopback interface of the far-end gateway 7200 is.

Right now traffic is only going through one near-end 7200 and through its DS3.

We would like to balance the load between the two routers and the two DS3s.

Is it possible to use GLPB to accomplish this?

I may not have explained this properly but would try and answer any questions in order to help someone understand it better.

I currently have live customer traffic so can't really "experiement" with it live.

Thanks,

Caryl

Everyone's tags (3)
5 REPLIES

Re: Does GLBP work for this?

Yes you can do it.

The one thing is, if I understood well the near-end 7200 are conncted to the local switch and to the DS3 links.So the near-end 7200 are not connected back to back.

Having this in mind you should track the DS3 link or the existence of the lookback of the far end 7200 , in order to decrement the AVF priority. If not you will have a near-end 7200 as a black hole for some user's traffic in the case of link failure (DS3) or other.

Regards

Dan

New Member

Does GLBP work for this?

You are correct there are no direct connections between the near-end 7200s.

I am working on a diagram to upload as well.

Re: Does GLBP work for this?

OK then , the main worry will be :

   -  near-end 7200 looses the connection to the far-end 7200 ( DS3 link, or other equipment /link on the path )

but it will still be the AVF . As a solution I think you can track ip route existence of the far-end 7200's loopback, and using this track you should lower the priority. This way if it looses the connection to far end will not be AVF.

   A better solution , i think , is to add a back to back interface between near end 7200, you will have a better redundancy.

Regards

Dan

New Member

Does GLBP work for this?

OK, here is a network map and the appropriate configs.

I think I have all the IPs and VLANS changed to protect the innocent.

I tried to color code the configs but it was lost in the paste.

The near end routers do have a connection into the same switch so not sure why you think I would need another connection between them.

Thanks again for any insight into deploying GLBP to utilize the idle DS3.

I do know that there will need to be additional interfaces created on the 2nd path that are not there today.

Caryl

INTERNET  GW________________________________

interface GigabitEthernet0/1

description Co-located @ Cabinet 100-104

ip address xx.xxx.238.130 255.255.255.248 secondary

ip address xx.xxx.234.34 255.255.255.248

ip route-cache flow

no ip mroute-cache

duplex auto

speed auto

media-type rj45

no negotiation auto

no cdp enable

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

media-type rj45

no negotiation auto

interface GigabitEthernet0/2.200

description FAR-NEAR VLAN

encapsulation dot1Q 200

  ip address xx.xxx.238.193 255.255.255.192

ip route 0.0.0.0 0.0.0.0 xx.xxx.238.129

FAR SW________________________________________________

interface GigabitEthernet0/1

description connected to far-gw

switchport mode trunk

interface GigabitEthernet0/2

description connection to far-gw2

switchport mode trunk

interface GigabitEthernet0/3

description to internet-gw

switchport mode trunk

FAR GW________________________________________________

pseudowire-class vlan-connect

encapsulation l2tpv3

protocol l2tpv3 class1

ip local interface Loopback0

interface Loopback0

ip address xx.xxx.254.161 255.255.255.255

interface Serial2/0

description DS3 to NEAR-GW

bandwidth 44210

ip address xx.x.0.10 255.255.255.252

ip broadcast-address xx.x.0.11

ip load-sharing per-packet

no ip route-cache cef

no ip route-cache

ip ospf authentication-key

ip ospf cost 25

ip ospf hello-interval 6

ip ospf dead-interval 20

dsu bandwidth 44210

framing c-bit

cablelength 10

down-when-looped

serial restart-delay 0

interface GigabitEthernet5/0

description connection to far-sw

mtu 4470

no ip address

no ip route-cache cef

no ip route-cache

ip ospf cost 9

negotiation auto

interface GigabitEthernet5/0.200

description VLAN 200 near tunnel

encapsulation dot1Q 200

no ip route-cache

no cdp enable

xconnect xx.xxx.254.81 200 pw-class vlan-connect

router ospf 1

log-adjacency-changes

redistribute static metric-type 1 subnets route-map LINK-PRIORITY-STATIC

network xx.x.0.0 0.0.0.3 area 0.0.0.0

network xx.x.0.4 0.0.0.3 area 0.0.0.0

network xx.x.0.8 0.0.0.3 area 0.0.0.0

network xx.x.0.32 0.0.0.3 area 0.0.0.0

network xx.xx.90.0 0.0.0.255 area 0.0.0.0

network xx.xxx.254.161 0.0.0.0 area 0.0.0.0

maximum-paths 6

distribute-list 35 out static

distance 40

access-list 35 permit any

route-map LINK-PRIORITY-STATIC permit 65535

match ip address 1

FAR GW2_______________________________________________________

pseudowire-class vlan-connect

encapsulation l2tpv3

protocol l2tpv3 class1

ip local interface Loopback0

interface Loopback0

ip address xx.xxx.254.162 255.255.255.255

interface Serial2/0

description DS3 to NEAR-GW2

bandwidth 44210

ip address xx.x.0.14 255.255.255.252

ip broadcast-address xx.x.0.15

ip load-sharing per-packet

no ip route-cache cef

no ip route-cache

ip ospf authentication-key

ip ospf cost 25

ip ospf hello-interval 6

ip ospf dead-interval 20

dsu bandwidth 44210

framing c-bit

cablelength 10

down-when-looped

serial restart-delay 0

interface GigabitEthernet5/0

description connection to far-sw

mtu 4470

no ip address

no ip route-cache cef

no ip route-cache

ip ospf cost 9

negotiation auto

router ospf 1

log-adjacency-changes

redistribute static metric-type 1 subnets route-map LINK-PRIORITY-STATIC

network xx.x.0.12 0.0.0.3 area 0.0.0.0

network xx.x.0.16 0.0.0.3 area 0.0.0.0

network xx.x.0.24 0.0.0.3 area 0.0.0.0

network xx.xx.90.0 0.0.0.255 area 0.0.0.0

network xx.xxx.254.162 0.0.0.0 area 0.0.0.0

maximum-paths 6

distribute-list 35 out static

distance 40

access-list 35 permit any

route-map LINK-PRIORITY-STATIC permit 65535

match ip address 1

NEAR GW_______________________________________________

interface Loopback0

ip address xx.xxx.254.81 255.255.255.255

interface GigabitEthernet0/2

description VLAN Trunk to near-sw

mtu 4470

no ip address

duplex auto

speed auto

media-type rj45

no negotiation auto

interface GigabitEthernet0/2.200

description VLAN 200 near tunnel to far

encapsulation dot1Q 200

no cdp enable

xconnect xx.xxx.254.161 210 pw-class vlan-connect

interface Serial4/0

description DS3 to FAR-GW

ip address xx.x.0.9 255.255.255.252

ip ospf authentication-key

ip ospf cost 25

ip ospf hello-interval 6

ip ospf dead-interval 20

dsu bandwidth 44210

framing c-bit

cablelength 10

serial restart-delay 0

router ospf 1

log-adjacency-changes

redistribute static metric-type 1 subnets route-map LINK-PRIORITY-STATIC

network xx.x.0.8 0.0.0.3 area 0.0.0.0

network xx.x.2.0 0.0.0.3 area 0.0.0.0

network xx.x.3.0 0.0.0.3 area 0.0.0.0

network xx.x.3.4 0.0.0.3 area 0.0.0.0

network xx.x.3.8 0.0.0.3 area 0

network xx.x.3.12 0.0.0.3 area 0.0.0.0

network xx.x.3.76 0.0.0.3 area 0.0.0.0

network xx.x.3.80 0.0.0.3 area 0.0.0.0

network xx.x.3.84 0.0.0.3 area 0.0.0.0

network xx.x.3.88 0.0.0.3 area 0.0.0.0

network xx.x.3.128 0.0.0.0 area 0

network xx.x.3.132 0.0.0.3 area 0.0.0.0

network xx.x.3.128 0.0.0.63 area 0.0.0.0

network xx.xx.xx.x 0.0.0.255 area 0.0.0.0

network xx.xx.11.0 0.0.0.255 area 0.0.0.0

network xx.xx.12.0 0.0.0.255 area 0.0.0.0

network xx.xx.15.0 0.0.0.255 area 0.0.0.0

network xx.xxx.254.81 0.0.0.0 area 0.0.0.0

maximum-paths 6

default-information originate metric 2000

distribute-list 30 out static

distance 40

access-list 30 permit any

route-map LINK-PRIORITY-STATIC permit 65535

match ip address 1

NEAR GW2______________________________________________

interface Loopback0

ip address xx.xxx.254.82 255.255.255.255

interface GigabitEthernet1/0

mtu 4470

no ip address

negotiation auto

interface Serial4/0

description DS3 to FAR-GW2

ip address xx.x.0.13 255.255.255.252

ip ospf authentication-key

ip ospf cost 25

ip ospf hello-interval 6

ip ospf dead-interval 20

dsu bandwidth 44210

framing c-bit

cablelength 10

serial restart-delay 0

router ospf 1

log-adjacency-changes

redistribute static metric-type 1 subnets route-map LINK-PRIORITY-STATIC

network xx.x.0.12 0.0.0.3 area 0.0.0.0

network xx.x.3.64 0.0.0.3 area 0.0.0.0

network xx.x.3.68 0.0.0.3 area 0.0.0.0

network xx.x.3.72 0.0.0.3 area 0.0.0.0

network xx.x.3.76 0.0.0.3 area 0.0.0.0

network xx.x.3.80 0.0.0.3 area 0.0.0.0

network xx.x.3.84 0.0.0.3 area 0.0.0.0

network xx.x.3.88 0.0.0.3 area 0.0.0.0

network xx.x.3.132 0.0.0.3 area 0.0.0.0

network xx.xx.xx.x 0.0.0.255 area 0.0.0.0

network xx.xx.11.0 0.0.0.255 area 0.0.0.0

network xx.xx.12.0 0.0.0.255 area 0.0.0.0

network xx.xx.15.0 0.0.0.255 area 0.0.0.0

network xx.xxx.254.82 0.0.0.0 area 0.0.0.0

maximum-paths 7

distribute-list 30 out static

distance 40

access-list 30 permit any

route-map LINK-PRIORITY-STATIC permit 65535

match ip address 1

NEAR SW___________________________________________________

interface Loopback0

ip address xx.xxx.254.83 255.255.255.255

interface GigabitEthernet1/2

description Trunk interface to near-gw

switchport trunk encapsulation dot1q

switchport mode trunk

mtu 4470

interface GigabitEthernet1/6

description connection to near-gw2

switchport trunk encapsulation dot1q

switchport mode trunk

mtu 4470

interface GigabitEthernet1/33

description Calix C7 Internet Uplink

switchport trunk encapsulation dot1q

switchport mode trunk

CALIX_______________________________________________

Virtual Router

IP IF RTRAID N1-1-VR10 (NEAR CO)  xx.xxx.238.194 255.255.255.192  VLAN 200

IP ROUTE  xx.xxx.238.192  255.255.255.192  xx.xxx.238.194

DSL CUSTOMER______________________________

Modem Config

IP  xx.xxx.238.196  S/M 255.255.255.192  GW xx.xxx.238.193

Does GLBP work for this?

Hi ,

My reason for the 2nd interface  between near-end routers is GLBP. If for example near-gw looses the connection with far-gw , it will still be AVF - being the gateway for some clients - as far I understoood from your setup is that the only routes that near-gw will have - beside those connected - will be received from far-gw. In the case decribed , you will not have any routes, so the traffic will be droped on this router (near-gw)

You can also activate ospf , on the interface's toward the clients.

Regards

Dan

595
Views
0
Helpful
5
Replies
CreatePlease to create content