Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Dot1q & Cisco 3745

Hi All,

We are trying to create a trunk between cisco 3550 and 3745. We are not able to send any traffic other the one specified as native.

The module is NM-16ESW on the Router with an IOS 12.4.

Please find the interface config on the switch and the router below:

interface G 2/0

no ip address

interface G 2/0.1

encapsulation dot1Q 1 native

no ip address

interface G 2/0.2

encapsulation dot1Q 2

ip address 10.0.9.13 255.255.255.0

interface Ethernet 2/0.11

encapsulation dot1Q 11

ip address 7.8.6.9 255.255.255.248

on the Switch

int g0/2

Switch mode trunk encapsulation dot1q

Switchport mode trunk

Switch mode trunk allowed vlans 1,2,5,11

We could send any traffic from the router if the vlan is defined as the native vlan. So through the trunk, I cannot send any tagged frames through the trunk.

We even changed the MTU size down to 1492 and 1480 on the router interface.

I am wondering what is missing here. can some 1 give me some inputs on this plz.

thanks

subra

3 REPLIES
New Member

Re: Dot1q & Cisco 3745

A couple of thoughts,

The NM-16ESW is a switchport module, and therefore would work as a trunk port with the same configs as your 3550, and creating the vlan interfaces on the 3745.

I think the issue with your config is that the ESW module ports are switchport by default, and the configuration you have is designed for a router port. I would put the command "no switchport" on the int G2/0, and that will probably make your config work.

Hope this helps,

Rob

New Member

Re: Dot1q & Cisco 3745

Thanks for the quick response. Let me try and post the feedback.

WR

subra

Purple

Re: Dot1q & Cisco 3745

On the router end get rid of the subinterfaces .

1. Create layer 2 vlans

at the command prompt enter vlan database

vlan 5 ,enter

vlan 2,enter

vlan 11 enter

exit

2. create layer 3 SVI's

conf t

interface vlan 2

ip address 10.0.9.13 255.255.255.0

interface vlan 5

ip address x.x.x.x

int vlan 11

ip address 7.8.6.9 255.255.255.248

Note: Not sure what this is , if its a misprint or what . You cannot combine a standard ethernet interface that is trunked with the switch config and make it work. Must put all 3 on the switch config.

REMOVE:interface Ethernet 2/0.11

Int g2/0

description 3550 uplink

switchport mode trunk

switchport trunk encapsulation dot1q ---> may not need this if this is the only encapsulation supported on 16ESW .

switchport trunk allowed 1,2,5,1

2459
Views
0
Helpful
3
Replies
CreatePlease to create content