cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3218
Views
5
Helpful
4
Replies

DSCP Mark EIGRP Traffic

jad.sadek
Level 1
Level 1

Hi all,

I have the requirement of DSCP marking EIGRP traffic from CS6 to AF31. I tried to use local-policy routing as per the following:

!

ip access-l extended EIGRP

permit eigrp any any

!

route-map LOCAL

match ip address EIGRP

set iop TOS|DSCP

!

ip local policy route-map LOCAL

!

The problem is that I don't have the option of setting DSCP marking in the route-map. Setting the precedence doesn't help in my case and the TOS option doen't reflect the TOS field of the IP header. Following is an extract from the documentation for using 'set ip tos'

=============================================================================================================

Usage Guidelines

This command allows you to set four bits in the ToS byte header. Table 35 shows the format of the four bits in binary form.

Table 35 ToS Bits and Description

T3

T2

T1

T0

Description

0

0

0

0

0 normal forwarding

0

0

0

1

1 minimum monetary cost

0

0

1

0

2 maximum reliability

0

1

0

0

4 maximum throughput

1

0

0

0

8 minimum delay

The T3 bit sets the delay. Setting T3 to 0 equals normal delay, and setting it to 1 equals low delay.

The T2 bit sets the throughput. Setting this bit to 0 equals normal throughput, and setting it to 1 equals maximum throughput. Similarly, the T1 and T0 bits set reliability and cost, respectively. Therefore, as an example, if you want to set a packet with the following requirements:

minimum delay T3 = 1

normal throughput T2 = 0

normal reliability T1 = 0

minimum monetary cost T0 = 1

=============================================================================================================

Using COPP doesn't allow as well setting the QOS marking.

Any suggestions or other options for DSCP marking EIGRP traffic.

Thanks,
Jad

1 Accepted Solution

Accepted Solutions

cadet alain
VIP Alumni
VIP Alumni

Hi,

Use MQC marking:

example:

access-list 100 permit eigrp any any

class-map EIGRP_TRAFFIC

match access-group 100

policy-map EIGRP_POLICY

class EIGRP_TRAFFIC

set dscp af31

interface x/x

service-policy out  EIGRP_POLICY

Regards.

Alain

Don't forget to rate helpful posts.

View solution in original post

4 Replies 4

cadet alain
VIP Alumni
VIP Alumni

Hi,

Use MQC marking:

example:

access-list 100 permit eigrp any any

class-map EIGRP_TRAFFIC

match access-group 100

policy-map EIGRP_POLICY

class EIGRP_TRAFFIC

set dscp af31

interface x/x

service-policy out  EIGRP_POLICY

Regards.

Alain

Don't forget to rate helpful posts.

Hi Alain,

EIGRP traffic is an Originating traffing and not a transiting traffic and thus it cannot be matched at the interface level.

Jad

Hi,

just tested it on GNS3 and it works.

Regards.

Alain.

Don't forget to rate helpful posts.

You are absolutely right Alain,

I didn't even try it :)... I was convinced that it is an originating traffic and will not match in QOS.

Thanks

Review Cisco Networking products for a $25 gift card