Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DSCP QoS/TOS not getting marked on outgoing packets.

Please see the attached doc to look at my config.

We are implementing QoS over an MPLS cloud and have configured a 3660 at our corporate office (see attached)

The traffic is being matched to the ACL and NBARs, but the outgoing packets are not getting marked with DSCP headers.

Anyone have any ideas on what I am doing wrong?

THANKS!

4 REPLIES

Re: DSCP QoS/TOS not getting marked on outgoing packets.

You may have claimed too much bandwidth.

"To successfully attach a policy map to an interface or a VC, the aggregate of the configured minimum bandwidths of the classes comprising the policy map must be less than or equal to 75 percent of the interface bandwidth or the bandwidth allocated to the VC."

Please check the command reference:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_command_reference_chapter09186a0080080786.html#wp1037551

Regards,

Leo

New Member

Re: DSCP QoS/TOS not getting marked on outgoing packets.

But the "max-reserve-bandwidth 100" command allows more than the default 75% bandwidth per interface.

Like I said, I have the exact same config on a 1720 at a remote site and it works fine with the "bandwidth percent 80" in the class COS2.

Any other ideas?

Silver

Re: DSCP QoS/TOS not getting marked on outgoing packets.

Hi

I'm not sure you are doing wrong, but can you try to mark on incoming interface, somtething like this.

class-map match-any COS2

match access-group name COS2-Traffic

match protocol citrix

class-map match-any GOLD

match ip dscp 26

!

policy-map OUT

class GOLD

bandwidth percent 80

class class-default

fair-queue

policy-map COS

class COS2

set ip dscp 26

class class-default

set ip dscp 0

interface Serial1/0

service-policy input COS

service-policy output OUT

Regards

Mike

Re: DSCP QoS/TOS not getting marked on outgoing packets.

Hello,

to my knowledge you should bind the service-policy to the PVC and not to the main interface. Can you try this configuration:

interface Serial1/1

bandwidth 1536

no ip address

encapsulation frame-relay IETF

frame-relay traffic-shaping

ip route-cache flow

tx-ring-limit 1

tx-queue-limit 1

max-reserved-bandwidth 100

interface Serial1/1.1 point-to-point

description ePVC to IPFR

ip address x.x.x.x 255.255.255.0

no cdp enable

frame-relay interface-dlci 100

class FRpol

map-class frame-relay FRpol

frame-relay cir 1500000

frame-relay mincir 1500000

frame-relay fair-queue

service-policy output COS

Hope this helps! Please rate all posts.

Regards, Martin

169
Views
2
Helpful
4
Replies
CreatePlease login to create content