Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Member

DSL MODEM TO CISCO 1905 CONNECTION WITH MAC ENCAPSULATION ROUTING

I have to connect my Beetel DSL Router which is provided by the ISP to Cisco 1905 router. I tried to bridge the modem and configure the router with staic ip, but the problem is that the DSL Router is using the network protocol for IP over ethernet as MAC Encapsulation routing. How will i configure this in cisco router? And there is a TR-69 configuration in DSL, do i need to do anything with that? Please help me out with a sample configuration. Thanks in advance !!!

Please use the below screenshot for reference.

wan.jpg

Regards, Tony http://yadhutony.blogspot.com
Everyone's tags (1)
4 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

DSL MODEM TO CISCO 1905 CONNECTION WITH MAC ENCAPSULATION ROUTIN

Hello Tony,

First of all I hope I have not misspelled your first name - sorry if I did.

the problem is that the DSL Router is using the network protocol for IP over ethernet as MAC Encapsulation routing

I do not understand this statement. Can you elaborate on this further please?

And there is a TR-69 configuration in DSL, do i need to do anything with that?

For the time being, no, you should not change it. Let's hope your provider won't be continuously reconfiguring your device back to routed mode. In any case, you should ask your ISP if you can reconfigure your modem to your needs, just to be on the safe side.

Best regards,

Peter

Cisco Employee

DSL MODEM TO CISCO 1905 CONNECTION WITH MAC ENCAPSULATION ROUTIN

Hello Tony,

The "MER" beast is something I have to learn more about. I am not leaving the thread, I just need some more time to get my head around it. I will keep you posted as soon as I have new information - hopefully in a few hours.

In the meantime, would other connection types work with your provider, in particular the PPPoE or PPPoA? That would make things somewhat easier.

Oh, and one more thing. While I did not get all details about the MER yet, it seems to me that it should allow you to connect the Cisco to the Beetel with a completely common IP configuration on its Ethernet interface, like an ordinary PC. What are your requirements on this connection - what do you need to do exactly that the Beetel cannot provide you currently? It would be helpful to know what you are actually trying to achieve, apart from having the Cisco router successfully connected to the internet.

Best regards,

Peter

Cisco Employee

DSL MODEM TO CISCO 1905 CONNECTION WITH MAC ENCAPSULATION ROUTIN

Hi Tony,

Sorry for chiming in lately.

Alright, first of all, about the MER. After looking for a description extensively, it turns out that the MER is a rather strange way of sending IP packets through ATM circuits in DSL using RFC 1483/2684 bridged encapsulation even though the IP packet is normally encapsulated using routed encapsulation.

http://www.abusar.org.br/ftp/Efficient_CLI.pdf

According to this document, IP packets in MER are encapsulated according to RFC 1483/2684 using LLC of 0xAA-AA-03, SNAP OUI 0x00-80-C2, SNAP PID 0x00-07 and the PAD field set to 0x00-00. Then the IP packet follows. No PPP is involved in this encapsulation. In other words, IP is carried over the ATM as if it was a frame, not a packet (if it was carried in RFC 1483/2684 routed mode, the encapulation would use LLC of 0xAA-AA-03, SNAP OUI 0x00-00-00, PID of 0x0800 and then the IP packet would follow). The only advantage of using the MER is, in my humble opinion, the ability to carry both IP and bridged (i.e. non-routed) protocols over the same ATM circuit. Otherwise, I find this MER stuff quite quirky.

But enough of nagging. I am personally thinking of setting your DSL modem to a fully bridged mode and running the PPPoE client on your Cisco router, so that the PPPoE session would start on your Cisco, simply traverse the DSL modem, go through the DSL and terminate at your ISP. The DSL modem would be reduced to a device that merely carries the data from and to the DSL line. Are you fine with that? You would, however, need to obtain PPP login credentials from your ISP.

Best regards,

Peter

Cisco Employee

Re: DSL MODEM TO CISCO 1905 CONNECTION WITH MAC ENCAPSULATION RO

Hello Tony,

The VPDN configuration is not the correct approach here. Please let me simply show you the commands how I would configure the PPPoE client on a clean router, and please feel free to adapt it to your particular needs. However, do not use the various "no ip ..." you originally indicated. They are not appropriate for your configuration and could lead to decreased routing performance of your Cisco router.

int gi0/0

description ADSL LAN Interface

ip address 172.17.0.1 255.255.0.0

ip nat inside

no shutdown

int gi0/1

description ADSL WAN Interface

pppoe-client dial-pool-number 1

no shutdown

int Dialer0

encapsulation ppp

dialer pool 1

ip address negotiated

ppp chap hostname YOUR_CHAP_LOGIN

ppp chap password YOUR_CHAP_PASSWORD

ip mtu 1492

ip tcp adjust-mss 1452

ip nat outside

ip route 0.0.0.0 0.0.0.0 dialer0

access-list 10 permit 172.17.0.0 0.0.255.255

ip nat inside source list 10 int dialer0 overload

Please keep me informed if this configuration worked for you, and I suggest also posting your entire configuration after applying these changes so that I can have an overview of what exactly is configured.

Best regards,

Peter

9 REPLIES
Cisco Employee

DSL MODEM TO CISCO 1905 CONNECTION WITH MAC ENCAPSULATION ROUTIN

Hello Tony,

First of all I hope I have not misspelled your first name - sorry if I did.

the problem is that the DSL Router is using the network protocol for IP over ethernet as MAC Encapsulation routing

I do not understand this statement. Can you elaborate on this further please?

And there is a TR-69 configuration in DSL, do i need to do anything with that?

For the time being, no, you should not change it. Let's hope your provider won't be continuously reconfiguring your device back to routed mode. In any case, you should ask your ISP if you can reconfigure your modem to your needs, just to be on the safe side.

Best regards,

Peter

New Member

DSL MODEM TO CISCO 1905 CONNECTION WITH MAC ENCAPSULATION ROUTIN

Hi Peter,

The connection type is MER. Please find the below screenshot :

Please help me.

Regards, Tony http://yadhutony.blogspot.com
Cisco Employee

DSL MODEM TO CISCO 1905 CONNECTION WITH MAC ENCAPSULATION ROUTIN

Hello Tony,

The "MER" beast is something I have to learn more about. I am not leaving the thread, I just need some more time to get my head around it. I will keep you posted as soon as I have new information - hopefully in a few hours.

In the meantime, would other connection types work with your provider, in particular the PPPoE or PPPoA? That would make things somewhat easier.

Oh, and one more thing. While I did not get all details about the MER yet, it seems to me that it should allow you to connect the Cisco to the Beetel with a completely common IP configuration on its Ethernet interface, like an ordinary PC. What are your requirements on this connection - what do you need to do exactly that the Beetel cannot provide you currently? It would be helpful to know what you are actually trying to achieve, apart from having the Cisco router successfully connected to the internet.

Best regards,

Peter

New Member

DSL MODEM TO CISCO 1905 CONNECTION WITH MAC ENCAPSULATION ROUTIN

Hi Peter,

Thanks for your reply. PPP0E and PPPoA works well with my provider. The only thing is i have to get a PPPoE username & password from ISP.

Well my actual reuirement is to configure firewall in the cisco router and to share the internet with another location. We would like to add the content filteing also in the near future.

Hope you will help me out to solve my issue soon.

Regards,

Tony

Regards, Tony http://yadhutony.blogspot.com
Cisco Employee

DSL MODEM TO CISCO 1905 CONNECTION WITH MAC ENCAPSULATION ROUTIN

Hi Tony,

Sorry for chiming in lately.

Alright, first of all, about the MER. After looking for a description extensively, it turns out that the MER is a rather strange way of sending IP packets through ATM circuits in DSL using RFC 1483/2684 bridged encapsulation even though the IP packet is normally encapsulated using routed encapsulation.

http://www.abusar.org.br/ftp/Efficient_CLI.pdf

According to this document, IP packets in MER are encapsulated according to RFC 1483/2684 using LLC of 0xAA-AA-03, SNAP OUI 0x00-80-C2, SNAP PID 0x00-07 and the PAD field set to 0x00-00. Then the IP packet follows. No PPP is involved in this encapsulation. In other words, IP is carried over the ATM as if it was a frame, not a packet (if it was carried in RFC 1483/2684 routed mode, the encapulation would use LLC of 0xAA-AA-03, SNAP OUI 0x00-00-00, PID of 0x0800 and then the IP packet would follow). The only advantage of using the MER is, in my humble opinion, the ability to carry both IP and bridged (i.e. non-routed) protocols over the same ATM circuit. Otherwise, I find this MER stuff quite quirky.

But enough of nagging. I am personally thinking of setting your DSL modem to a fully bridged mode and running the PPPoE client on your Cisco router, so that the PPPoE session would start on your Cisco, simply traverse the DSL modem, go through the DSL and terminate at your ISP. The DSL modem would be reduced to a device that merely carries the data from and to the DSL line. Are you fine with that? You would, however, need to obtain PPP login credentials from your ISP.

Best regards,

Peter

New Member

DSL MODEM TO CISCO 1905 CONNECTION WITH MAC ENCAPSULATION ROUTIN

Hi Peter,

Thank you so much for your reply. It helped me to find out a solution.

Regards,

Tony 

Regards, Tony http://yadhutony.blogspot.com
New Member

DSL MODEM TO CISCO 1905 CONNECTION WITH MAC ENCAPSULATION ROUTIN

Hi Peter,

I met with a problem again. I got the pppoe credentials from ISP and started doing the configuration. But the problem is that my Cisco 1905 doesn't seems to support pppoe. Is there any parallel way to do the configuration? Please find the configuration details that i tried to carry out:

 

router(config)#vpdn enable
router(config)#vpdn-group 1
router(config-vpdn)#request-dialin
router(config-vpdn)#protocol pppoe
router(config-vpdn)#exit

router(config)#interface gi0/1
router(config-if)#description ADSL WAN Interface
router(config-if)#no ip address
router(config-if)#no ip redirects
router(config-if)#no ip unreachables
router(config-if)#no ip proxy-arp
router(config-if)#no ip mroute-cache
router(config-if)#pppoe enable
router(config-if)#no cdp enable
router(config-if)#exit

router(config)#interface Dialer1
router(config-if)#description ADSL WAN Dialer
router(config-if)#ip address xxxxx yyyyyy
router(config-if)#no ip unreachables
router(config-if)#ip nat outside
router(config-if)#encapsulation ppp
router(config-if)#no ip mroute-cache
router(config-if)#dialer pool 1
router(config-if)#dialer-group 1
router(config-if)#no cdp enable

router(config-if)#ppp authentication chap pap callin
router(config-if)#ppp chap hostname xxxxx

router(config-if)#ppp chap password xxxxx
router(config-if)#ppp pap sent-username xxxxx password xxxx

router(config-if)#exit

router(config)#dialer-list 1 protocol ip permit

router(config)#interface Dialer1
router(config-if)#ip mtu 1492
router(config-if)#ip tcp adjust-mss 1452
router(config-if)#exit

router(config)#interface gi0/0
router(config-if)#description ADSL LAN Interface

router(config-if)#ip address 172.17.0.1 255.255.0.0
router(config-if)#no ip redirects
router(config-if)#no ip unreachables
router(config-if)#no ip proxy-arp
router(config-if)#ip nat inside
router(config-if)#no ip mroute-cache
router(config-if)#no cdp enable
router(config-if)#exit

router(config)#access-list 10 permit 172.17.0.0 0.0.255.255

router(config)#no cdp run

router(config)#ip nat inside source list 10 interface Dialer1 overload

router(config)#ip classless

router(config)#interface Dialer1
router(config-if)#shutdown
router(config-if)#ppp ipcp route default
router(config-if)#no shutdown
router(config-if)#exit

router(config)#ip route 0.0.0.0 0.0.0.0 Dialer1

Hope you will help me.

Regards,

Tony

Regards, Tony http://yadhutony.blogspot.com
Cisco Employee

Re: DSL MODEM TO CISCO 1905 CONNECTION WITH MAC ENCAPSULATION RO

Hello Tony,

The VPDN configuration is not the correct approach here. Please let me simply show you the commands how I would configure the PPPoE client on a clean router, and please feel free to adapt it to your particular needs. However, do not use the various "no ip ..." you originally indicated. They are not appropriate for your configuration and could lead to decreased routing performance of your Cisco router.

int gi0/0

description ADSL LAN Interface

ip address 172.17.0.1 255.255.0.0

ip nat inside

no shutdown

int gi0/1

description ADSL WAN Interface

pppoe-client dial-pool-number 1

no shutdown

int Dialer0

encapsulation ppp

dialer pool 1

ip address negotiated

ppp chap hostname YOUR_CHAP_LOGIN

ppp chap password YOUR_CHAP_PASSWORD

ip mtu 1492

ip tcp adjust-mss 1452

ip nat outside

ip route 0.0.0.0 0.0.0.0 dialer0

access-list 10 permit 172.17.0.0 0.0.255.255

ip nat inside source list 10 int dialer0 overload

Please keep me informed if this configuration worked for you, and I suggest also posting your entire configuration after applying these changes so that I can have an overview of what exactly is configured.

Best regards,

Peter

New Member

DSL MODEM TO CISCO 1905 CONNECTION WITH MAC ENCAPSULATION ROUTIN

Hi Peter,

Sorry for the late reply. I was out of office for a week.

By the way i have done the configuration in normal way[modem in fully bridged mode] and it worked out  without the pppoe credentials and MER configuration.

Anyway thank you so much for your help.

Plz find the configuration details:


Building configuration...

Current configuration : 5779 bytes
!
! Last configuration change at 16:07:59 UTC Thu Jun 28 2012 by xxxx
! NVRAM config last updated at 15:43:47 UTC Thu Jun 28 2012 by xxxx
! NVRAM config last updated at 15:43:47 UTC Thu Jun 28 2012 by xxxx
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
security passwords min-length 6
no logging buffered
enable secret 5 1$vwasdfaf7#$%ssd
!
no aaa new-model
!
!
no ipv6 cef
ip source-route
no ip gratuitous-arps
ip cef
!
!
!
!
!
ip name-server xxxxxxx
ip name-server xxxxxxx
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
!
!
!
username xxxxxx privilege 15 password 0 xxxx
!
redundancy
!
!
!
!
!
class-map type inspect match-any inspection-traffic
match protocol dns
match protocol ftp
match protocol https
match protocol icmp
match protocol imap
match protocol pop3
match protocol netshow
match protocol shell
match protocol realmedia
match protocol rtsp
match protocol smtp
match protocol sql-net
match protocol tftp
match protocol tcp
match protocol udp
match protocol l2tp
class-map type inspect match-all insp-traffic
match class-map inspection-traffic
class-map type inspect match-all http
match protocol http
class-map type inspect match-any icmp
match protocol icmp
match protocol tcp
match protocol udp
class-map type inspect match-all invalid-src
match access-group 100
class-map type inspect match-all icmp-access
match class-map tsq-icmp
!
!
policy-map type inspect SELF-TO-OUT-POLICY
class type inspect icmp-access
  inspect
class class-default
  pass
policy-map type inspect IN-TO-OUT-POLICY
class type inspect invalid-src
  drop log
class type inspect http
  inspect
class type inspect insp-traffic
  inspect
class class-default
  drop
policy-map type inspect OUT-TO-IN-POLICY
class class-default
  drop
!
zone security INSIDE
zone security OUTSIDE
zone-pair security OUT-TO-IN source OUTSIDE destination INSIDE
service-policy type inspect OUT-TO-IN-POLICY
zone-pair security IN-TO-OUT source INSIDE destination OUTSIDE
service-policy type inspect IN-TO-OUT-POLICY
zone-pair security SELF-TO-OUT source self destination OUTSIDE
service-policy type inspect SELF-TO-OUT-POLICY
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
ip mask-reply
ip directed-broadcast
shutdown
!
interface GigabitEthernet0/0
description LAN INTERFACE
ip address 172.17.0.71 255.255.0.0
ip nat inside
ip virtual-reassembly in
zone-member security INSIDE
duplex auto
speed auto
!
interface GigabitEthernet0/1
description WAN-INTERNET-INTERFACE
ip address xxxx yyyy
ip nat outside
ip virtual-reassembly in
zone-member security OUTSIDE
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
ip mask-reply
ip directed-broadcast
shutdown
no fair-queue
clock rate 2000000
!
ip forward-protocol nd
!
no ip http server
ip http authentication local
ip http secure-server
!
ip nat inside source list 1 interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 xxxx
!
access-list 1 permit 172.17.0.0 0.0.255.255
access-list 100 permit ip host 255.255.255.255 any
access-list 100 permit ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip xxxx yyyy any
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
privilege level 15
login local
transport input ssh
!
scheduler allocate 20000 1000
end

Regards,

Tony

Regards, Tony http://yadhutony.blogspot.com
2883
Views
0
Helpful
9
Replies
CreatePlease to create content