Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

DSL not able to connect

I have a block of static IP addresses given by my ISP. They say I should be able to assign a static IP address like the one below and be able to connect. However I am not. I also tried to change the static route to point to the DG and still no joy

The DG is 64.85.55.1

What am I doing wrong?

BLKLANSTR01#sh run

Building configuration...

Current configuration : 1092 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname BLKLANSTR01

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

!

!

ip source-route

!

!

!

!

ip cef

!

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

archive

log config

hidekeys

!

!

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

ip address 64.85.55.19 255.255.255.224

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface Vlan1

ip address 10.116.38.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

no ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 FastEthernet4

no ip http server

no ip http secure-server

!

!

ip nat inside source list 10 interface FastEthernet4 overload

!

access-list 10 permit 10.116.38.0 0.0.0.255

access-list 120 permit ip any any

!

!

!

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end

BLKLANSTR01#

1 REPLY
Hall of Fame Super Silver

Re: DSL not able to connect

Hello Brent,

a DSL line is an ATM interface from the point of view of a Cisco Router.

Here you are using an external box acting as DSL modem or router.

Your configuration could be fine if the the box acts as a bridge taking ethernet frames encapsulating them in ATM AAL5 PDUs and sending them over the DSL line.

But also the line has to be provisioned to accept this. (this is called RFC1483 bridged in contrast with RFC1483 routed where are IP packets to be sent in AAL% PDUs)

Ask your provider what they expect from you:

if it is IPv4 over ATM you need a DSL interface on the router and the ip address is then associated to the ATM / ADSL interface without using the external box. (RFC 1483 routed mode)

if is PPPoEoA you need to configure a PPPoE client on your router with the external box acting as an ethernet bridge.

Hope to help

Giuseppe

205
Views
0
Helpful
1
Replies
CreatePlease to create content