Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Dsl PPPoE without NAT

Hi need help to bridge dls interface and ethernernet interface so I will be able to use my public ip address on the LAN side og my router(Cisco 876).

The reason is that i have another router with a public ip address on the wan side so I would like the 876 to be a "gateway" for this router.

Se attacment for config

Hope someone could help me with this!

  • WAN Routing and Switching
6 REPLIES
Cisco Employee

Re: Dsl PPPoE without NAT

Hi,

I'm not sure to understand what you want to achieve. A drawing could help here.

Are both routers connected to the same LAN ? If you want your first router to use the 876 as its gateway, you could configure a default route on the first router.

Thanks

Laurent.

New Member

Re: Dsl PPPoE without NAT

Hi, thanks for your reply.

__________

| UC520 |

|__________|

|

WAN 80.xxx.xxx.154 255.255.255.252

|

|

Fe0 Fe1 Fe2 Fe3

| | | |

80.xxx.xxx.153

| | | |

______________________

| CISCO 876 |

|______________________|

|

Dsl Interface

|

|

|

ISP Static IP 80.xxx.xxx.153 PPPoE

|

|

I have two static (public)ip addresses 80.xxx.xxx.153 255.255.255.252 and 80.xxx.xxx.154 255.255.255.252

My ISP delivered a Thomson Speedtouch router who was configurated like the drawing. I have replaced the Thomson router with the 876. The problem is that I got it to work with NAT, but I would like it not to be NATed. Bridged between Dsl interface and BVI1 or Fe0.

Hall of Fame Super Gold

Re: Dsl PPPoE without NAT

It would almost better to keep the cheap modem, bridging an ADSL interface isn't worth a cisco router :)

Anyway,

interface atm x/x/y.zz point-to-point

pvc z z

brige-group 1

interface vlan1

brige-group 1

You can also give an IP address to VLAN interface one side, FA0 on UC520. This to manage the 876.

Note, you should work with a reputable cisco partner on cases like these. He would resolve most problem immediately and save you a lot of head scratching.

Cisco Employee

Re: Dsl PPPoE without NAT

Hi,

I don't think it's achievable with PPPoE.

You need to implement RFC1483 and IRB or configuring the 876 as a true bridge and start the PPPoE session directly from UC520.

You will have plenty of examples at the following link:

http://www.cisco.com/en/US/tech/tk175/tk15/tech_configuration_examples_list.html

HTH

Laurent.

Hall of Fame Super Gold

Re: Dsl PPPoE without NAT

That is what the OP asked for, and I've indicated a short config about.

New Member

Re: Dsl PPPoE without NAT

Yes, I know it's old but I had a similar issue this week with my new connection.  I used ip unnumbered.

Hopefully this will be of use to others too.

Try something like:

This is for a connecting a Cisco 877w to BT's new FTTC service but should work on any Cisco router supporting vlans with a relatively recent IOS version.

PPPoE assigned /27 from ISP. I'm using IP unnumbered to allow the rest of the pool to be split between NAT and real addressing.

3 subnets/vlans: 1 internal wired (1), 1 wlan (5), 1 DMZ/external (87)
NAT/PAT pool for some internal addresses, static NAT for others.
A small /29 DMZ subnet for when NAT is undesirable.
Fast Ethernet 1 runs as a trunk for all vlans except vlan 5 (wlan)
Fast Ethernet 3 is connected to the VDSL modem

DHCP Server for the 3 vlans
I've got some other internal routers connected and using OSPF.


!!!!This is not a complete config!!!!!!
!!!!Add security etc. Before use!!!!!!!

!
!
ip dhcp excluded-address 192.168.5.254
ip dhcp excluded-address a.b.c.126
ip dhcp excluded-address 192.168.6.254
!
ip dhcp pool wlan5
   network 192.168.5.0 255.255.255.0
   domain-name
   default-router 192.168.5.254
   dns-server 192.168.6.133 208.67.222.222 208.67.220.220
   lease 7
!
ip dhcp pool lan
   network 192.168.6.0 255.255.255.0
   domain-name
   default-router 192.168.6.254
   dns-server 192.168.6.133 208.67.222.222 208.67.220.220
   lease 7
!
ip dhcp pool dmz
   network a.b.c.120 255.255.255.248
   domain-name
   default-router a.b.c.126
   dns-server 195.74.113.58 195.74.113.62 208.67.222.222 208.67.220.220
   lease 3
!
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pppoe
!
interface FastEthernet0
duplex full
speed 100
!
interface FastEthernet1
switchport trunk allowed vlan 1-4,6-4094
switchport mode trunk
duplex full
speed 100
!
interface FastEthernet2
duplex full
speed 100
!
interface FastEthernet3
switchport access vlan 87
duplex full
speed 100
!
interface Dot11Radio0
ip address 192.168.5.254 255.255.255.0
ip pim sparse-dense-mode
ip nat inside
ip virtual-reassembly
!
interface Vlan1
ip address 192.168.1.254 255.255.255.0 secondary
ip address 192.168.6.254 255.255.255.0
ip pim sparse-dense-mode
ip nat inside
ip virtual-reassembly
load-interval 30
!
interface Vlan87
description DMZ fttc WAN
ip address a.b.c.126 255.255.255.224
ip nat outside
ip virtual-reassembly
ip tcp adjust-mss 1452
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer1
ip unnumbered Vlan87
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
load-interval 30
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname
ppp chap password 7
ppp ipcp dns request
!
router ospf 1
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 192.168.5.0 0.0.0.255 area 0
network 192.168.6.0 0.0.0.255 area 0
default-information originate
!
ip nat pool myisp a.b.c.108 a.b.c.116 prefix-length 27
ip nat inside source list nat-allow pool myisp overload
ip nat inside source static 192.168.6.133 a.b.c.97 extendable
ip nat inside source static tcp 192.168.6.201 22 a.b.c.98 62022 extendable
ip nat inside source static tcp 192.168.5.253 80 a.b.c.98 80 extendable
!
ip access-list extended nat-allow
permit ip 192.168.0.0 0.0.15.255 any
!
access-list 100 permit ip 192.168.0.0 0.0.15.255 any
!
dialer-list 1 protocol ip list 100
!
route-map myisp permit 10
match ip address 100
match interface Dialer1
!
!

1458
Views
0
Helpful
6
Replies
This widget could not be displayed.