Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Dual Homing using BGP

Hi,

We have 2 ISP's and have our IP space.

We would like to do load sharing between the 2 ISP's.

For Incoming traffic, can we advertise our IP range through both the ISP's without any preference attribute. The Internet Community based on peering of ISP1 and ISP2 with other service providers shall decide the incoming traffic based on the geographical orientation of the ISPs across the Internet.

Please let me know whether this is possible?

-Sai

2 REPLIES

Re: Dual Homing using BGP

Hello,

this is possible for sure. Do you have your own official AS number? If not, then the config gets somewhat more tricky.

In case you have an official AS number the config could look like this:

interface Ethernet0/1

description to ISP1

ip address 1.4.x.x.x.255.252

interface Ethernet0/2

description to ISP2

ip address 2.2.x.x.x.255.252

router bgp 65000

network 1.1.0.0 mask 255.255.0.0

neighbor 1.4.5.1 remote-as 1 ! ISP1

neighbor 1.4.5.1 prefix-list NoTrash in

neighbor 1.4.5.1 filter-list 1 out

neighbor 1.4.5.1 weight 150

neighbor 2.2.2.1 remote-as 2 ! ISP2

neighbor 2.2.2.1 prefix-list NoTrash in

neighbor 2.2.2.1 filter-list 1 out

neighbor 2.2.2.1 weight 100

no auto-summary

ip as-path access-list 1 permit ^$

ip prefix-list NoTrash deny 192.168.0.0/16 le 32

ip prefix-list NoTrash deny 172.16.0.0/12 le 32

ip prefix-list NoTrash deny 10.0.0.0/8 le 32

ip prefix-list NoTrash deny 1.1.0.0/16 le 32

ip prefix-list NoTrash permit 0.0.0.0/0 le 32

ip route 1.1.x.x.255.0.0 Null 0 250

This would not announce only the assigned IP addresses (assumed 1.1.0.0/16) to ISP1 and ISP2, i.e. it prevents that you become transit AS between them. Also all RFC1918 routes are blocked. You could extend this and use the BOGON list for filtering, but this would require more maintainance, because you have to adjust the filters from time to time. For a customer it should be sufficient to block all routes you potentially have internally.

You need to adjust IP addresses, AS numbers and prefix to your environment.

In this example ISP1 is primary and ISP2 is backup (selected through weight). In case you want to have a more flexible selection you should use an incoming route-map to set f.e. Local Preference.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: Dual Homing using BGP

Hi Martin,

We have our own AS number. Also on the interface facing the LAN we might have to use PBR for VPN traffic, what say?

-Sai.

169
Views
5
Helpful
2
Replies
CreatePlease login to create content