Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Dual T1 Point to Point Configuration on Cisco 2610

Greetings,

I was wondering if anyone out there can help me with a supposed to be "very simple" Point to Point MLPPP router configuration. Currently we have two of our branches connected using one P2P T1 provided by AT&T, and now we have installed two new T1 lines provided by TDS to replace the AT&T T1.

We are planning to bundle two new T1 line provided by TDS to increase the bandwidth within branches.

The scenario is that, all the interfaces show that they are up and active but no packet goes across. Also, when I manually shutdown one interface on one side router logically on the other end interface should go down too but that is not happening.

I have attached both routers configuration below:

Main_to_Ells#show config

Using 1409 out of 29688 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Main_to_Ells

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$67dJ$r2sWrP4OIBn9rjH4U/3ln1

enable password ********

!

clock timezone ES -5

no aaa new-model

ip subnet-zero

ip cef

!

!

ip name-server 10.31.1.180

!

no ip bootp server

!

!

!

controller T1 0/0

framing esf

clock source line primary

linecode b8zs

channel-group 1 timeslots 1-24 speed 64

!

controller T1 0/1

framing esf

linecode b8zs

channel-group 1 timeslots 1-24 speed 64

!

!

!

interface Multilink1

ip address 10.31.100.22 255.255.255.252

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

!

interface Ethernet0/0

description connected to local subnet 10.31.1.X

ip address 10.31.1.2 255.255.255.0

ip route-cache flow

full-duplex

!

interface Serial0/0:1

no ip address

encapsulation ppp

ip route-cache flow

tx-ring-limit 26

tx-queue-limit 26

no fair-queue

ppp multilink

ppp multilink group 1

!

interface Serial0/1:1

no ip address

encapsulation ppp

ip route-cache flow

tx-ring-limit 26

tx-queue-limit 26

no keepalive

no fair-queue

ppp multilink

ppp multilink group 1

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 10.31.1.1

ip route 10.31.6.0 255.255.255.0 10.31.100.21

!

!

!

line con 0

login

line aux 0

line vty 0 4

password *******

login

!

!

end

------------

Main_to_Ells#show config

Using 1409 out of 29688 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Main_to_Ells

!

boot-start-marker

boot-end-marker

clock timezone ES -5

no aaa new-model

ip subnet-zero

ip cef

!

!

ip name-server 10.31.1.180

!

no ip bootp server

!

!

!

controller T1 0/0

framing esf

clock source line primary

linecode b8zs

channel-group 1 timeslots 1-24 speed 64

!

controller T1 0/1

framing esf

linecode b8zs

channel-group 1 timeslots 1-24 speed 64

!

!

!

interface Multilink1

ip address 10.31.100.22 255.255.255.252

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

!

interface Ethernet0/0

description connected to local subnet 10.31.1.X

ip address 10.31.1.2 255.255.255.0

ip route-cache flow

full-duplex

!

interface Serial0/0:1

no ip address

encapsulation ppp

ip route-cache flow

tx-ring-limit 26

tx-queue-limit 26

no fair-queue

ppp multilink

ppp multilink group 1

!

interface Serial0/1:1

no ip address

encapsulation ppp

ip route-cache flow

tx-ring-limit 26

tx-queue-limit 26

no keepalive

no fair-queue

ppp multilink

ppp multilink group 1

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 10.31.1.1

ip route 10.31.6.0 255.255.255.0 10.31.100.21

!

!

!

line con 0

login

line aux 0

line vty 0 4

login

end

9 REPLIES

Re: Dual T1 Point to Point Configuration on Cisco 2610

Your post shows the config for the same router twice. Can you post the other side's config?

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Dual T1 Point to Point Configuration on Cisco 2610

Opps... here you go the second router configuration thank for looking into this matter:

Ellsworth-R#show config

Using 1458 out of 29688 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Ellsworth-R

!

boot-start-marker

boot-end-marker

!

!

clock timezone ES -5

no aaa new-model

ip subnet-zero

ip cef

!

!

ip name-server 10.31.1.180

!

no ip bootp server

!

!

!

controller T1 0/0

framing esf

linecode b8zs

channel-group 1 timeslots 1-24 speed 64

!

controller T1 0/1

framing esf

linecode b8zs

channel-group 1 timeslots 1-24 speed 64

!

!

!

interface Multilink1

ip address 10.31.100.21 255.255.255.252

ppp multilink

ppp multilink fragment disable

ppp multilink group 1

!

interface Ethernet0/0

description connected to local subnet 10.31.1.X

ip address 10.31.6.2 255.255.255.0

ip route-cache flow

full-duplex

!

interface Serial0/0:1

no ip address

encapsulation ppp

ip route-cache flow

tx-ring-limit 26

tx-queue-limit 26

no keepalive

no fair-queue

ppp multilink

ppp multilink group 1

!

interface Serial0/1:1

no ip address

encapsulation ppp

ip route-cache flow

tx-ring-limit 26

tx-queue-limit 26

no keepalive

no fair-queue

ppp multilink

ppp multilink group 1

!

no ip http server

ip classless

ip route 0.0.0.0 255.255.255.0 10.31.100.22

!

!

access-list 100 permit ip any any dscp cs7

access-list 101 permit ip any any dscp cs6

priority-list 1 protocol ip high list 100

!

line con 0

login

line aux 0

line vty 0 4

exec-timeout 30 0

login

!

!

end

Ellsworth-R#

---------------Ellsworth-R#show ver

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-I-M), Version 12.3(26), RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by cisco Systems, Inc.

Compiled Mon 17-Mar-08 15:23 by dchih

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

Ellsworth-R uptime is 2 days, 15 hours, 24 minutes

System returned to ROM by power-on

System image file is "flash:c2600-i-mz.123-26.bin"

cisco 2610 (MPC860) processor (revision 0x202) with 28672K/4096K bytes of memory

.

Processor board ID JAD03341259 (683390826)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

Primary Rate ISDN software, Version 1.1.

1 Ethernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

2 Channelized T1/PRI port(s)

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Re: Dual T1 Point to Point Configuration on Cisco 2610

I agree with what the previous poster put. Put the "keepalive" option back on the interfaces for the time being. With "no keepalive" the interfaces don't send keepalive packets, and it makes it look like the interface is always up.

Secondly, also as the other poster mentioned, the provider has to provision your circuit for multilink in order for multilink to work. I had this problem at one point to.

Thirdly, can you ping any of the following:

10.31.1.1 from Main_to_Ells

10.31.100.21 from Main_to_Ells

10.31.100.22 from Ellsworth

Also, you could post the output from "sho controll t1" and we can see if you have any errors.

Can you also post "sh int | inc CRC|line"

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Dual T1 Point to Point Configuration on Cisco 2610

Thanks for your imputs

here the result of pings:

Main_to_Ells#ping 10.31.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.31.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Main_to_Ells#ping 10.31.100.21

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.31.100.21, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Main_to_Ells#ping 10.31.100.22

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.31.100.22, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms

Main_to_Ells#

----------

Main_to_Ells#sh int | inc CRC|line

Ethernet0/0 is up, line protocol is up

98 input errors, 98 CRC, 49 frame, 0 overrun, 0 ignored

Serial0/0:1 is up, line protocol is up

2160 input errors, 676 CRC, 1468 frame, 0 overrun, 2 ignored, 16 abort

Serial0/1:1 is up, line protocol is up

71782 input errors, 4583 CRC, 32857 frame, 0 overrun, 62 ignored, 34342 abort

Multilink1 is up, line protocol is up

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

Main_to_Ells#

------------ on the second router

Ellsworth-R#sh int | inc CRC|line

Ethernet0/0 is up, line protocol is up

4 input errors, 4 CRC, 0 frame, 0 overrun, 0 ignored

Serial0/0:1 is up, line protocol is up

33145699 input errors, 1081539 CRC, 32064154 frame, 0 overrun, 198 ignored,

6 abort

Serial0/1:1 is up, line protocol is up

32925807 input errors, 1030437 CRC, 31895364 frame, 0 overrun, 217 ignored,

6 abort

Multilink1 is up, line protocol is up

87 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

Ellsworth-R#

Also, I'm on the phone with TDS to make sure that the T1s are provisioned properly

Thank you very much,

Silver

Re: Dual T1 Point to Point Configuration on Cisco 2610

It looks like you have "no keepalive" set on the s0/1:1 interfaces on both sides. With this setting it will look like the interface is UP UP when it may not be.

Other than that, I'd check with the Service Provider to ensure that the circuits are configured for MLPPP. We ran into some issues where the carrier did not order the circuits for this purpose.

New Member

Re: Dual T1 Point to Point Configuration on Cisco 2610

Is this how it supposed to be?

Ethernet0/0 is up, line protocol is up

Hardware is AmdP2, address is 0007.856c.4d40 (bia 0007.856c.4d40)

Description: connected to local subnet 10.31.1.X

Internet address is 10.31.1.2/24

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/2/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 6000 bits/sec, 9 packets/sec

5 minute output rate 0 bits/sec, 1 packets/sec

1978713 packets input, 162893269 bytes, 0 no buffer

Received 1966803 broadcasts, 0 runts, 0 giants, 0 throttles

98 input errors, 98 CRC, 49 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

42478 packets output, 4343603 bytes, 0 underruns

0 output errors, 0 collisions, 3 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

Serial0/0:1 is up, line protocol is up

Hardware is PowerQUICC Serial

MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, LCP Open, multilink Open, loopback not set

Keepalive set (60 sec)

Last input 00:01:14, output 00:00:04, output hang never

Last clearing of "show interface" counters 3d01h

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

29297 packets input, 1287902 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 4 giants, 0 throttles

2160 input errors, 676 CRC, 1468 frame, 0 overrun, 2 ignored, 16 abort

29306 packets output, 1287776 bytes, 0 underruns

0 output errors, 0 collisions, 13 interface resets

0 output buffer failures, 0 output buffers swapped out

9 carrier transitions

Timeslot(s) Used:1-24, SCC: 1, Transmitter delay is 0 flags

Serial0/1:1 is up, line protocol is up

Hardware is PowerQUICC Serial

MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, LCP Open, multilink Open, loopback not set

Keepalive set (60 sec)

Last input 00:00:19, output 00:00:09, output hang never

Last clearing of "show interface" counters 3d01h

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

29299 packets input, 1287630 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 1 giants, 0 throttles

71782 input errors, 4583 CRC, 32857 frame, 0 overrun, 62 ignored, 34342 abort

29301 packets output, 1288034 bytes, 0 underruns

0 output errors, 0 collisions, 3 interface resets

0 output buffer failures, 0 output buffers swapped out

9 carrier transitions

Timeslot(s) Used:1-24, SCC: 2, Transmitter delay is 0 flags

----------------

Not working yet though !!!

Thanks for any help,

Re: Dual T1 Point to Point Configuration on Cisco 2610

You have a lot of CRC errors on both links. This is usually due to the clock source. Your clock source should (most of the time) be set to line if you're getting timing from the provider.

Post "sho controllers t1" and we can tell what it's clock source is.

John

HTH, John *** Please rate all useful posts ***
New Member

Re: Dual T1 Point to Point Configuration on Cisco 2610

here are the results for both routers:

Main_to_Ells#sh controllers t1

T1 0/0 is up.

Applique type is Channelized T1

Cablelength is long gain36 0db

No alarms detected.

alarm-trigger is not set

Soaking time: 3, Clearance time: 10

AIS State:Clear LOS State:Clear LOF State:Clear

Version info Firmware: 20070320, FPGA: 20, spm_count = 0

Framing is ESF, Line Code is B8ZS, Clock Source is Line Primary.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (267 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 24 hours)

0 Line Code Violations, 0 Path Code Violations,

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

T1 0/1 is up.

Applique type is Channelized T1

Cablelength is long gain36 0db

No alarms detected.

alarm-trigger is not set

Soaking time: 3, Clearance time: 10

AIS State:Clear LOS State:Clear LOF State:Clear

Version info Firmware: 20070320, FPGA: 20, spm_count = 0

Framing is ESF, Line Code is B8ZS, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (268 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 24 hours)

0 Line Code Violations, 0 Path Code Violations,

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Main_to_Ells#

--------------

Ellsworth-R#sh controllers t1

T1 0/0 is up.

Applique type is Channelized T1

Cablelength is long gain36 0db

No alarms detected.

alarm-trigger is not set

Soaking time: 3, Clearance time: 10

AIS State:Clear LOS State:Clear LOF State:Clear

Version info Firmware: 20070320, FPGA: 20, spm_count = 0

Framing is ESF, Line Code is B8ZS, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (36 seconds elapsed):

0 Line Code Violations, 439 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

1 Errored Secs, 1 Bursty Err Secs, 9 Severely Err Secs, 0 Unavail Secs

Total Data (last 24 hours)

55 Line Code Violations, 962763 Path Code Violations,

882 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 950 Degraded Mins,

2411 Errored Secs, 1799 Bursty Err Secs, 17178 Severely Err Secs, 0 Unavail

Secs

T1 0/1 is up.

Applique type is Channelized T1

Cablelength is long gain36 0db

No alarms detected.

alarm-trigger is not set

Soaking time: 3, Clearance time: 10

AIS State:Clear LOS State:Clear LOF State:Clear

Version info Firmware: 20070320, FPGA: 20, spm_count = 0

Framing is ESF, Line Code is B8ZS, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (39 seconds elapsed):

0 Line Code Violations, 401 Path Code Violations

35 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

30 Errored Secs, 1 Bursty Err Secs, 7 Severely Err Secs, 0 Unavail Secs

Total Data (last 24 hours)

35 Line Code Violations, 960752 Path Code Violations,

79031 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 927 Degraded Mins,

63173 Errored Secs, 1605 Bursty Err Secs, 17203 Severely Err Secs, 0 Unavai

l Secs

Ellsworth-R#

Silver

Re: Dual T1 Point to Point Configuration on Cisco 2610

The output of Show Controllers shows massive Path Code Violations incrementing on the Ellsworth circuits. I'd clear counters and monitor them, check physical connectivity, then verify the configuration with my carrier. Have the carrier test both circuits.

939
Views
0
Helpful
9
Replies