Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Dual Want Policy Based Routing Problem

Hello!

I have configured 1700 series router to forward workstation traffic through one port and the voice through another. The Configuration is pretty straight forward, but we experience a major problems. When the SIP phones plugged in to the switch with pass through to the computers, we loose connections to PBX or Internet and it's not consistent, it's flapping in uneven amount of time. I can work all day and then just stop working with no clear cause. It does happened when only phones are connected to integrated switch alone. Completely makes no sense.

When this occurs i can go the router and can ping everhing but NAT translation is just stop working, which is the reson to lost connections.

here is the config:

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname cartergeer

!

boot-start-marker

warm-reboot

boot-end-marker

!

no aaa new-model

!

!

dot11 syslog

!

!

ip cef

no ip dhcp use vrf connected

no ip dhcp conflict logging

ip dhcp excluded-address 192.168.1.1 192.168.1.10

!

ip dhcp pool PC-SUBNET

   import all

   network 192.168.1.0 255.255.255.0

   dns-server 7.228.35.42 7.228.37.195 8.8.8.8

   domain-name greatbasin.net

   default-router 192.168.1.1

!

!

ip domain name greatbasin.net

ip name-server 7.228.35.42

ip name-server 7.228.37.195

ip name-server 8.8.8.8

!

multilink bundle-name authenticated

!

!

!

!

archive  

log config

  hidekeys

!

!

!

!

!

interface FastEthernet0

description WAN1

ip address 7.228.13.165 255.255.255.252

ip nat outside

ip virtual-reassembly

no ip mroute-cache

duplex auto

speed auto

!

interface FastEthernet1

decription WAN2

ip address 7.228.13.169 255.255.255.252

ip nat outside

ip virtual-reassembly

no ip mroute-cache

duplex auto

speed auto

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface FastEthernet9

!

interface Dot11Radio0

no ip address

shutdown

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!        

interface Dot11Radio1

no ip address

shutdown

speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0

station-role root

!

interface Vlan1

description LOCAL-LAN

ip address 192.168.2.1 255.255.255.0 secondary

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip policy route-map LAN-TO-WAN

!

interface Async1

no ip address

encapsulation slip

!

no ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 FastEthernet0

ip route 0.0.0.0 0.0.0.0 FastEthernet1

!

!

no ip http server

no ip http secure-server

ip nat inside source list 101 interface FastEthernet0 overload

ip nat inside source list 102 interface FastEthernet1 overload

!

access-list 101 permit ip 192.168.1.0 0.0.0.255 any

access-list 102 permit ip 192.168.2.0 0.0.0.255 any

!

!

!

route-map LAN-TO-WAN permit 10

description PC-SUBNET-NAT

match ip address 101

set interface FastEthernet0

!

route-map LAN-TO-WAN permit 20

description VOICE-SUBNET-NAT

match ip address 102

set interface FastEthernet1

!

!

!        

!

control-plane

!

!

line con 0

exec-timeout 0 0

logging synchronous

line 1

modem InOut

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

end

2 REPLIES
Purple

Dual Want Policy Based Routing Problem

Hi,

You should modify your config like this:

no ip nat inside source list 101 interface FastEthernet0 overload

no ip nat inside source list 102 interface FastEthernet1 overload

no route-map LAN-TO-WAN

route-map LAN-TO-WAN permit 10

match ip address 101

set ip next-hop x.x.x.x

route-map LAN-TO-WAN permit 20

match ip address 102

set ip next-hop y.y.y.y

route-map NAT-To-WAN1

match ip address 101

match interface f0

route-map NAT-To-WAN2

match ip address 102

match interface f1

ip nat inside source route-map NAT-To-WAN1 interface FastEthernet0 overload

ip nat inside sourceroute-map NAT-To-WAN2  interface FastEthernet1 overload

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Dual Want Policy Based Routing Problem

Cadet first of all thank you for your response and work! =) I did made  the changes that you proposed and applied them today and I will test  them for the few days and will report back. But, what is the difference  in my approach vs yours for the NAT?

214
Views
0
Helpful
2
Replies