Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Dumb device can't talk over MULTILINK PPP WAN link

I've got several remote locations with Verifone credit card machines (network based, not serial). When my links are setup like this, the machines work fine:

interface GigabitEthernet0/0.1

encapsulation dot1Q 123

ip address 10.1.xx.xx 255.255.255.0

ip helper-address 10.1.xx.xx

!

interface GigabitEthernet0/0.2

encapsulation dot1Q 223

ip address 10.2.xx.xx 255.255.255.0

ip access-group 121 in

ip helper-address 10.1.xx.xx

!

interface GigabitEthernet0/0.3

encapsulation dot1Q 323

ip address 10.3.xx.xx 255.255.255.0

ip pim sparse-mode

!

interface GigabitEthernet0/0.4

encapsulation dot1Q 423

ip address 10.4.xx.xx 255.255.255.0

ip access-group 120 in

!

interface GigabitEthernet0/1

ip address dhcp

shutdown

duplex auto

speed auto

media-type rj45

!

interface Serial0/1/0

ip unnumbered GigabitEthernet0/0.1

ip pim sparse-mode

service-policy output Serial-Policy

load-interval 30

!

interface Serial0/2/0

ip unnumbered GigabitEthernet0/0.1

ip pim sparse-mode

service-policy output Serial-Policy

load-interval 30

Everyone I've talked to says I should be using multilink PPP, but when I do, the credit card machine can't connect out through the WAN. Every other device works fine, PC's, IP Phones, etc. Just not the credit card machine. Here is the config with PPP:

interface Multilink 1

ip unnumbered GigabitEthernet0/0.1

ip pim sparse-mode

service-policy output Serial-Policy

ppp multilink

ppp multilink group 1

interface GigabitEthernet0/0.1

encapsulation dot1Q 123

ip address 10.1.xx.xx 255.255.255.0

ip helper-address 10.1.xx.xx

!

interface GigabitEthernet0/0.2

encapsulation dot1Q 223

ip address 10.2.xx.xx 255.255.255.0

ip access-group 121 in

ip helper-address 10.1.xx.xx

!

interface GigabitEthernet0/0.3

encapsulation dot1Q 323

ip address 10.3.xx.xx 255.255.255.0

ip pim sparse-mode

!

interface GigabitEthernet0/0.4

encapsulation dot1Q 423

ip address 10.4.xx.xx 255.255.255.0

ip access-group 120 in

!

interface GigabitEthernet0/1

ip address dhcp

shutdown

duplex auto

speed auto

media-type rj45

!

interface Serial0/1/0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

!

interface Serial0/2/0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

Again, every other device works fine, just not the credit card machine. I had to switch the config back and the CC machine started working again. I control both sides of the WAN link. I've tried "ppp multilink fragment disable" and that didn't help. Should I be using a loopback interface for the common IP address? Any ideas or suggestions?

6 REPLIES

Re: Dumb device can't talk over MULTILINK PPP WAN link

If enabling multilink breaks connectivity for one application it sounds like a possible MTU issue. Try lowering the MTU to 1450 on the interface or use 'ip tcp adjust-mss 1450' if it's a TCP application and see if that helps.

HTH

Sundar

New Member

Re: Dumb device can't talk over MULTILINK PPP WAN link

Which interface, the multilink or the serial interfaces?

Re: Dumb device can't talk over MULTILINK PPP WAN link

It shouldn't matter but try it on the multilink interface.

New Member

Re: Dumb device can't talk over MULTILINK PPP WAN link

I tried setting the MTU on the interface as well as doing ip tcp mss 1450 and neither helped the situation.

Re: Dumb device can't talk over MULTILINK PPP WAN link

You may have to run some debugs to see why the traffic fails. You may be able to find something with debug ppp multilink data or events. As with any debugs, exercise caution and run the debugs during during a maintenance window.

HTH

Sundar

Bronze

Re: Dumb device can't talk over MULTILINK PPP WAN link

Please see this link and turn on transparent bridging... I have used this in the past to solve these issues specifically!

http://www.cisco.com/en/US/tech/tk331/tk660/technologies_tech_note09186a0080094471.shtml

Let me know if this works.

267
Views
0
Helpful
6
Replies
CreatePlease to create content