Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Dynamic bandwidth division on serial

I' m trying to set some bandwidth division rules to divide dinamically the bandwith

between 2 lan.

I mean if one of the lan doesn't use his assigned bandwith or part of it, the other Lan can use also the free part of bandwith.

I have to apply this in INPUT and OUTPUT. Wath Have i to use?

Can any help, plz?

18 REPLIES

Re: Dynamic bandwidth division on serial

Hi there,

You need to use QoS on the link. Depending on how much you want each lan to have, I would opt for something like "bandwidth percent 50" in the policy map, or even "priority percent 50" check out this link for more details:-

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos_c/fqcprt8/qcfmcli2.htm

Regards,

LH

Please rate all posts

New Member

Re: Dynamic bandwidth division on serial

Thx very useful guide but I' m not understending one thing.

If I apply a policy on the serial I can set only the output direction (not the input one), but i want to limit either download and upload from internet.

How can I do that?

thx

Re: Dynamic bandwidth division on serial

Hi there,

Best thing to do is also apply the policy outbound on the ethernet interface too, so that it can only go at a certain speed through the router either way.

Regards,

LH

Please rate all posts

New Member

Re: Dynamic bandwidth division on serial

thx here the conf I' ve created.....

conf t

access-list 110 remark "Lan1serialOUT"

access-list 110 permit ip 192.168.180.0 0.0.0.255 any

access-list 110 permit ip 192.168.99.128 0.0.0.127 any

access-list 120 remark "Lan2serialOUT"

access-list 120 permit ip 192.168.99.0 0.0.0.127 any

class-map match-all Lan1

match access-group 110

class-map match-all Lan2

match access-group 120

policy-map OUT

class Lan1

police 1100000 206000 250000 conform-action transmit exceed-action drop

exit

class Lan2

police 700000 100000 150000 conform-action transmit exceed-action drop

exit

class class-default

fair-queue 20

exit

int serial 1/0

service-policy output OUT

...........

Now im not understanding wath I have to apply on ethernet and fastethernet

int eth 0/0

int fa 2/0

Have I to set these access lists for the 2 interfaces?

access-list 130 remark "ethernetOUT"

access-list 130 permit ip any 192.168.180.0 0.0.0.255

access-list 130 permit ip any 192.168.99.128 0.0.0.127

access-list 140 remark "fastethernetOUT"

access-list 140 permit ip any 192.168.99.0 0.0.0.127

Have I to consider the inbound traffic from internet or wath?

thx in advance!

Re: Dynamic bandwidth division on serial

Hi there,

You need to think about the flow of traffic for the access lists. If you got:-

1.x.x.x ---- router ---- 2.x.x.x

For one way you need to specify traffic going TO 2.x.x.x and the other way you need to specify traffic coming FROM 2.x.x.x

Regards,

LH

Please rate all posts

New Member

Re: Dynamic bandwidth division on serial

Have I to apply both "incoming" ACL and "outgoing" ACL as service-policy output?

Re: Dynamic bandwidth division on serial

Create 2 policy maps. One for incoming traffic and one for out going traffic. Then apply the relevant on to the interface. You'll need 2 access lists per range, TO and FROM, so that'll mean 2 class maps per range too.

Regards,

LH

Please rate all posts

New Member

Re: Dynamic bandwidth division on serial

I'm not understanding how to apply these policies, couse router doesnt accept any policy in input on the serial.

plz, follow this example....

class-map match-all Lan1OUT

match access-group 110

class-map match-all Lan2OUT

match access-group 120

class-map match-all Lan1IN

match access-group 130

class-map match-all Lan2IN

match access-group 140

policy-map serialOUT

class Lan1OUT

bandwidth percent 40

exit

class Lan2OUT

bandwidth percent 35

exit

policy-map serialIN

class Lan1IN

bandwidth percent 40

exit

class Lan2IN

bandwidth percent 35

exit

int s 1/0

service-policy output serialOUT

(this works)

service-policy input serialIN

(doesnt appare in running-config)

where have I to apply serialIN rules?

Re: Dynamic bandwidth division on serial

Hello again,

The serialIN policy should work on the inbound traffic if you are policing. If it's not working, then you can apply it on the interface that the traffic uses to go out of, usualyy an ethernet connection.

Regards,

LH

Please rate all posts

New Member

Re: Dynamic bandwidth division on serial

ok thx i'll try .....

New Member

Re: Dynamic bandwidth division on serial

Only one other thing...I think this can work well 4 TCP traffic, but I' m not so sure 4 UDP one...

Re: Dynamic bandwidth division on serial

Hi there,

What bits of UDP traffic are you trying to match?

Regards

LH

Please rate all posts

New Member

Re: Dynamic bandwidth division on serial

Well, i want to limit udp traffic too..

serial output policy---R---ethernet output policy

if i'll apply these policies TCP will be limited in input on the serial by the windowing but UDP got none, so i was thinking, wath will happen 4 UDP traffic?

Re: Dynamic bandwidth division on serial

Hi there,

You simply have to specify the traffic with either an access list in the class map or use nbar. The same as you would for TCP.

Regards,

LH

Please rate all posts

New Member

Re: Dynamic bandwidth division on serial

THX

Wath u mean 4 nbar?

New Member

Re: Dynamic bandwidth division on serial

Wath u think about this conf ?

conf t

access-list 110 remark "Lan1serialOUT"

access-list 110 permit ip 192.168.180.0 0.0.0.255 any

access-list 110 permit ip 192.168.99.128 0.0.0.127 any

access-list 120 remark "Lan2serialOUT"

access-list 120 permit ip 192.168.99.0 0.0.0.127 any

access-list 130 remark "ethernetOUT"

access-list 130 permit ip any 192.168.180.0 0.0.0.255

access-list 130 permit ip any 192.168.99.128 0.0.0.127

access-list 140 remark "fastethernetOUT"

access-list 140 permit ip any 192.168.99.0 0.0.0.127

class-map match-all Lan1

match access-group 110

class-map match-all Lan2

match access-group 120

class-map match-all ethOUT

match access-group 130

class-map match-all faOUT

match access-group 140

policy-map serialOUT

class Lan1

bandwidth percent 55

exit

class Lan2

bandwidth percent 35

exit

class class-default

fair-queue 20

exit

policy-map ethOUT

class ethOUT

police 1100000 206000 250000 conform-action transmit exceed-action drop

exit

policy-map faOUT

class faOUT

police 700000 100000 150000 conform-action transmit exceed-action drop

exit

int serial 1/0

service-policy output serialOUT

max-reserved-bandwidth 90

int eth 0/0

service-policy output ethOUT

int fa 2/0

service-policy output faOUT

Re: Dynamic bandwidth division on serial

Hey there,

That looks very good to me. When it's applied you can issue "show policy-map" to see how many much use each is having.

NBAR is "Network Based Application Recognition" you use it for things like "match protocol http" etc..

Regards,

LH

Please rate all posts

New Member

Re: Dynamic bandwidth division on serial

thx very mutch I hope this will work well ;-)

165
Views
29
Helpful
18
Replies
CreatePlease login to create content