Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

dynamic ip configuration

Hello!

I have a Cisco 827 that I it want to use for my connection to Internet in house.

I have tried several configurations but I have not managed to connect to Internet.

I don?t have static ip, my ip is dynamic.

This is my configuration:

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname gorka

!

enable secret xxx

enable password ++++++++!

ip subnet-zero

no ip routing

!

!

!

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

no ip route-cache

bridge-group 1

hold-queue 100 out

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

pvc 8/32

encapsulation aal5snap

!

dsl operating-mode auto

bridge-group 1

!

ip classless

ip http server

ip pim bidir-enable

!

!

!

snmp-server community public RO

bridge 1 protocol ieee

!

line con 0

stopbits 1

line vty 0 4

password ++++++++

login

!

scheduler max-task-time 5000

end

Do I need a dialer?

Thanks.

  • WAN Routing and Switching
5 REPLIES

Re: dynamic ip configuration

hi

You can refer the config samples stated in the below link for Cisco 827 routers.

http://www.cisco.com/en/US/products/hw/routers/ps380/prod_configuration_examples_list.html

regds

Re: dynamic ip configuration

Hi,

Hope you don't mind if i jump in with some more specific info here.

It appears that you do not have dialer interface setup to negotiate ppp paramaters with you ISP.

Try the config below. you need to get the PVC settings from your ISP and the encapsulation type.

!

interface ATM0

no ip address

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

no shut

!

interface ATM0.1 point-to-point

pvc 8/32

pppoe-client dial-pool-number 1

no shut

!

!

interface Dialer0

ip address negotiated

ip mtu 1452

ip nat outside

encapsulation ppp

dialer pool 1

ppp authentication chap callin

ppp chap hostname ISPUSERNAME

ppp chap password ISPPASSWORD

no shut

!

the ip address negotiated command will give the dialer interface an IP address from you ISP. to check it do a 'sh int dialer 0'.

Load this configuration into your router and watch in dialer 0 to see if it gets an ip address.

Let me know how this goes.

Remember - please rate all posts :)

Cheers

Stephen

========================== http://www.rconfig.com A free, open source network device configuration management tool, customizable to your needs! - Always vote on an answer if you found it helpful
New Member

Re: dynamic ip configuration

Hi,

noticed this in your config:

no ip routing !!!

Re: dynamic ip configuration

Hi,

Just noticed another thing thank to the last guy.

enable ip routing

create a static route point all traffic out dialer0

i.e. ip route 0.0.0.0 0.0.0.0 dialer0

also enable nat as follows

Int e0

ip nat inside

!

dialer 0

ip nat outside

!

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

you need to do this to allow all PC's/hosts inside your router access to the internet.

Thanks... Pls Rate all posts

Stephen

========================== http://www.rconfig.com A free, open source network device configuration management tool, customizable to your needs! - Always vote on an answer if you found it helpful
New Member

Re: dynamic ip configuration

Hi Stephen!

I am sorry not to have answered before, but I have not seen the response.

At the moment i have this configuration:

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

!

ip subnet-zero

!

vpdn enable

!

vpdn-group pppoe

request-dialin

protocol pppoe

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

ip nat inside

hold-queue 100 out

!

interface ATM0

no ip address

no atm ilmi-keepalive

bundle-enable

dsl operating-mode auto

hold-queue 224 in

!

interface ATM0.1 point-to-point

pvc 8/32

pppoe-client dial-pool-number 1

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

ppp chap hostname adslppp@telefonicanetpa

ppp chap password 0 adslppp

!

ip nat inside source list 1 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

ip pim bidir-enable

!

!

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 1 deny any

!

line con 0

password indartsu99

stopbits 1

line vty 0

access-class 1 in

exec-timeout 120 0

password indartsu99

login

line vty 1 4

password indartsu99

login

!

scheduler max-task-time 5000

end

I have managed to go out to Internet but i can see only a few pages.

To the majority I do not go out.

If I remove the "acces list 1" I do not see any.

That interface affects? Do not I see any access-group in any interface?

Your mtu is different...

Can it be a safety problem?.

Doing a "show in eth0" I see that I have ip.

All interfaces are up.

I can do "ping" on the outside without problems from the pc and from the router.

Thanks.

Javier.

224
Views
5
Helpful
5
Replies