Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

dynamic NAT inside -> outside and static NAT outside -> inside on the same device

I have a single router that I'd like to perform source and destination NAT at the same time.

Possible?

I.e.

interface FastEthernet0

ip nat outside

ip add 10.1.1.1.255.255.255.0

!

interface FastEthernet1

ip nat inside

ip add 192.168.1.1 255.255.255.0

!

ip nat inside source route-map dynamic_nat_map interface FastEthernet0 overload

ip nat outside source static 10.100.1.24 192.168.2.24

ip route 172.16.0.0 255.240.0.0 192.168.1.2

ip access-list extended dynamic_nat_acl

permit ip 172.16.0.0 255.240.0.0 192.168.2.0 0.0.0.255

!

route-map dynamic_nat_map permit 10

match ip address dynamic_nat_acl

!

I'd like users on 172.16.0.0/12 connect to 10.100.1.24, but they must appear as 192.168.1.1 and 10.100.1.24 needs to appear to them as 192.168.2.24

Everyone's tags (6)
1 REPLY

Re: dynamic NAT inside -> outside and static NAT outside -> insi

Boris,

Where is the 172.16/12 ?

Where is the 10.100.1.x ?

536
Views
0
Helpful
1
Replies
CreatePlease to create content