Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

E1/T1 card connectivity back-to-back

Hi All,

I have two 2801 routers populated with VWIC-2MFT-T1/E1 card in each. I have configured routers using commands as below.

controller e1 0/2/0

framing no-CRC4

clock source internal

channel-group 0 timeslots 1-31

These commands brought a serial interface up dynamically which I have configured using the following commands.

interface Serial 0/2/0:0

ip address 192.168.100.1 255.255.255.0

bandwidth {bandwidth}

The above configuration is done on one of the router and the other router is configured in the same way except the ip address (i.e. the IP address on the other router is 192.168.100.2 255.255.255.0)

The intention is to connect the routers back-to-back and check the connectivity. By configuring the router in the above way, the Serial interface of both routers changes their status as well as Protocol to UP status. But still I am not able to ping the peer end router by logging into one of the router.

So, I tried to ping the serial interface of the router in which I was logged in. Strangely, I am not able to ping the local Serial interface itself.

Am I missing out any configuration? Any configuration example will also help.

Thanks,

Bhushan

7 REPLIES

Re: E1/T1 card connectivity back-to-back

Might sound stupid, but did you issue "no shutdown" on the Serial interfaces?

Also some show interface and show controller e1/t1 will help, if you post it here.

Hall of Fame Super Gold

Re: E1/T1 card connectivity back-to-back

Send:

show controllers E1

show interface x/y

show ip interface x/y

Note only ONE side must have clock source internal.

New Member

Re: E1/T1 card connectivity back-to-back

Hi,

The output for 'show commands' are attached along with this post. Thank you for the note, which I forgot mention in my initial post that the clock source internal has been configured on only one router.

On both routers, under interface serial 'no shutdown' command was issued.

I am not able to ping to peer end router and the local serial interface of router as well. It will be great if you can help out.

Thanks,

Bhushan

Re: E1/T1 card connectivity back-to-back

In your attached text file you have the output of one of the routers:

Router#show controller e1 0/2/0
E1 1/0 is up.
Applique type is Channelized E1 - balanced
No alarms detected.
alarm-trigger is not set
Version info Firmware: 20011109, FPGA: 15
Framing is CRC4, Line Code is HDB3, Clock Source is Line.

If on both routers you have exactly the same status, than it's not good. I hope that if you do the show controller e1... command on the other router is showing Clock Source is Internal. Does it?

Second, try to change the encapsulation to PPP, just to see if you still get the UP/UP status for the interfaces.

Hall of Fame Super Gold

Re: E1/T1 card connectivity back-to-back

If on both routers you have exactly the same status, than it's not good.
 I hope that if you do the show controller e1... command on the other 
router is showing Clock Source is Internal. Does it?

OP has stated already that is the case, please read above.

New Member

Re: E1/T1 card connectivity back-to-back

Hi,

I was trying to fix this problem from past few days, unfortunately with no success. Since I was doing the configuration of T1/E1 for the first time, it took some time.

While going through some of the documents, I have read about using RJ-48 cable for connecting T1/E1 cards on two routers back to back. So, following that document I have used a RJ-48 cable between 2 routers.

Two routers are configured in the following way after that.

RouterA

RouterA(config)#controller e1 0/1/0

RouterA(config-controller)#framing crc4

RouterA(config-controller)#linecode hdb3

RouterA(config-controller)#clock source internal

RouterA(config-controller)#channel-group 0 timeslots 1-31

RouterA(config)#interface serial 0/1/0:0

RouterA(config-if)#ip address 192.168.1.1 255.255.255.252

RouterA(config-if)#encapsulation ppp

RouterA(config-if)#no shut

RouterB

RouterB(config)#controller e1 0/1/0

RouterB(config-controller)#framing crc4

RouterB(config-controller)#linecode hdb3

RouterB(config-controller)#channel-group 0 timeslots 1-31

RouterB(config)#interface serial 0/1/0:0

RouterB(config-if)#ip address 192.168.1.2 255.255.255.252

RouterB(config-if)#encapsulation ppp

RouterB(config-if)#no shut

After doing these configurations, ping was successful between routers. I guess the problem was with 'framing' configuration under controller. In order to cross check, I have changed framing to no-crc4. It created the same problem again (not able to ping local serial interface as well as the peer end serial interface).

So, reverting back the 'framing' configuration to CRC4 worked fine.

For time being, the configuration is working fine. But I would like to understand the concept behind it so that it helps me in future.

Any how, I would like to thank you both for your timely help. Your guidance also helped me a lot to narrow down to possibilities for the problem encountered.

Hall of Fame Super Gold

Re: E1/T1 card connectivity back-to-back

That's strange, framing as long set congruently, should not affect operation.

2426
Views
0
Helpful
7
Replies
CreatePlease to create content