Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

eBGP Mesh - Redundancy failing

Hi all,

I've the following problem which I hope people can help me with. I've built a lab as proof of concept.

The topology is attached.

 

> There are 4 sites,  each site is connected via two separate VPLS networks. The aim is that as long as there is one active carrier in a site it can still reach every network.  

> Each site is advertising routes it has received and local routes.

 

For this scenario, 

Carrier A has dropped in Frankfurt

Carrier B has dropped in CIX

 

There are two problems with the current scenario. 

1.  All sites can see routes to each other, but can not ping each other.... based on best paths I believe this is due to asynchronous routing but am unsure how to correct without using redistributed statics

2.  I've split subnets to travel via a specific VPLS network based on local preference, my original thoughts were that if a carrier drops in a site it would move all traffic over the second VPLS network and reach the router that way. However it chooses a path with multiple hops.  I know local preference is preferred...so need to somehow make low hops the preferred. 

thank you for your help 

 

CIX sees 

CIX#sh ip bgp
BGP table version is 77, local router ID is 10.16.16.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  10.1.1.0/24      172.17.90.43                  150      0 65019 64912 i
*>                  172.17.90.42             0    150      0 64912 i
*  10.2.2.0/24      172.17.90.43                  150      0 65019 64912 i
*>                  172.17.90.42             0    150      0 64912 i
*  10.3.3.0/24      172.17.90.43                  150      0 65019 64912 i
*>                  172.17.90.42             0    150      0 64912 i
*> 10.4.4.0/24      0.0.0.0                  0         32768 i
*> 10.5.5.0/24      0.0.0.0                  0         32768 i
*> 10.6.6.0/24      0.0.0.0                  0         32768 i
*> 10.7.7.0/24      172.17.90.43             0    150      0 65019 i
*                   172.17.90.42                  150      0 64912 65019 i
*> 10.8.8.0/24      172.17.90.43             0    150      0 65019 i
*                   172.17.90.42                  150      0 64912 65019 i
*> 10.9.9.0/24      172.17.90.43             0    150      0 65019 i
*                   172.17.90.42                  150      0 64912 65019 i
*> 10.10.10.0/24    172.17.90.42                  150      0 64912 65025 i
*                   172.17.90.43                  150      0 65019 65025 i
   Network          Next Hop            Metric LocPrf Weight Path
*  10.11.11.0/24    172.17.90.43                  200      0 65019 64912 i
*>                  172.17.90.42             0    200      0 64912 i
*  10.12.12.0/24    172.17.90.43                  200      0 65019 64912 i
*>                  172.17.90.42             0    200      0 64912 i
*  10.13.13.0/24    172.17.90.43                  200      0 65019 64912 i
*>                  172.17.90.42             0    200      0 64912 i
*> 10.14.14.0/24    0.0.0.0                  0         32768 i
*> 10.15.15.0/24    0.0.0.0                  0         32768 i
*> 10.16.16.0/24    0.0.0.0                  0         32768 i
*> 10.17.17.0/24    172.17.90.43             0    200      0 65019 i
*                   172.17.90.42                  200      0 64912 65019 i
*> 10.18.18.0/24    172.17.90.43             0    200      0 65019 i
*                   172.17.90.42                  200      0 64912 65019 i
*> 10.19.19.0/24    172.17.90.43             0    200      0 65019 i
*                   172.17.90.42                  200      0 64912 65019 i
*  10.20.20.0/24    172.17.90.42                  200      0 64912 65019 65025 i
*>                  172.17.90.43                  200      0 65019 65025 i

Frankfurt sees


Frankfurt#sh ip bgp
BGP table version is 114, local router ID is 10.20.20.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.1.1.0/24      172.17.90.12             0    200      0 64912 i
*                   172.17.90.13                  200      0 65019 64912 i
*> 10.2.2.0/24      172.17.90.12             0    200      0 64912 i
*                   172.17.90.13                  200      0 65019 64912 i
*> 10.3.3.0/24      172.17.90.12             0    200      0 64912 i
*                   172.17.90.13                  200      0 65019 64912 i
*  10.4.4.0/24      172.17.90.12                  200      0 64912 65019 64911 i
*>                  172.17.90.13                  200      0 65019 64911 i
*  10.5.5.0/24      172.17.90.12                  200      0 64912 65019 64911 i
*>                  172.17.90.13                  200      0 65019 64911 i
*  10.6.6.0/24      172.17.90.12                  200      0 64912 65019 64911 i
*>                  172.17.90.13                  200      0 65019 64911 i
*  10.7.7.0/24      172.17.90.12                  200      0 64912 65019 i
*>                  172.17.90.13             0    200      0 65019 i
*  10.8.8.0/24      172.17.90.12                  200      0 64912 65019 i
*>                  172.17.90.13             0    200      0 65019 i
*  10.9.9.0/24      172.17.90.12                  200      0 64912 65019 i
   Network          Next Hop            Metric LocPrf Weight Path
*>                  172.17.90.13             0    200      0 65019 i
*> 10.10.10.0/24    0.0.0.0                  0         32768 i
*> 10.11.11.0/24    172.17.90.12             0    150      0 64912 i
*                   172.17.90.13                  150      0 65019 64912 i
*> 10.12.12.0/24    172.17.90.12             0    150      0 64912 i
*                   172.17.90.13                  150      0 65019 64912 i
*> 10.13.13.0/24    172.17.90.12             0    150      0 64912 i
*                   172.17.90.13                  150      0 65019 64912 i
*> 10.14.14.0/24    172.17.90.12                  150      0 64912 64911 i
*                   172.17.90.13                  150      0 65019 64911 i
*> 10.15.15.0/24    172.17.90.12                  150      0 64912 64911 i
*                   172.17.90.13                  150      0 65019 64911 i
*> 10.16.16.0/24    172.17.90.12                  150      0 64912 64911 i
*                   172.17.90.13                  150      0 65019 64911 i
*  10.17.17.0/24    172.17.90.12                  150      0 64912 65019 i
*>                  172.17.90.13             0    150      0 65019 i
*  10.18.18.0/24    172.17.90.12                  150      0 64912 65019 i
*>                  172.17.90.13             0    150      0 65019 i
*  10.19.19.0/24    172.17.90.12                  150      0 64912 65019 i
*>                  172.17.90.13             0    150      0 65019 i
*> 10.20.20.0/24    0.0.0.0                  0         32768 i

CLO sees

CLO#sh ip bgp
BGP table version is 80, local router ID is 10.13.13.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.1.1.0/24      0.0.0.0                  0         32768 i
*> 10.2.2.0/24      0.0.0.0                  0         32768 i
*> 10.3.3.0/24      0.0.0.0                  0         32768 i
*  10.4.4.0/24      172.17.90.15                  200      0 65025 65019 64911 i
*>                  172.17.90.13                  200      0 65019 64911 i
*                   172.17.90.43                  150      0 65019 64911 i
*                   172.17.90.41             0    150      0 64911 i
*  10.5.5.0/24      172.17.90.15                  200      0 65025 65019 64911 i
*>                  172.17.90.13                  200      0 65019 64911 i
*                   172.17.90.43                  150      0 65019 64911 i
*                   172.17.90.41             0    150      0 64911 i
*  10.6.6.0/24      172.17.90.15                  200      0 65025 65019 64911 i
*>                  172.17.90.13                  200      0 65019 64911 i
*                   172.17.90.43                  150      0 65019 64911 i
*                   172.17.90.41             0    150      0 64911 i
*  10.7.7.0/24      172.17.90.15                  200      0 65025 65019 i
*                   172.17.90.41                  150      0 64911 65019 i
   Network          Next Hop            Metric LocPrf Weight Path
*                   172.17.90.43             0    150      0 65019 i
*>                  172.17.90.13             0    200      0 65019 i
*  10.8.8.0/24      172.17.90.15                  200      0 65025 65019 i
*                   172.17.90.41                  150      0 64911 65019 i
*                   172.17.90.43             0    150      0 65019 i
*>                  172.17.90.13             0    200      0 65019 i
*  10.9.9.0/24      172.17.90.15                  200      0 65025 65019 i
*                   172.17.90.41                  150      0 64911 65019 i
*                   172.17.90.43             0    150      0 65019 i
*>                  172.17.90.13             0    200      0 65019 i
*> 10.10.10.0/24    172.17.90.15             0    200      0 65025 i
*                   172.17.90.43                  150      0 65019 65025 i
*                   172.17.90.13                  200      0 65019 65025 i
*> 10.11.11.0/24    0.0.0.0                  0         32768 i
*> 10.12.12.0/24    0.0.0.0                  0         32768 i
*> 10.13.13.0/24    0.0.0.0                  0         32768 i
*  10.14.14.0/24    172.17.90.43                  200      0 65019 64911 i
*                   172.17.90.13                  150      0 65019 64911 i
*>                  172.17.90.41             0    200      0 64911 i
*  10.15.15.0/24    172.17.90.43                  200      0 65019 64911 i
*                   172.17.90.13                  150      0 65019 64911 i
*>                  172.17.90.41             0    200      0 64911 i
   Network          Next Hop            Metric LocPrf Weight Path
*  10.16.16.0/24    172.17.90.43                  200      0 65019 64911 i
*                   172.17.90.13                  150      0 65019 64911 i
*>                  172.17.90.41             0    200      0 64911 i
*  10.17.17.0/24    172.17.90.15                  150      0 65025 65019 i
*                   172.17.90.41                  200      0 64911 65019 i
*>                  172.17.90.43             0    200      0 65019 i
*                   172.17.90.13             0    150      0 65019 i
*  10.18.18.0/24    172.17.90.15                  150      0 65025 65019 i
*                   172.17.90.41                  200      0 64911 65019 i
*>                  172.17.90.43             0    200      0 65019 i
*                   172.17.90.13             0    150      0 65019 i
*  10.19.19.0/24    172.17.90.15                  150      0 65025 65019 i
*                   172.17.90.41                  200      0 64911 65019 i
*>                  172.17.90.43             0    200      0 65019 i
*                   172.17.90.13             0    150      0 65019 i
*  10.20.20.0/24    172.17.90.41                  200      0 64911 65019 65025 i
*>                  172.17.90.43                  200      0 65019 65025 i
*                   172.17.90.13                  150      0 65019 65025 i
*                   172.17.90.15             0    150      0 65025 i
CLO#ping 20.20.20.1

London see

London#sh ip bgp
BGP table version is 123, local router ID is 10.19.19.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  10.1.1.0/24      172.17.90.15                  200      0 65025 64912 i
*                   172.17.90.41                  150      0 64911 64912 i
*                   172.17.90.42             0    150      0 64912 i
*>                  172.17.90.12             0    200      0 64912 i
*  10.2.2.0/24      172.17.90.15                  200      0 65025 64912 i
*                   172.17.90.41                  150      0 64911 64912 i
*                   172.17.90.42             0    150      0 64912 i
*>                  172.17.90.12             0    200      0 64912 i
*  10.3.3.0/24      172.17.90.15                  200      0 65025 64912 i
*                   172.17.90.41                  150      0 64911 64912 i
*                   172.17.90.42             0    150      0 64912 i
*>                  172.17.90.12             0    200      0 64912 i
*> 10.4.4.0/24      172.17.90.41             0    150      0 64911 i
*> 10.5.5.0/24      172.17.90.41             0    150      0 64911 i
*> 10.6.6.0/24      172.17.90.41             0    150      0 64911 i
*> 10.7.7.0/24      0.0.0.0                  0         32768 i
*> 10.8.8.0/24      0.0.0.0                  0         32768 i
   Network          Next Hop            Metric LocPrf Weight Path
*> 10.9.9.0/24      0.0.0.0                  0         32768 i
*  10.10.10.0/24    172.17.90.41                  150      0 64911 64912 65025 i
*>                  172.17.90.15             0    200      0 65025 i
*                   172.17.90.42                  150      0 64912 65025 i
*                   172.17.90.12                  200      0 64912 65025 i
*  10.11.11.0/24    172.17.90.41                  200      0 64911 64912 i
*                   172.17.90.15                  150      0 65025 64912 i
*>                  172.17.90.42             0    200      0 64912 i
*                   172.17.90.12             0    150      0 64912 i
*  10.12.12.0/24    172.17.90.41                  200      0 64911 64912 i
*                   172.17.90.15                  150      0 65025 64912 i
*>                  172.17.90.42             0    200      0 64912 i
*                   172.17.90.12             0    150      0 64912 i
*  10.13.13.0/24    172.17.90.41                  200      0 64911 64912 i
*                   172.17.90.15                  150      0 65025 64912 i
*>                  172.17.90.42             0    200      0 64912 i
*                   172.17.90.12             0    150      0 64912 i
*> 10.14.14.0/24    172.17.90.41             0    200      0 64911 i
*                   172.17.90.15                  150      0 65025 64912 64911 i
*                   172.17.90.42                  200      0 64912 64911 i
*                   172.17.90.12                  150      0 64912 64911 i
*> 10.15.15.0/24    172.17.90.41             0    200      0 64911 i
   Network          Next Hop            Metric LocPrf Weight Path
*                   172.17.90.15                  150      0 65025 64912 64911 i
*                   172.17.90.42                  200      0 64912 64911 i
*                   172.17.90.12                  150      0 64912 64911 i
*> 10.16.16.0/24    172.17.90.41             0    200      0 64911 i
*                   172.17.90.15                  150      0 65025 64912 64911 i
*                   172.17.90.42                  200      0 64912 64911 i
*                   172.17.90.12                  150      0 64912 64911 i
*> 10.17.17.0/24    0.0.0.0                  0         32768 i
*> 10.18.18.0/24    0.0.0.0                  0         32768 i
*> 10.19.19.0/24    0.0.0.0                  0         32768 i
*> 10.20.20.0/24    172.17.90.15             0    150      0 65025 i

 

Configs: CIX 

CIX#sh run
Building configuration...

Current configuration : 5104 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CIX
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
interface Loopback4
 ip address 10.4.4.1 255.255.255.0
!
interface Loopback5
 ip address 10.5.5.1 255.255.255.0
!
interface Loopback6
 ip address 10.6.6.1 255.255.255.0
!
interface Loopback14
 ip address 10.14.14.1 255.255.255.0
!
interface Loopback15
 ip address 10.15.15.1 255.255.255.0
!
interface Loopback16
 ip address 10.16.16.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.17.90.11 255.255.255.224
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.17.90.41 255.255.255.224
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router bgp 64911
 bgp log-neighbor-changes
 neighbor BT_VPLS peer-group
 neighbor BT_VPLS timers 6 20
 neighbor COLT_VPLS peer-group
 neighbor COLT_VPLS timers 6 20
 neighbor 172.17.90.12 remote-as 64912
 neighbor 172.17.90.12 peer-group BT_VPLS
 neighbor 172.17.90.12 description EBGP with CIXlonakilty
 neighbor 172.17.90.13 remote-as 65019
 neighbor 172.17.90.13 peer-group BT_VPLS
 neighbor 172.17.90.13 description EBGP with London
 neighbor 172.17.90.15 remote-as 65025
 neighbor 172.17.90.15 peer-group BT_VPLS
 neighbor 172.17.90.15 description EBGP with Frankfurt
 neighbor 172.17.90.42 remote-as 64912
 neighbor 172.17.90.42 peer-group COLT_VPLS
 neighbor 172.17.90.42 description EBGP with CIX
 neighbor 172.17.90.43 remote-as 65019
 neighbor 172.17.90.43 peer-group COLT_VPLS
 neighbor 172.17.90.43 description EBGP with London
 neighbor 172.17.90.45 remote-as 65025
 neighbor 172.17.90.45 peer-group COLT_VPLS
 neighbor 172.17.90.45 description EBGP with Frankfurt
 !
 address-family ipv4
  neighbor BT_VPLS next-hop-self
  neighbor BT_VPLS soft-reconfiguration inbound
  neighbor BT_VPLS route-map BT_VPLS_IN in
  neighbor BT_VPLS route-map BT_VPLS_OUT out
  neighbor COLT_VPLS next-hop-self
  neighbor COLT_VPLS soft-reconfiguration inbound
  neighbor COLT_VPLS route-map COLT_VPLS_IN in
  neighbor COLT_VPLS route-map COLT_VPLS_OUT out
  neighbor 172.17.90.12 activate
  neighbor 172.17.90.13 activate
  neighbor 172.17.90.15 activate
  neighbor 172.17.90.42 activate
  neighbor 172.17.90.43 activate
  neighbor 172.17.90.45 activate
  no auto-summary
  no synchronization
  network 10.4.4.0 mask 255.255.255.0
  network 10.5.5.0 mask 255.255.255.0
  network 10.6.6.0 mask 255.255.255.0
  network 10.14.14.0 mask 255.255.255.0
  network 10.15.15.0 mask 255.255.255.0
  network 10.16.16.0 mask 255.255.255.0
 exit-address-family
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
ip prefix-list BO_CIX_BT seq 10 permit 10.4.4.0/24
ip prefix-list BO_CIX_BT seq 20 permit 10.5.5.0/24
ip prefix-list BO_CIX_BT seq 30 permit 10.6.6.0/24
!
ip prefix-list BO_CIX_COLT seq 10 permit 10.14.14.0/24
ip prefix-list BO_CIX_COLT seq 20 permit 10.15.15.0/24
ip prefix-list BO_CIX_COLT seq 30 permit 10.16.16.0/24
!
ip prefix-list BT_VPLS_ROUTES seq 10 permit 10.1.1.0/24
ip prefix-list BT_VPLS_ROUTES seq 20 permit 10.2.2.0/24
ip prefix-list BT_VPLS_ROUTES seq 30 permit 10.3.3.0/24
ip prefix-list BT_VPLS_ROUTES seq 40 permit 10.7.7.0/24
ip prefix-list BT_VPLS_ROUTES seq 50 permit 10.8.8.0/24
ip prefix-list BT_VPLS_ROUTES seq 60 permit 10.9.9.0/24
ip prefix-list BT_VPLS_ROUTES seq 70 permit 10.10.10.0/24
!
ip prefix-list COLT_VPLS_ROUTES seq 10 permit 10.11.11.0/24
ip prefix-list COLT_VPLS_ROUTES seq 20 permit 10.12.12.0/24
ip prefix-list COLT_VPLS_ROUTES seq 30 permit 10.13.13.0/24
ip prefix-list COLT_VPLS_ROUTES seq 40 permit 10.17.17.0/24
ip prefix-list COLT_VPLS_ROUTES seq 50 permit 10.18.18.0/24
ip prefix-list COLT_VPLS_ROUTES seq 60 permit 10.19.19.0/24
ip prefix-list COLT_VPLS_ROUTES seq 70 permit 10.20.20.0/24
!
!
!
route-map BT_VPLS_IN permit 10
 match ip address prefix-list BT_VPLS_ROUTES
 set local-preference 200
!
route-map BT_VPLS_IN permit 20
 match ip address prefix-list COLT_VPLS_ROUTES
 set local-preference 150
!
route-map BT_VPLS_IN deny 30
 description block all other advertisements
!
route-map COLT_VPLS_IN permit 10
 match ip address prefix-list COLT_VPLS_ROUTES
 set local-preference 200
!
route-map COLT_VPLS_IN permit 20
 match ip address prefix-list BT_VPLS_ROUTES
 set local-preference 150
!
route-map COLT_VPLS_IN deny 30
 description block all other advertisements
!
route-map BT_VPLS_OUT permit 10
 match ip address prefix-list BO_CIX_COLT BO_CIX_BT BT_VPLS_ROUTES COLT_VPLS_ROUTES
!
route-map BT_VPLS_OUT deny 20
 description block all other advertisements
!
route-map COLT_VPLS_OUT permit 10
 match ip address prefix-list BO_CIX_COLT BO_CIX_BT COLT_VPLS_ROUTES BT_VPLS_ROUTES
!
route-map COLT_VPLS_OUT deny 20
 description block all other advertisements
!

Configs: Frankfurt

Frankfurt#sh run
Building configuration...

Current configuration : 4885 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Frankfurt
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback10
 ip address 10.10.10.1 255.255.255.0
!
interface Loopback20
 ip address 10.20.20.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.17.90.15 255.255.255.224
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.17.90.45 255.255.255.224
 shutdown
 duplex auto
 speed auto
!
router bgp 65025
 bgp log-neighbor-changes
 neighbor COLT_VPLS peer-group
 neighbor COLT_VPLS timers 6 20
 neighbor BT_VPLS peer-group
 neighbor BT_VPLS timers 6 20
 neighbor 172.17.90.11 remote-as 64911
 neighbor 172.17.90.11 peer-group BT_VPLS
 neighbor 172.17.90.11 description EBGP with CIX
 neighbor 172.17.90.12 remote-as 64912
 neighbor 172.17.90.12 peer-group BT_VPLS
 neighbor 172.17.90.12 description EBGP with CLO
 neighbor 172.17.90.13 remote-as 65019
 neighbor 172.17.90.13 peer-group BT_VPLS
 neighbor 172.17.90.13 description EBGP with London
 neighbor 172.17.90.41 remote-as 64911
 neighbor 172.17.90.41 peer-group COLT_VPLS
 neighbor 172.17.90.41 description EBGP with CIX
 neighbor 172.17.90.42 remote-as 64912
 neighbor 172.17.90.42 peer-group COLT_VPLS
 neighbor 172.17.90.42 description EBGP with CLO
 neighbor 172.17.90.43 remote-as 65019
 neighbor 172.17.90.43 peer-group COLT_VPLS
 neighbor 172.17.90.43 description EBGP with London
 maximum-paths 2
 !
 address-family ipv4
  neighbor COLT_VPLS next-hop-self
  neighbor COLT_VPLS soft-reconfiguration inbound
  neighbor COLT_VPLS route-map COLT_VPLS_IN in
  neighbor COLT_VPLS route-map COLT_VPLS_OUT out
  neighbor BT_VPLS next-hop-self
  neighbor BT_VPLS soft-reconfiguration inbound
  neighbor BT_VPLS route-map BT_VPLS_IN in
  neighbor BT_VPLS route-map BT_VPLS_OUT out
  neighbor 172.17.90.11 activate
  neighbor 172.17.90.12 activate
  neighbor 172.17.90.13 activate
  neighbor 172.17.90.41 activate
  neighbor 172.17.90.42 activate
  neighbor 172.17.90.43 activate
  maximum-paths 2
  no auto-summary
  no synchronization
  network 10.10.10.0 mask 255.255.255.0
  network 10.20.20.0 mask 255.255.255.0
 exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
ip prefix-list BO_FRA_BT seq 10 permit 10.10.10.0/24
!
ip prefix-list BO_FRA_COLT seq 10 permit 10.20.20.0/24
!
ip prefix-list BT_VPLS_ROUTES seq 10 permit 10.1.1.0/24
ip prefix-list BT_VPLS_ROUTES seq 20 permit 10.2.2.0/24
ip prefix-list BT_VPLS_ROUTES seq 30 permit 10.3.3.0/24
ip prefix-list BT_VPLS_ROUTES seq 40 permit 10.7.7.0/24
ip prefix-list BT_VPLS_ROUTES seq 50 permit 10.8.8.0/24
ip prefix-list BT_VPLS_ROUTES seq 60 permit 10.9.9.0/24
ip prefix-list BT_VPLS_ROUTES seq 70 permit 10.4.4.0/24
ip prefix-list BT_VPLS_ROUTES seq 80 permit 10.5.5.0/24
ip prefix-list BT_VPLS_ROUTES seq 90 permit 10.6.6.0/24
!
ip prefix-list COLT_VPLS_ROUTES seq 10 permit 10.11.11.0/24
ip prefix-list COLT_VPLS_ROUTES seq 20 permit 10.12.12.0/24
ip prefix-list COLT_VPLS_ROUTES seq 30 permit 10.13.13.0/24
ip prefix-list COLT_VPLS_ROUTES seq 40 permit 10.17.17.0/24
ip prefix-list COLT_VPLS_ROUTES seq 50 permit 10.18.18.0/24
ip prefix-list COLT_VPLS_ROUTES seq 60 permit 10.19.19.0/24
ip prefix-list COLT_VPLS_ROUTES seq 70 permit 10.14.14.0/24
ip prefix-list COLT_VPLS_ROUTES seq 80 permit 10.15.15.0/24
ip prefix-list COLT_VPLS_ROUTES seq 90 permit 10.16.16.0/24
!
!
!
route-map BT_VPLS_IN permit 10
 match ip address prefix-list BT_VPLS_ROUTES
 set local-preference 200
!
route-map BT_VPLS_IN permit 20
 match ip address prefix-list COLT_VPLS_ROUTES
 set local-preference 150
!
route-map BT_VPLS_IN deny 30
 description block all other advertisements
!
route-map COLT_VPLS_IN permit 10
 match ip address prefix-list COLT_VPLS_ROUTES
 set local-preference 200
!
route-map COLT_VPLS_IN permit 20
 match ip address prefix-list BT_VPLS_ROUTES
 set local-preference 150
!
route-map COLT_VPLS_IN deny 30
 description block all other advertisements
!
route-map BT_VPLS_OUT permit 10
 match ip address prefix-list BO_FRA_BT BO_FRA_COLT BT_VPLS_ROUTES COLT_VPLS_ROUTES
!
route-map BT_VPLS_OUT deny 20
 description block all other advertisements
!
route-map COLT_VPLS_OUT permit 10
 match ip address prefix-list BO_FRA_BT BO_FRA_COLT COLT_VPLS_ROUTES BT_VPLS_ROUTES
!
route-map COLT_VPLS_OUT deny 20
 description block all other advertisements
!
!

Config: CLO 

CLO#sh run
Building configuration...

Current configuration : 5120 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CLO
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
!
interface Loopback2
 ip address 10.2.2.1 255.255.255.0
!
interface Loopback3
 ip address 10.3.3.1 255.255.255.0
!
interface Loopback11
 ip address 10.11.11.1 255.255.255.0
!
interface Loopback12
 ip address 10.12.12.1 255.255.255.0
!
interface Loopback13
 ip address 10.13.13.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.17.90.12 255.255.255.224
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.17.90.42 255.255.255.224
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
!
router bgp 64912
 bgp log-neighbor-changes
 neighbor COLT_VPLS peer-group
 neighbor COLT_VPLS timers 6 20
 neighbor BT_VPLS peer-group
 neighbor BT_VPLS timers 6 20
 neighbor 172.17.90.11 remote-as 64911
 neighbor 172.17.90.11 peer-group BT_VPLS
 neighbor 172.17.90.11 description EBGP with CIX
 neighbor 172.17.90.13 remote-as 65019
 neighbor 172.17.90.13 peer-group BT_VPLS
 neighbor 172.17.90.13 description EBGP with London
 neighbor 172.17.90.15 remote-as 65025
 neighbor 172.17.90.15 peer-group BT_VPLS
 neighbor 172.17.90.15 description EBGP with Frankfurt
 neighbor 172.17.90.41 remote-as 64911
 neighbor 172.17.90.41 peer-group COLT_VPLS
 neighbor 172.17.90.41 description EBGP with CIX
 neighbor 172.17.90.43 remote-as 65019
 neighbor 172.17.90.43 peer-group COLT_VPLS
 neighbor 172.17.90.43 description EBGP with London
 neighbor 172.17.90.45 remote-as 65025
 neighbor 172.17.90.45 peer-group COLT_VPLS
 neighbor 172.17.90.45 description EBGP with Frankfurt
 maximum-paths 2
 !
 address-family ipv4
  neighbor COLT_VPLS next-hop-self
  neighbor COLT_VPLS soft-reconfiguration inbound
  neighbor COLT_VPLS route-map COLT_VPLS_IN in
  neighbor COLT_VPLS route-map COLT_VPLS_OUT out
  neighbor BT_VPLS next-hop-self
  neighbor BT_VPLS soft-reconfiguration inbound
  neighbor BT_VPLS route-map BT_VPLS_IN in
  neighbor BT_VPLS route-map BT_VPLS_OUT out
  neighbor 172.17.90.11 activate
  neighbor 172.17.90.13 activate
  neighbor 172.17.90.15 activate
  neighbor 172.17.90.41 activate
  neighbor 172.17.90.43 activate
  neighbor 172.17.90.45 activate
  maximum-paths 2
  no auto-summary
  no synchronization
  network 10.1.1.0 mask 255.255.255.0
  network 10.2.2.0 mask 255.255.255.0
  network 10.3.3.0 mask 255.255.255.0
  network 10.11.11.0 mask 255.255.255.0
  network 10.12.12.0 mask 255.255.255.0
  network 10.13.13.0 mask 255.255.255.0
 exit-address-family
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
ip prefix-list BO_CLON_BT seq 10 permit 10.1.1.0/24
ip prefix-list BO_CLON_BT seq 20 permit 10.2.2.0/24
ip prefix-list BO_CLON_BT seq 30 permit 10.3.3.0/24
!
ip prefix-list BO_CLON_COLT seq 10 permit 10.11.11.0/24
ip prefix-list BO_CLON_COLT seq 20 permit 10.12.12.0/24
ip prefix-list BO_CLON_COLT seq 30 permit 10.13.13.0/24
!
ip prefix-list BT_VPLS_ROUTES seq 10 permit 10.4.4.0/24
ip prefix-list BT_VPLS_ROUTES seq 20 permit 10.5.5.0/24
ip prefix-list BT_VPLS_ROUTES seq 30 permit 10.6.6.0/24
ip prefix-list BT_VPLS_ROUTES seq 40 permit 10.7.7.0/24
ip prefix-list BT_VPLS_ROUTES seq 50 permit 10.8.8.0/24
ip prefix-list BT_VPLS_ROUTES seq 60 permit 10.9.9.0/24
ip prefix-list BT_VPLS_ROUTES seq 70 permit 10.10.10.0/24
!
ip prefix-list COLT_VPLS_ROUTES seq 10 permit 10.14.14.0/24
ip prefix-list COLT_VPLS_ROUTES seq 20 permit 10.15.15.0/24
ip prefix-list COLT_VPLS_ROUTES seq 30 permit 10.16.16.0/24
ip prefix-list COLT_VPLS_ROUTES seq 40 permit 10.17.17.0/24
ip prefix-list COLT_VPLS_ROUTES seq 50 permit 10.18.18.0/24
ip prefix-list COLT_VPLS_ROUTES seq 60 permit 10.19.19.0/24
ip prefix-list COLT_VPLS_ROUTES seq 70 permit 10.20.20.0/24
!
!
!
route-map BT_VPLS_IN permit 10
 match ip address prefix-list BT_VPLS_ROUTES
 set local-preference 200
!
route-map BT_VPLS_IN permit 20
 match ip address prefix-list COLT_VPLS_ROUTES
 set local-preference 150
!
route-map BT_VPLS_IN deny 30
 description block all other advertisements
!
route-map COLT_VPLS_IN permit 10
 match ip address prefix-list COLT_VPLS_ROUTES
 set local-preference 200
!
route-map COLT_VPLS_IN permit 20
 match ip address prefix-list BT_VPLS_ROUTES
 set local-preference 150
!
route-map COLT_VPLS_IN deny 30
 description block all other advertisements
!
route-map BT_VPLS_OUT permit 10
 match ip address prefix-list BO_CLON_BT BO_CLON_COLT BT_VPLS_ROUTES COLT_VPLS_ROUTES
!
route-map BT_VPLS_OUT deny 20
 description block all other advertisements
!
route-map COLT_VPLS_OUT permit 10
 match ip address prefix-list BO_CLON_BT BO_CLON_COLT BT_VPLS_ROUTES COLT_VPLS_ROUTES
!
route-map COLT_VPLS_OUT deny 20
 description block all other advertisements
!
!

Config : London 

London#sh run
Building configuration...

Current configuration : 5277 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname London
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback7
 ip address 10.7.7.1 255.255.255.0
!
interface Loopback8
 ip address 10.8.8.1 255.255.255.0
!
interface Loopback9
 ip address 10.9.9.1 255.255.255.0
!
interface Loopback17
 ip address 10.17.17.1 255.255.255.0
!
interface Loopback18
 ip address 10.18.18.1 255.255.255.0
!
interface Loopback19
 ip address 10.19.19.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 172.17.90.13 255.255.255.224
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.17.90.43 255.255.255.224
 duplex auto
 speed auto
!
router bgp 65019
 bgp log-neighbor-changes
 neighbor COLT_VPLS peer-group
 neighbor COLT_VPLS timers 6 20
 neighbor BT_VPLS peer-group
 neighbor BT_VPLS timers 6 20
 neighbor 172.17.90.11 remote-as 64911
 neighbor 172.17.90.11 peer-group BT_VPLS
 neighbor 172.17.90.11 description EBGP with CIX
 neighbor 172.17.90.12 remote-as 64912
 neighbor 172.17.90.12 peer-group BT_VPLS
 neighbor 172.17.90.12 description EBGP with Clonakilty
 neighbor 172.17.90.15 remote-as 65025
 neighbor 172.17.90.15 peer-group BT_VPLS
 neighbor 172.17.90.15 description EBGP with Frankfurt
 neighbor 172.17.90.41 remote-as 64911
 neighbor 172.17.90.41 peer-group COLT_VPLS
 neighbor 172.17.90.41 description EBGP with CIX
 neighbor 172.17.90.42 remote-as 64912
 neighbor 172.17.90.42 peer-group COLT_VPLS
 neighbor 172.17.90.42 description EBGP with Clonakilty
 neighbor 172.17.90.45 remote-as 65025
 neighbor 172.17.90.45 peer-group COLT_VPLS
 neighbor 172.17.90.45 description EBGP with Frankfurt
 maximum-paths 2
 !
 address-family ipv4
  neighbor COLT_VPLS next-hop-self
  neighbor COLT_VPLS soft-reconfiguration inbound
  neighbor COLT_VPLS route-map COLT_VPLS_IN in
  neighbor COLT_VPLS route-map COLT_VPLS_OUT out
  neighbor BT_VPLS next-hop-self
  neighbor BT_VPLS soft-reconfiguration inbound
  neighbor BT_VPLS route-map BT_VPLS_IN in
  neighbor BT_VPLS route-map BT_VPLS_OUT out
  neighbor 172.17.90.11 activate
  neighbor 172.17.90.12 activate
  neighbor 172.17.90.15 activate
  neighbor 172.17.90.41 activate
  neighbor 172.17.90.42 activate
  neighbor 172.17.90.45 activate
  maximum-paths 2
  no auto-summary
  no synchronization
  network 10.7.7.0 mask 255.255.255.0
  network 10.8.8.0 mask 255.255.255.0
  network 10.9.9.0 mask 255.255.255.0
  network 10.17.17.0 mask 255.255.255.0
  network 10.18.18.0 mask 255.255.255.0
  network 10.19.19.0 mask 255.255.255.0
 exit-address-family
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
ip prefix-list BO_LONDON_BT seq 10 permit 10.7.7.0/24
ip prefix-list BO_LONDON_BT seq 20 permit 10.8.8.0/24
ip prefix-list BO_LONDON_BT seq 30 permit 10.9.9.0/24
!
ip prefix-list BO_LONDON_COLT seq 10 permit 10.17.17.0/24
ip prefix-list BO_LONDON_COLT seq 20 permit 10.18.18.0/24
ip prefix-list BO_LONDON_COLT seq 30 permit 10.19.19.0/24
!
ip prefix-list BT_VPLS_ROUTES seq 10 permit 10.1.1.0/24
ip prefix-list BT_VPLS_ROUTES seq 20 permit 10.2.2.0/24
ip prefix-list BT_VPLS_ROUTES seq 30 permit 10.3.3.0/24
ip prefix-list BT_VPLS_ROUTES seq 40 permit 10.4.4.0/24
ip prefix-list BT_VPLS_ROUTES seq 50 permit 10.5.5.0/24
ip prefix-list BT_VPLS_ROUTES seq 60 permit 10.6.6.0/24
ip prefix-list BT_VPLS_ROUTES seq 70 permit 10.10.10.0/24
!
ip prefix-list COLT_VPLS_ROUTES seq 10 permit 10.11.11.0/24
ip prefix-list COLT_VPLS_ROUTES seq 20 permit 10.12.12.0/24
ip prefix-list COLT_VPLS_ROUTES seq 30 permit 10.13.13.0/24
ip prefix-list COLT_VPLS_ROUTES seq 40 permit 10.14.14.0/24
ip prefix-list COLT_VPLS_ROUTES seq 50 permit 10.15.15.0/24
ip prefix-list COLT_VPLS_ROUTES seq 60 permit 10.16.16.0/24
ip prefix-list COLT_VPLS_ROUTES seq 70 permit 10.20.20.0/24
!
!
!
route-map BT_VPLS_IN permit 10
 match ip address prefix-list BT_VPLS_ROUTES
 set local-preference 200
!
route-map BT_VPLS_IN permit 20
 match ip address prefix-list COLT_VPLS_ROUTES
 set local-preference 150
!
route-map BT_VPLS_IN deny 30
 description block all other advertisements
!
route-map COLT_VPLS_IN permit 10
 match ip address prefix-list COLT_VPLS_ROUTES
 set local-preference 200
!
route-map COLT_VPLS_IN permit 20
 match ip address prefix-list BT_VPLS_ROUTES
 set local-preference 150
!
route-map COLT_VPLS_IN deny 30
 description block all other advertisements
!
route-map BT_VPLS_OUT permit 10
 match ip address prefix-list BO_LONDON_COLT BO_LONDON_BT BT_VPLS_ROUTES COLT_VPLS_ROUTES
!
route-map BT_VPLS_OUT deny 20
 description block all other advertisements
!
route-map COLT_VPLS_OUT permit 10
 match ip address prefix-list BO_LONDON_COLT BO_LONDON_BT COLT_VPLS_ROUTES BT_VPLS_ROUTES
!
route-map COLT_VPLS_OUT deny 20
 description block all other advertisements
!
!

 

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions

Hello.I'm not sure what is

Hello.

I'm not sure what is the issue with pings - please provide traces between the devices for troubleshooting.

 

To prefer one way over another without sticking to preference per cloud, you could use as-path prepend: when you announce orange prefix over Carrier B, or Blue prefix over Carrier A, prepend twice.

In this case you won't need any LP manipulation.

In this case you won't need list of prefixes per router, because prepend should be done on originating router only.

2 REPLIES

Hello.I'm not sure what is

Hello.

I'm not sure what is the issue with pings - please provide traces between the devices for troubleshooting.

 

To prefer one way over another without sticking to preference per cloud, you could use as-path prepend: when you announce orange prefix over Carrier B, or Blue prefix over Carrier A, prepend twice.

In this case you won't need any LP manipulation.

In this case you won't need list of prefixes per router, because prepend should be done on originating router only.

Community Member

Hi Vasilii, The ping was my

Hi Vasilii, 

The ping was my mistake, 

Changed to outbound AS-Path Prepend.  That seems to do the trick

thanks

118
Views
0
Helpful
2
Replies
CreatePlease to create content