Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

eBGP Multipath Load Sharing Issue

Hi,

I am running in to an issue with eBGP multipath load sharing.  I have a CE router connected to an ISP single PE router running eBGP on an MPLS network.  CE router has a 5Mb ethernet and a 1.5Mb T1 link to the ISP.  I am using the "maximum paths command" and relying on IP CEF for load sharing.  The BGP routing table shows two destination routes but installs T1 link as the preferred route.  How can I manipulate BGP to use the 5Mb ethernet link first.  I assume the preferred route is being learned from iBGP in the ISP MPLS network.

Here's my partial config:

interface FastEthernet0/1

description SPRINT MPLS NUA46357861

bandwidth 5000

ip address 192.168.0.17 255.255.255.252

ip flow ingress

ip flow egress

duplex full

speed 10

service-policy output SHAPE

interface Serial0/0/0

description SPRINT NUA46341529

bandwidth 1536

ip address 192.168.0.21 255.255.255.252

encapsulation ppp

shutdown

max-reserved-bandwidth 94

service-policy output 1.5MB

router bgp 65000

no synchronization

bgp router-id 6.6.6.6

bgp log-neighbor-changes

network 10.1.6.0 mask 255.255.255.0

network 172.16.6.0 mask 255.255.255.0

network 192.168.0.16 mask 255.255.255.252

network 192.168.0.20 mask 255.255.255.252

neighbor 192.168.0.18 remote-as 1803

neighbor 192.168.0.18 version 4

neighbor 192.168.0.22 remote-as 1803

neighbor 192.168.0.22 version 4

maximum-paths 4

no auto-summary

11 REPLIES

eBGP Multipath Load Sharing Issue

Hello,

The Maximum-paths command allows BGP to install more than one path in the routing table, IF and ONLY IF the Destination Network is being learned through both WAN links and has the following EQUAL:

1- Weight

2- Local Preference.

3- Shortest As Path.

4- MED Value

5- Origin Code

if the above attributes for a given Network destination are equal in the BGP table, BGP will install two paths in the routing table (RIP) for that Network.

Regards,

Mohamed

New Member

eBGP Multipath Load Sharing Issue

Hi Mohamed,

You are correct.  The routing table does show two paths to the same destination, but the route learned via the T1 is listed higher in the order than the 5MB link.  This causing majority of hte traffic to be passed through the T1 while the 5Mb link is hardly used.

Isn't there an easy way to tell BGP that T1 has lower bandwidth so use the 5Mb link first.

eBGP Multipath Load Sharing Issue

Hi,

Use the Weight or Local-Preference attribute if you just want to prefer the 5Mb link.

Regards,

Mohamed

New Member

eBGP Multipath Load Sharing Issue

Hi Mohamed,

Sorry! maybe I wasn't clear in my earlier post.  I want to  perform unequal load share between the two links with the 5Mb link listed first in the routing table.  I am able to get this functionality with equal paths, but in this instance IP CEF is routing majority of the traffic on the T1 link because BGP is listing it first in the routing table.

New Member

eBGP Multipath Load Sharing Issue

Hi Abbas

We have a feature in BGP - DMZ Link Bandwidth, which will do the job as required for your problem. Refer to the guide below:

http://www.cisco.com/en/US/docs/ios/12_2t/12_2t2/feature/guide/ftbgplb.html#wp

This feature helps to have higher bandwidth link get more preference over the lower with defined ratio of packets sent proportionately.

Hope it helps.

Kind Regards,

Madni

New Member

eBGP Multipath Load Sharing Issue

Hi Madni,

I have tried BGP -DMZLink BW feature and I am still having the same issue.

Here is my config and route table as reference:

!

interface FastEthernet0/1

description SPRINT MPLS NUA

bandwidth 5000

ip address 192.168.0.17 255.255.255.252

ip flow ingress

ip flow egress

duplex full

speed 10

service-policy output SHAPE

!

interface Serial0/0/0

description SPRINT NUA

bandwidth 1536

ip address 192.168.0.21 255.255.255.252

encapsulation ppp

max-reserved-bandwidth 94

service-policy output 1.5MB

router bgp 65000

bgp router-id 6.6.6.6

bgp log-neighbor-changes

neighbor 192.168.0.18 remote-as 1803

neighbor 192.168.0.18 version 4

neighbor 192.168.0.22 remote-as 1803

neighbor 192.168.0.22 version 4

maximum-paths 4

!

address-family ipv4

  neighbor 192.168.0.18 activate

  neighbor 192.168.0.18 dmzlink-bw

  neighbor 192.168.0.22 activate

  neighbor 192.168.0.22 dmzlink-bw

  maximum-paths 4

  no auto-summary

  no synchronization

  bgp dmzlink-bw

  network 10.1.6.0 mask 255.255.255.0

  network 172.16.6.0 mask 255.255.255.0

  network 192.168.0.16 mask 255.255.255.252

  network 192.168.0.20 mask 255.255.255.252

exit-address-family

!

B    192.168.128.0/24 [20/0] via 192.168.0.18, 6d16h

     6.0.0.0/32 is subnetted, 1 subnets

C       6.6.6.6 is directly connected, Loopback0

     172.16.0.0/16 is variably subnetted, 9 subnets, 3 masks

B       172.16.0.24/29 [20/0] via 192.168.0.18, 6d16h

B       172.16.0.16/29 [20/0] via 192.168.0.18, 6d16h

B       172.16.8.0/24 [20/0] via 192.168.0.18, 4d23h

B       172.16.0.8/29 [20/0] via 192.168.0.18, 6d16h

B       172.16.5.0/24 [20/0] via 192.168.0.18, 6d16h

C       172.16.6.0/24 is directly connected, FastEthernet0/0.20

B       172.16.7.0/24 [20/0] via 192.168.0.18, 6d16h

B       172.16.0.0/29 [20/0] via 192.168.0.18, 6d16h

B       172.16.2.0/23 [20/0] via 192.168.0.18, 6d16h

B    192.168.64.0/24 [20/0] via 192.168.0.18, 6d16h

B    192.168.65.0/24 [20/0] via 192.168.0.18, 6d16h

     10.0.0.0/24 is subnetted, 7 subnets

B       10.1.8.0 [20/0] via 192.168.0.18, 4d23h

B       10.1.2.0 [20/0] via 192.168.0.18, 6d16h

B       10.2.2.0 [20/0] via 192.168.0.18, 6d16h

B       10.1.7.0 [20/0] via 192.168.0.18, 6d16h

C       10.1.6.0 is directly connected, FastEthernet0/0.10

B       10.1.5.0 [20/0] via 192.168.0.18, 6d16h

B       10.2.7.0 [20/0] via 192.168.0.18, 6d16h

     192.168.0.0/30 is subnetted, 8 subnets

B       192.168.0.100 [20/0] via 192.168.0.18, 6d16h

B       192.168.0.32 [20/0] via 192.168.0.18, 6d16h

B       192.168.0.12 [20/0] via 192.168.0.18, 6d16h

B       192.168.0.0 [20/0] via 192.168.0.18, 6d16h

B       192.168.0.4 [20/0] via 192.168.0.18, 6d16h

B       192.168.0.24 [20/0] via 192.168.0.18, 6d16h

B       192.168.0.28 [20/0] via 192.168.0.18, 6d16h

C       192.168.0.16 is directly connected, FastEthernet0/1

B    192.168.254.0/24 [20/0] via 192.168.0.18, 6d16h

B    192.168.252.0/24 [20/0] via 192.168.0.18, 6d16h

B*   0.0.0.0/0 [20/0] via 192.168.0.18, 6d16h

Thank You.

Re: eBGP Multipath Load Sharing Issue

Hi Abbas,

your config looks alrite. Did you try to soft clear the bgp peering just in case after you applied the dmzlink-bw command.

Try that and see if helps.

The strange thing is you have maximum-paths 4 and yet your RIB only shows one best path.  can you please post your

sh ip bgp summ

sh ip bgp 172.16.7.0

HTH

New Member

eBGP Multipath Load Sharing Issue

The T1 serial link was admin shut when I copied the ip route info hence the routes missing.  I also cleared BGP peering on both circuits but the issue remained.  I will try to use weight or local preference as a possible option.

Thanks

eBGP Multipath Load Sharing Issue

Hi,

IMHO, you would need to get two BGP routes forming multipath load sharing first.

And then you could tune it with the dmzlink-bw feature to make it unequal in fact based on the bandwidth values received from your neighbor in a community for each prefix.

See

http://www.cisco.com/en/US/docs/ios/iproute_bgp/command/reference/irg_bgp3.html#wp1106455

for details.

I'm afraid in your case the maximum you can get is preferring the 5 Mb line by setting the weight or local preference as Mohamed Sobair adviced already.

BR,

Milan

Bronze

eBGP Multipath Load Sharing Issue

I have a similar issue. I am running multi-VRF in a VRF-lite deployment on a Cisco ASR. I am seeing similar route suppression between VRFs where although maximum paths is set to 4 globally in the BGP process and within the individual address-families. The VRF local to the load balanced routed path show both paths equally available in the routing and CEF tables. Somewhere in the VRF to VRF BGP transport between VRFs, all routes other than the first path in the originating VRF are suppressed.

Super Bronze

eBGP Multipath Load Sharing Issue

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

If your platform supports it, another approach would be to use OER/PfR.

636
Views
0
Helpful
11
Replies
CreatePlease login to create content