Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

eBGP redist static command?

Hello

I have two routers connected back to back...im running eBGP between them...i want to do redist static (to enter the serial interface networks into BGP without using the network statement, however when i do this i do not see the routes...any ideas? TIA

interface Serial1/0

description Connection to BGP WAN rtr

ip address 172.26.10.2 255.255.255.252

no ip directed-broadcast

no ip mroute-cache

no fair-queue

clockrate 56000

!

interface Serial1/1

no ip address

no ip directed-broadcast

shutdown

!

interface Serial1/2

description Connection to Remote WAN BGP RTR

ip address 172.26.10.10 255.255.255.252

no ip directed-broadcast

!

interface Serial1/3

no ip address

no ip directed-broadcast

shutdown

!

router bgp 65511

no synchronization

redistribute connected

neighbor 172.26.10.1 remote-as 65512

neighbor 172.26.10.9 remote-as 65510

!

the neighbor routers are configured the same (for EBGP just with the different serial IPs)

3 REPLIES
Silver

Re: eBGP redist static command?

If you do a 'show ip bgp' on this router, do you see the routes in your own bgp table?

If so, does a 'show ip bgp neighbor 172.26.10.1 advertised-routes' show the routes?

What does a 'show ip bgp' on the remote router look like? Is it completely blank?

If you use 'network' statements, do the neighbors get the routes then?

New Member

Re: eBGP redist static command?

Thanks for the reply...but it was a long day and i was missing it...i figured it out...BGP was auto summarizing...therefore sending out the aggregated routes

New Member

Re: eBGP redist static command?

If you want to redistribute connected networks into bgp, you need to use 'redistribute connected' command.

Hope this helps

Jabran

136
Views
0
Helpful
3
Replies