Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EIGRP - 2600 and 3640

I am trying to enable EIGRP on both my 2600 and 3640, but I keep getting :

IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 192.168.2.1 not on common subnet for Ethernet0/0

on the 2600....

Help please:

2600 Show Run:

Current configuration : 973 bytes

!

version 12.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

boot-start-marker

boot system flash

boot-end-marker

!

no logging on

!

no aaa new-model

ip subnet-zero

ip cef

!

!

ip dhcp excluded-address 192.168.3.1 192.168.3.150

!

ip dhcp pool 192.168.3.0/24

   network 192.168.3.0 255.255.255.0

   default-router 192.168.3.1

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8

!

!

username woodjl1650 privilege 15 password 0 henry999

!

!

!

!

interface Ethernet0/0

ip address 192.168.3.1 255.255.255.0

half-duplex

!

interface Serial0/0

no ip address

shutdown

!

interface Serial0/1

no ip address

shutdown

!

router eigrp 1

network 192.168.0.0

network 192.168.2.0

network 192.168.3.0

auto-summary

!

no ip http server

ip classless

!

!

snmp-server community public RO

snmp-server community private RW

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

!

end

3640 Router:

Current configuration : 1872 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 3640-Internet

!

boot system flash c3640-ik9s-mz.122-40a.bin

!

username woodjl1650 privilege 15 password 0 henry999

memory-size iomem 25

ip subnet-zero

ip cef

!

!

ip domain-name www.jkkcc.com

ip name-server 192.168.2.127

ip name-server 192.168.2.128

ip dhcp excluded-address 192.168.2.1 192.168.2.150

!

ip dhcp pool 192.168.2.0/24

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   dns-server 192.168.2.127 192.168.2.128 8.8.8.8 127.0.0.1

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address dhcp

ip nat outside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

clock rate 2000000

!

interface FastEthernet0/1

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip route-cache flow

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

interface Ethernet1/0

no ip address

shutdown

half-duplex

!

interface Ethernet1/1

no ip address

shutdown

half-duplex

!

interface Ethernet3/0

no ip address

shutdown

half-duplex

!

interface Ethernet3/1

no ip address

shutdown

half-duplex

!

router eigrp 1

network 192.168.0.0

network 192.168.2.0

network 192.168.3.0

auto-summary

!

ip nat inside source list 15 interface FastEthernet0/0 overload

ip nat inside source static tcp 192.168.2.128 80 interface FastEthernet0/0 80

ip nat inside source static tcp 192.168.2.128 25 interface FastEthernet0/0 25

ip classless

ip http server

ip http authentication local

!

access-list 15 permit 192.168.2.0 0.0.0.255

snmp-server community public RO

snmp-server community private RW

snmp-server enable traps tty

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

end

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

EIGRP - 2600 and 3640

Hi,

no it won't form a neighbour relationship.

Regards.

Alain

Don't forget to rate helpful posts.
3 REPLIES
New Member

EIGRP - 2600 and 3640

Hi,

As you mentioned there is IP address on the point to point link are not in same subnet.Change the subnet IP address either on e0/0 OR f0/1.

interface Ethernet0/0

ip address 192.168.3.1 255.255.255.0 <<<<<

half-duplex


interface FastEthernet0/1

ip address 192.168.2.1 255.255.255.0 <<<

New Member

EIGRP - 2600 and 3640

So EIGRP does not work on two different subnets?

Purple

EIGRP - 2600 and 3640

Hi,

no it won't form a neighbour relationship.

Regards.

Alain

Don't forget to rate helpful posts.
390
Views
0
Helpful
3
Replies
CreatePlease login to create content