Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

EIGRP Adjacency Problem

Hi,

I have two routers connected through a Frame-Relay cloud with point-to-point subinterfaces. There is a connection between those routers at Layers 1 & 2. Routers see each other from CDP and ping each other serial interfaces. However there is no any EIGRP Adjacency between them. The router with 12.4(9)T7 IOS do not send hello packets out of serial interface nor receive. Does anybody know if there is a known bug for that IOS version. I have checked the EIGRP Configuration and is correct. Frame-Relay confguration also is correct. I can see LMI packets at both sides.

3 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Silver

Re: EIGRP Adjacency Problem

Hello,

I would try to issue the following:

router eigrp ASN

no passive-interface serialx/y

and see if anything changes

even if not needed you could add a frame-relay map ip x.x.x.x with broadcast option under point-to-point FR subif

or simply a clear ip eigrp ASN to rerun the process may be eigrp process was created before configuring the ip address on the serial interface.

Hope to help

Giuseppe

Hall of Fame Super Bronze

Re: EIGRP Adjacency Problem

Have you tried using the neighbor command under the EIGRP process and see if unicast work within EIGRP?

By default, EIGRP will use multicast for the exchange of hello packets.

Point-to-Point subinterfaces should provide the multicast service by default, thus I'm not sure why it isn't working.

Can you provide configs along with the show frame pvc output?

__

Edison.

Re: EIGRP Adjacency Problem

Could you post the configs please? Maybe it is simply a typo. Sometimes it takes two sets of eyes to spot them.

If you do show ip protocols, do you see EIGRP on the interface?

5 REPLIES
Hall of Fame Super Silver

Re: EIGRP Adjacency Problem

Hello,

I would try to issue the following:

router eigrp ASN

no passive-interface serialx/y

and see if anything changes

even if not needed you could add a frame-relay map ip x.x.x.x with broadcast option under point-to-point FR subif

or simply a clear ip eigrp ASN to rerun the process may be eigrp process was created before configuring the ip address on the serial interface.

Hope to help

Giuseppe

Hall of Fame Super Bronze

Re: EIGRP Adjacency Problem

Have you tried using the neighbor command under the EIGRP process and see if unicast work within EIGRP?

By default, EIGRP will use multicast for the exchange of hello packets.

Point-to-Point subinterfaces should provide the multicast service by default, thus I'm not sure why it isn't working.

Can you provide configs along with the show frame pvc output?

__

Edison.

Re: EIGRP Adjacency Problem

Could you post the configs please? Maybe it is simply a typo. Sometimes it takes two sets of eyes to spot them.

If you do show ip protocols, do you see EIGRP on the interface?

New Member

Re: EIGRP Adjacency Problem

You are right...I think I am little stupid..I was using the follow set of commands ander EIGRP :

passive-interface default

no passive-interface Serial0/0/0

no passive-interface BRI0/1/0

So i added th command

no passive-interface Serial0/0/0.100 and it seems working fine..

Thanks

New Member

Re: EIGRP Adjacency Problem

have you tried disabling spilt horizon for EIGRP on the hub router..?

steve Knockswell

271
Views
0
Helpful
5
Replies
CreatePlease to create content