Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

EIGRP and BGP mutual redistribution.

I am doing mutual redistribution with the following:

router eigrp 10

redistribute bgp 64586 metric 155000 10 255 1 4470 route-map bgp-to-eigrp

network 10.134.0.0

auto-summary

! redist bgp routes with route-map and metric

router bgp 64586

no synchronization

bgp log-neighbor-changes

redistribute eigrp 10 route-map eigrp-to-bgp

neighbor 10.134.254.253 remote-as 209

neighbor 10.134.254.253 ebgp-multihop 2

neighbor 10.134.254.253 update-source Loopback0

neighbor 10.134.254.253 weight 40000

no auto-summary

!redist eigrp routes with route-map

access-list 1 permit 10.134.99.252 0.0.0.0

! rtdallas-7206

access-list 2 permit 10.134.99.251 0.0.0.0

! rtapple

access-list 3 permit 10.134.99.247 0.0.0.0

! rtlb

access-list 4 permit 10.134.99.246 0.0.0.0

! rtbrun

access-list 5 permit 10.134.99.245 0.0.0.0

! rteb

access-list 6 permit 10.134.99.244 0.0.0.0

! rtdal-fg

access-list 7 permit 10.134.99.241 0.0.0.0

! rtwest

access-list 8 permit 10.134.99.236 0.0.0.0

! rt6513-nw

access-list 9 permit 10.134.99.233 0.0.0.0

! rt6513-d

access-list 10 permit 10.134.99.254 0.0.0.0

! rt6513-3

access-list 11 permit 10.134.99.243 0.0.0.0

! rtgac4

access-list 12 permit 10.134.99.239 0.0.0.0

! rtgac-old

route-map eigrp-to-bgp deny 10

match ip next-hop 1

!

route-map eigrp-to-bgp deny 11

match ip next-hop 2

!

route-map eigrp-to-bgp deny 12

match ip next-hop 3

!

route-map eigrp-to-bgp deny 13

match ip next-hop 4

!

route-map eigrp-to-bgp deny 14

match ip next-hop 5

!

route-map eigrp-to-bgp deny 15

match ip next-hop 6

!

route-map eigrp-to-bgp deny 16

match ip next-hop 7

!

route-map eigrp-to-bgp deny 17

match ip next-hop 8

!

route-map eigrp-to-bgp deny 18

match ip next-hop 9

!

route-map eigrp-to-bgp permit 30

set tag 10

!set tag to deny later in redist to bgp

route-map bgp-to-eigrp deny 10

match tag 10

!deny routes learned from eigrp

!

route-map bgp-to-eigrp permit 20

set tag 64586

set ip next-hop 10.134.92.254

This seems to work except for routes in EIGRP at another router.

rt6513-3 is running both protocols and doing the redistribution. It also has

the external BGP session. On this router the EIGRP entry for the BGP

learned route is

P 10.134.60.0/24, 1 successors, FD is 18944, tag is 64586

via Redistributed

and the route table entry is

6513-3#sh ip ro 10.134.60.0

Routing entry for 10.134.60.0/24

Known via "bgp 64586", distance 20, metric 0

Tag 209, type external

Redistributing via eigrp 10

Advertised by eigrp 10 metric 155000 10 255 1 4470 route-map bgp-to-eigrp

bgp 64586 (self originated)

Last update from 10.134.254.253 01:20:42 ago

Routing Descriptor Blocks:

* 10.134.254.253, from 10.134.254.253, 01:20:42 ago

Route metric is 0, traffic share count is 1

AS Hops 2

Route tag 209

When I go to another router that is running EIGRP only (rt6513-2n) the EIGRP

topo entry is

P 10.134.60.0/24, 1 successors, FD is 864000

via 10.134.92.244, Vlan92

via 10.134.92.254, Vlan92

The metric is now the same as the metric for the other route that is learned

natively in EIGRP from a 3rd router (rtgac).

I changed the delay on rtgac to try to force the BGP learned route to have a

higher metric, but what happened is both routes have the new higher metric in

rt6513-2

before the change they both showed 858880.

The metrics for these should be calculated from these values

rtgac rt6513-3

155000 44210

10 20

255 255

1 5

4470 1500

If I shut down the interface for the route on rtgac I get this on (6513-2n)

P 10.134.60.0/24, 1 successors, FD is 19200, tag is 64586

via 10.134.92.254, Vlan92

If I no shut the interface it goes back to this

P 10.134.60.0/24, 1 successors, FD is 864000

via 10.134.92.244, Vlan92

via 10.134.92.254, Vlan92

1 REPLY
Silver

Re: EIGRP and BGP mutual redistribution.

Please post the topology. I don't quite understand where the other router connects to.

You have posted the configuration from one router only. Is the configuration same on the other routers?

I cannot help you exactly without topology and all of the configuration, but try redistributing without route-maps, and then gradually add route-map complexity.

This config seems ok, if you're really blocking all the next hops you need to block, and not the ones you don't want.

463
Views
0
Helpful
1
Replies
CreatePlease to create content