Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

EIGRP and distribute-list

Hi all I seem to have a small issue with distributing into EIGRP.

I have a 3550 switch running c3550-ipservices-mz.122-25.SEE.bin so I can run EIGRP on it - I have the following config (edited to leave only relevent parts)

router eigrp 64

redistribute static metric 100000 500 255 1 1500

network 10.1.1.28 0.0.0.3

distribute-list 1 out static

auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.1.1

ip route 10.1.248.0 255.255.255.0 10.1.1.2

!

access-list 1 permit 10.1.248.0 0.0.0.255

sho ip protocols on the 3550 show's it is not routing for the 10.1.248/24

Neibouring devices have no route for 10.1.248/24:

router2#sho ip eigrp top 10.1.248.0 255.255.255.0

% IP-EIGRP (AS 64): Route not in topology table

is this due to the auto-summary? The rest of the network in running 255.255.248.0 mask If not any ideas (I've checked router2 with sho ip eigrp neigbours, and sho ip eigrp traffic to confirm that eigrp traffic / updates are going between the two)

Hope that all makes sence (difficult to tell when writing in such a small window :)

James Butler

6 REPLIES
Hall of Fame Super Gold

Re: EIGRP and distribute-list

James

My first question would be whether the:

ip route 10.1.248.0 255.255.255.0 10.1.1.2

is a valid route. I note that your default route next hop address is 10.1.1.1 is 10.1.1.2 a valid next hop also?

When you do show ip route on the original router does the 10.1.248/24 show up in the routing table as a static route?

From the network statement it looks like you have one interface which is active in EIGRP. Is it forming a valid neighbor relationship with the other router that you are looking at?

I am also curious about your statement that: "sho ip protocols on the 3550 show's it is not routing for the 10.1.248/24". Show ip protocol would not show redistributed static routes. It should show that Redistributing: staic, eigrp 64 but will not show the networks that are redistributed. I believe that you are possibly confused because it does show routing for Networks: and lists the networks that match network statements under router eigrp, but it does not list specific redistributed routes.

And I do not see how auto-summary would come into play since the only interface that matches a network statement would be in network 10, and the static route is in 10, so it would not be summarized.

HTH

Rick

New Member

Re: EIGRP and distribute-list

Thanks for comming back Rick:

I've probbably made it harder because I changed all the IP address for some bazaire reason. Anyway sho ip route 10.1.248.0/24 shows me:

Routing entry for 10.1.248.0/24

Known via "static", distance 1, metric 0

Redistributing via eigrp 64

Routing Descriptor Blocks:

* 10.1.1.2

Route metric is 0, traffic share count is 1

So it is redistributing into eigrp? The other routers are neighbouring fine (sho ip eigrp ne and sho ip eigrp traffic) but they don't learn about the route.

Hall of Fame Super Gold

Re: EIGRP and distribute-list

James

This output verifies that 10.1.248.0/24 is a valid static route and that the router believes that it is being redistributed into eigrp.

What do you get if you do show ip eigrp topology 10.1.248.0 255.255.255.0? (be sure to include the mask in the command)

HTH

Rick

New Member

Re: EIGRP and distribute-list

On the switch where the redistribution is occuring:

sho ip eigrp top 10.1.248.0 255.255.255.0

IP-EIGRP (AS 64): Topology entry for 10.1.248.0/24

State is Passive, Query origin flag is 1, 0 Successor(s), FD is 4294967295

Routing Descriptor Blocks:

10.1.129.1 (GigabitEthernet0/1), from 10.1.10.29, Send flag is 0x0

Composite metric is (80896/78336), Route is Internal

Vector metric:

Minimum bandwidth is 35087 Kbit

Total delay is 310 microseconds

Reliability is 255/255

Load is 30/255

Minimum MTU is 1500

Hop count is 3

On another router:

sho ip eigrp top 10.1.248.0 255.255.255.0

% IP-EIGRP (AS 64): Route not in topology table

yet they can both see each other under sho ip eigrp nei.

I think I need to go back and read my EIGRP output notes carefully to make sence of the Routing Descriptor Blocks

James

Hall of Fame Super Gold

Re: EIGRP and distribute-list

James

The output that you have posted shows 10.1.248.0/24 as an EIGRP internal route not as a redistributed route. For one thing under the Routing Descriptor Blocks it has a next hop address and a neighbor from whom you learned the route whereas in a redistributed static the next hop is 0.0.0.0 and it indicates from Rstatic. Also your output indicates that the route is Internal whereas a redistributed route indicates that Route is External. Also the Load factor is 30 wheras your redistribution metrics give it as 1. And this route has a hop count of 3 whereas a redistributed static has a hop count of 0.

The output shows that you learned this route from 10.1.10.29. If you go to that router what do you find?

Also I note that the only network statement that you show is this:

network 10.1.1.28 0.0.0.3

but if the network is 10.1.1.28 how does 10.1.10.29 become a neighbor? Did you mis-type something or did you eliminate other networks from the config that you posted?

HTH

Rick

Gold

Re: EIGRP and distribute-list

"The output that you have posted shows 10.1.248.0/24 as an EIGRP internal route not as a redistributed route."

Note the internal route isn't being installed in the local routing table (it has 0 successors), because of the locally configured static route (routers always assume humans are smarter than routers--we can debate if this is always a valid assumption or not at some other point).

I think my next step would be to try clearing the entry out of the topo table (clear ip eigrp topo 64 10.1.248.0 255.255.255.0, if I remember the command right). In fact, do a clear ip eigrp events, then clear that entry from the topo table, and then see what the event log tells you. debug ip eigrp notifications might also provide useful information on the redistribution process.

Just a thought....

:-)

Russ

352
Views
0
Helpful
6
Replies
CreatePlease to create content