Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

EIGRP and Floating static issue

Subnet 10.251.12.64/26 is located at remote location. From central site Core-1 is eigrp neigbhor with 10.90.247.26 (primary path) and secondary internet (VPN tunnel), so from Core-1 we have configured floating static pointing to juniper device. The problem is when primary is down Core-1 is switching to Juniper however when the primary link is back up it does not learn from EIGRP. As soon as I do clear ip route it starts learning thru EIGRP.

When running on secondary path, Core-1 does not even show that subnet learning thru EIGRP.

Core-1#sh ip route 10.251.12.64

Routing entry for 10.251.12.64/26

Known via "static", distance 240, metric 0

Redistributing via eigrp 1

Advertised by eigrp 1

Routing Descriptor Blocks:

* 10.90.247.30

Route metric is 0, traffic share count is 1

Core-1#sh ip eigrp topo 10.251.12.64 255.255.255.192

IP-EIGRP topology entry for 10.251.12.64/26

State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2816

Routing Descriptor Blocks:

0.0.0.0, from Rstatic, Send flag is 0x0

Composite metric is (2816/0), Route is External

Vector metric:

Minimum bandwidth is 1000000 Kbit

Total delay is 10 microseconds

Reliability is 255/255

Load is 1/255

Minimum MTU is 1500

Hop count is 0

External data:

Originating router is 10.47.158.6 (this system)

AS number of route is 0

External protocol is Static, external metric is 0

Administrator tag is 0 (0x00000000)

Core-1#clear ip route 10.251.12.64 255.255.255.192

Core-1#sh ip route 10.251.12.64

Routing entry for 10.251.12.64/26

Known via "eigrp 1", distance 170, metric 59648

Tag 65011, type external

Redistributing via eigrp 1

Advertised by eigrp 1 (self originated)

Last update from 10.90.247.26 on Vlan102, 00:00:04 ago

Routing Descriptor Blocks:

* 10.90.247.26, from 10.90.247.26, 00:00:04 ago, via Vlan102

Route metric is 59648, traffic share count is 1

Total delay is 110 microseconds, minimum bandwidth is 45045 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 10/255, Hops 1

Core-1>sh ver

Cisco Internetwork Operating System Software

IOS (tm) MSFC Software (C6MSFC-DS-M), Version 12.0(7)XE1, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

TAC:Home:SW:IOS:Specials for info

Copyright (c) 1986-2000 by cisco Systems, Inc.

Compiled Fri 04-Feb-00 00:04 by lstringr

Image text-base: 0x60008900, data-base: 0x60E44000

ROM: System Bootstrap, Version 12.0(3)XE, RELEASE SOFTWARE

BOOTFLASH: MSFC Software (C6MSFC-BOOT-M), Version 12.0(7)XE1, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

BASRTRNDC006 uptime is 2 years, 45 weeks, 5 days, 20 hours, 42 minutes

System returned to ROM by power-on at 03:38:47 est Thu Sep 8 2005

System restarted at 13:08:03 est Tue Feb 28 2006

Running default software

cisco Cat6k-MSFC (R5000) processor with 122880K/8192K bytes of memory.

Processor board ID SAD04240NKC

R5000 CPU at 200Mhz, Implementation 35, Rev 2.1, 512KB L2 Cache

Last reset from power-on

Bridging software.

X.25 software, Version 3.0.0.

9 Virtual Ethernet/IEEE 802.3 interface(s)

123K bytes of non-volatile configuration memory.

4096K bytes of packet SRAM memory.

16384K bytes of Flash internal SIMM (Sector size 256K).

Configuration register is 0x102

Please help how we would resolve this issue, let me know if you need any more information.

3 REPLIES
Hall of Fame Super Blue

Re: EIGRP and Floating static issue

Pramod

I have just done a quick test of this in a lab and it works for me. Not using 6500 etc. but principle is same with other routers/switches.

Can you post

1) Eigrp config from 6500

2) static routes added on 6500

Jon

Community Member

Re: EIGRP and Floating static issue

John,

Here's the config, the other static routes are also for the same site and has similar issue:

router eigrp 1

redistribute static

passive-interface Vlan1

passive-interface Vlan20

passive-interface Vlan170

network 10.0.0.0

network 138.57.0.0

no auto-summary

ip route 10.85.0.0 255.255.240.0 10.90.247.30 240

ip route 10.251.4.160 255.255.255.240 10.90.247.30 240

ip route 10.251.12.64 255.255.255.192 10.90.247.30 240

Hall of Fame Super Blue

Re: EIGRP and Floating static issue

Pramod

Ran the following test with "debug eigrp fsm" turned on

Initial State

==============

Using primary path - 192.168.15.2

=================================

shutdown interface to 192.168.15.2 so router

============================================

then uses static route

======================

ip route 10.251.12.64 255.255.255.192 192.168.15.3 240

SW2#debug eigrp fsm

EIGRP FSM Events/Actions debugging is on

SW2#

01:10:20: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, chan

ged state to down

01:10:21: %LINK-3-UPDOWN: Interface FastEthernet0/10, changed state to down

01:10:30: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.15.2 (Vlan102) is d

own: holding time expired

01:10:30: DUAL: linkdown: start - 192.168.15.2 via Vlan102

01:10:30: DUAL: Destination 192.168.15.0/24

01:10:30: DUAL: Destination 10.251.12.64/26

01:10:30: DUAL: Find FS for dest 10.251.12.64/26. FD is 2816, RD is 2816

01:10:30: DUAL: 192.168.15.2 metric 4294967295/4294967295 not found Dmin

is 4294967295

01:10:30: DUAL: Peer total/stub 0/0 template/full-stub 0/0

01:10:30: DUAL: Dest 10.251.12.64/26 (No peers) not entering active state.

01:10:30: DUAL: Removing dest 10.251.12.64/26, nexthop 192.168.15.2

01:10:30: DUAL: No routes. Flushing dest 10.251.12.64/26

01:10:30: DUAL: linkdown: finish

01:10:30: DUAL: dest(10.251.12.64/26) not active

01:10:30: DUAL: rcvupdate: 10.251.12.64/26 via Rstatic metric 2816/0

01:10:30: DUAL: Find FS for dest 10.251.12.64/26. FD is 4294967295, RD is 429496

7295 found

01:10:30: DUAL: RT installed 10.251.12.64/26 via 192.168.15.3

01:10:30: DUAL: Send update about 10.251.12.64/26. Reason: metric chg

01:10:30: DUAL: Send update about 10.251.12.64/26. Reason: new if

Bring interface to 192.168.15.2 back up

=======================================

router replaces static route with route

=======================================

received from 192.168.15.2

==========================

SW2#sh debug

EIGRP:

EIGRP FSM Events/Actions debugging is on

SW2#

01:11:57: %LINK-3-UPDOWN: Interface FastEthernet0/10, changed state to up

01:11:59: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, changed state to up

sh debug

01:12:32: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.15.2 (Vlan102) is up: new adjacenc

y

01:12:34: DUAL: dest(10.251.12.64/26) not active

01:12:34: DUAL: rcvupdate: 10.251.12.64/26 via 192.168.15.2 metric 2816/256

01:12:34: DUAL: Find FS for dest 10.251.12.64/26. FD is 2816, RD is 2816

01:12:34: DUAL: 192.168.15.3 metric 2816/0

01:12:34: DUAL: 192.168.15.2 metric 2816/256 found Dmin is 2816

01:12:34: DUAL: RT installed 10.251.12.64/26 via 192.168.15.2

01:12:34: DUAL: Send update about 10.251.12.64/26. Reason: new if

01:12:34: DUAL: rcvupdate: 10.251.12.64/26 via Redistributed metric 4294967295/4294967295

01:12:34: DUAL: Find FS for dest 10.251.12.64/26. FD is 2816, RD is 2816

01:12:34: DUAL: 192.168.15.2 metric 2816/256

01:12:34: DUAL: 192.168.15.3 metric 4294967295/4294967295 found Dmin is 2816

01:12:34: DUAL: Removing dest 10.251.12.64/26, nexthop 192.168.15.3

01:12:34: DUAL: RT installed 10.251.12.64/26 via 192.168.15.2

As you can see it all works fine for me. Perhaps you could run this debug out of hours to see what you get ?

Jon

217
Views
0
Helpful
3
Replies
CreatePlease to create content