Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EIGRP/BGP routing loop Help

Hi Guys.I am trying to learn BGP and  I have been playing around with a BGP lab config using GNS3. It calls for different autonomous systems running different IGPs and these atonomous systems are connected via eBGP. iBGP is also running withing the AS.  The router are are all connected via loop back addresses. To achieve full BGP connectivity the redistibute connected command is used under the BGP process on each router. There is no redistribution with IGPs. No filtering or router manipulaiton is being performed as yet.

There is a problem within the AS that is running EIGRP and iBGP. When i do the debug ip routing and debug bgp updates on these routers i see where the router's   loopback is being learn by learn via iBGP and then withdrawn and the relearned via EIGRP and the flapping continues. I have shut down all outgoing connections from these routers and they are in essence connected back to back just now and the problem still continues.

I would love some advice on this issue. Thanks in advance.

Some configs are listed below.

-------R6------R7-------

R6#sho ver

Cisco IOS Software, 3700 Software (C3745-ADVENTERPRISEK9_IVS-M), Version 12.4(15)T8, RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by Cisco Systems, Inc.

Compiled Mon 01-Dec-08 20:17 by prod_rel_team

ROM: ROMMON Emulation Microcode

ROM: 3700 Software (C3745-ADVENTERPRISEK9_IVS-M), Version 12.4(15)T8, RELEASE SOFTWARE (fc3)

R6 uptime is 3 days, 19 hours, 54 minutes

System returned to ROM by unknown reload cause - suspect boot_data[BOOT_COUNT] 0x0, BOOT_COUNT 0, BOOTDATA 19

System image file is "tftp://255.255.255.255/unknown"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Cisco 3745 (R7000) processor (revision 2.0) with 249856K/12288K bytes of memory.

Processor board ID FTX0945W0MY

R7000 CPU at 350MHz, Implementation 39, Rev 2.1, 256KB L2, 512KB L3 Cache

3 FastEthernet interfaces

DRAM configuration is 64 bits wide with parity enabled.

151K bytes of NVRAM.

16384K bytes of ATA System CompactFlash (Read/Write)

Configuration register is 0x2102

R6: sho run

!

interface Loopback0

ip address 6.6.6.6 255.255.255.255

!

interface FastEthernet0/0

ip address 192.168.46.6 255.255.255.0

shutdown

speed 100

full-duplex

!

interface FastEthernet0/1

ip address 192.168.56.6 255.255.255.0

shutdown

speed 100

full-duplex

!

interface FastEthernet1/0

ip address 192.168.67.6 255.255.255.0

duplex auto

speed auto

!

router eigrp 10

network 6.6.6.6 0.0.0.0

network 192.168.67.0

no auto-summary

!

router bgp 200

no synchronization

bgp log-neighbor-changes

redistribute connected

neighbor 4.4.4.4 remote-as 300

neighbor 4.4.4.4 ebgp-multihop 2

neighbor 4.4.4.4 update-source Loopback0

neighbor 5.5.5.5 remote-as 300

neighbor 5.5.5.5 ebgp-multihop 2

neighbor 5.5.5.5 update-source Loopback0

neighbor 7.7.7.7 remote-as 200

neighbor 7.7.7.7 update-source Loopback0

no auto-summary

!

ip forward-protocol nd

ip route 4.4.4.4 255.255.255.255 192.168.46.4

ip route 5.5.5.5 255.255.255.255 192.168.56.5

R7: sho run

!

interface Loopback0

ip address 7.7.7.7 255.255.255.255

!

interface FastEthernet0/0

ip address 192.168.67.7 255.255.255.0

speed 100

full-duplex

!

interface FastEthernet0/1

ip address 192.168.117.7 255.255.255.0

shutdown

duplex auto

speed auto

!

router eigrp 10

network 7.7.7.7 0.0.0.0

network 192.168.67.0

auto-summary

!

router bgp 200

no synchronization

bgp log-neighbor-changes

redistribute connected

neighbor 6.6.6.6 remote-as 200

neighbor 6.6.6.6 update-source Loopback0

neighbor 11.11.11.11 remote-as 400

neighbor 11.11.11.11 password VAULT

neighbor 11.11.11.11 ebgp-multihop 2

neighbor 11.11.11.11 update-source Loopback0

no auto-summary

!

ip forward-protocol nd

ip route 11.11.11.11 255.255.255.255 192.168.117.11

R6: debug ip routing and debug bgp updates

!

Mar  4 19:59:03.597: RT: del 7.7.7.7/32 via 7.7.7.7, bgp metric [200/0]

*Mar  4 19:59:03.601: RT: delete subnet route to 7.7.7.7/32

*Mar  4 19:59:03.601: RT: NET-RED 7.7.7.7/32

*Mar  4 19:59:03.617: RT: Try lookup less specific 7.7.7.7/32, default 1

*Mar  4 19:59:03.621: RT: Found major net on less specific 7.0.0.0/8

--More--

*Mar  4 19:59:30.257: RT: network 7.0.0.0 is now variably masked

*Mar  4 19:59:30.261: RT: add 7.7.7.7/32 via 7.7.7.7, bgp metric [200/0]

*Mar  4 19:59:30.265: RT: NET-RED 7.7.7.7/32

--More--

*Mar  4 19:59:35.369: RT: del 7.7.7.7/32 via 7.7.7.7, bgp metric [200/0]

*Mar  4 19:59:35.373: RT: delete subnet route to 7.7.7.7/32

*Mar  4 19:59:35.377: RT: NET-RED 7.7.7.7/32

*Mar  4 19:59:35.389: RT: Try lookup less specific 7.7.7.7/32, default 1

*Mar  4 19:59:35.393: RT: Found major net on less specific 7.0.0.0/8

*Mar  4 20:01:34.265: RT: network 7.0.0.0 is now variably masked

*Mar  4 20:01:34.269: RT: add 7.7.7.7/32 via 7.7.7.7, bgp metric [200/0]

*Mar  4 20:01:34.273: RT: NET-RED 7.7.7.7/32

--More--

*Mar  4 20:01:39.377: RT: del 7.7.7.7/32 via 7.7.7.7, bgp metric [200/0]

*Mar  4 20:01:39.381: RT: delete subnet route to 7.7.7.7/32

*Mar  4 20:01:39.381: RT: NET-RED 7.7.7.7/32

*Mar  4 20:01:39.397: RT: Try lookup less specific 7.7.7.7/32, default 1

*Mar  4 20:01:39.401: RT: Found major net on less specific 7.0.0.0/8

The following also appears in the logs

*Mar  4 20:23:23.137: RT: recursion error routing 7.7.7.7 - probable routing loop

*Mar  4 20:23:23.449: RT: recursion error routing 7.7.7.7 - probable routing loop

*Mar  4 20:23:23.917: RT: recursion error routing 7.7.7.7 - probable routing loop

*Mar  4 20:23:24.057: RT: recursion error routing 7.7.7.7 - probable routing loop

*Mar  4 20:23:24.065: RT: recursion error routing 7.7.7.7 - probable routing loop

--More--

*Mar  4 20:23:24.669: RT: recursion error routing 7.7.7.7 - probable routing loop

*Mar  4 20:23:25.289: RT: recursion error routing 7.7.7.7 - probable routing loop

--More--

*Mar  4 20:23:25.893: RT: recursion error routing 7.7.7.7 - probable routing loop

--More--

*Mar  4 20:23:27.737: RT: recursion error routing 7.7.7.7 - probable routing loop

*Mar  4 20:23:28.357: RT: recursion error routing 7.7.7.7 - probable routing loop

--More--

*Mar  4 20:23:32.633: RT: recursion error routing 7.7.7.7 - probable routing loop

*Mar  4 20:23:33.297: RT: recursion error routing 7.7.7.7 - probable routing loop

--More--

*Mar  4 20:23:38.825: RT: del 7.7.7.7/32 via 7.7.7.7, bgp metric [200/0]

*Mar  4 20:23:38.829: RT: delete subnet route to 7.7.7.7/32

*Mar  4 20:23:38.833: RT: NET-RED 7.7.7.7/32

*Mar  4 20:23:38.849: RT: Try lookup less specific 7.7.7.7/32, default 1

*Mar  4 20:23:38.849: RT: Found major net on less specific 7.0.0.0/8

Mar  4 20:44:05.952: BGP(0): no valid path for 7.7.7.7/32

*Mar  4 20:44:06.044: BGP(0): nettable_walker 7.7.7.7/32 no best path

*Mar  4 20:44:06.048: RT: del 7.7.7.7/32 via 7.7.7.7, bgp metric [200/0]

*Mar  4 20:44:06.048: RT: delete subnet route to 7.7.7.7/32

*Mar  4 20:44:06.052: RT: NET-RED 7.7.7.7/32

*Mar  4 20:44:06.068: RT: Try lookup less specific 7.7.7.7/32, default 1

*Mar  4 20:44:06.072: RT: Found major net on less specific 7.0.0.0/8

R6#

*Mar  4 20:44:31.300: BGP(0): Revise route installing 1 of 1 routes for 7.7.7.7/32 -> 7.7.7.7(main) to main IP table

*Mar  4 20:44:31.304: RT: network 7.0.0.0 is now variably masked

*Mar  4 20:44:31.308: RT: add 7.7.7.7/32 via 7.7.7.7, bgp metric [200/0]

*Mar  4 20:44:31.312: RT: NET-RED 7.7.7.7/32

R6#

*Mar  4 20:44:36.328: BGP(0): no valid path for 7.7.7.7/32

*Mar  4 20:44:36.444: BGP(0): nettable_walker 7.7.7.7/32 no best path

*Mar  4 20:44:36.448: RT: del 7.7.7.7/32 via 7.7.7.7, bgp metric [200/0]

*Mar  4 20:44:36.448: RT: delete subnet route to 7.7.7.7/32

*Mar  4 20:44:36.448: RT: NET-RED 7.7.7.7/32

*Mar  4 20:44:36.456: RT: Try lookup less specific 7.7.7.7/32, default 1

*Mar  4 20:44:36.456: RT: Found major net on less specific 7.0.0.0/8

R6#

*Mar  4 20:45:02.556: BGP(0): Revise route installing 1 of 1 routes for 7.7.7.7/32 -> 7.7.7.7(main) to main IP table

*Mar  4 20:45:02.560: RT: network 7.0.0.0 is now variably masked

*Mar  4 20:45:02.564: RT: add 7.7.7.7/32 via 7.7.7.7, bgp metric [200/0]

*Mar  4 20:45:02.568: RT: NET-RED 7.7.7.7/32

R6#

Thanks in advance.

Marlon

1 ACCEPTED SOLUTION

Accepted Solutions

EIGRP/BGP routing loop Help

Hello.

EIGRP is using auto-summary that is causing the issue.

In your case EIGRP is advertising classful route (like 7.0.0.0/8), but your BGP peer is advertising more specific 7.7.7.7/32 that will be [recursively] used in the next-hop.

PS: the issue you are observing is not "routing loop" it's a "recursive routing" issue.

PS2: route to iBGP peers [next-hops and tcp endpoints] must be always known/learnt via IGP.

2 REPLIES

EIGRP/BGP routing loop Help

Hello.

EIGRP is using auto-summary that is causing the issue.

In your case EIGRP is advertising classful route (like 7.0.0.0/8), but your BGP peer is advertising more specific 7.7.7.7/32 that will be [recursively] used in the next-hop.

PS: the issue you are observing is not "routing loop" it's a "recursive routing" issue.

PS2: route to iBGP peers [next-hops and tcp endpoints] must be always known/learnt via IGP.

New Member

EIGRP/BGP routing loop Help

Thank you very much. I saw the error and corrected it. That problem is now solved. I now have some route flapping the other routers that i need to sort out. Thanks again.

156
Views
0
Helpful
2
Replies