cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
686
Views
0
Helpful
3
Replies

EIGRP config issue

Sharkey13
Level 1
Level 1

Hello - I have what should be an easy configuration issue that I cannot figure out.

Description:  I have three routers (D, P, and V) that are connected to each other.  All configured with EIGRP.  Router P connects to core network.

Problem:  Router D logs the following syslog error messages (lots of them):
192.168.101.122 96687: Router D: 096684: Oct 19 8:08:05.010: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 2: Neighbor 192.168.100.65 (Serial0/1/0.216) is up: new adjacency
192.168.101.122 96686: Router D: 096683: Oct 19 8:08:00.394: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 2: Neighbor 192.168.100.65 (Serial0/1/0.216) is down: Interface Goodbye received

Also, all traffic from router D traverses through router V, rather than utilizing default route to router P.

Relevant configuration:

Router D:
interface Serial0/1/0.16 point-to-point
description connection to V
ip address 192.168.101.122 255.255.255.252
frame-relay interface-dlci 16
!
interface Serial0/1/0.216 point-to-point
description connection to P
ip address 192.168.100.66 255.255.255.252
frame-relay interface-dlci 216

router eigrp 2
network 192.168.100.64 0.0.0.3
network 192.168.101.120 0.0.0.3
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 192.168.100.65

Router P:
interface ATM3/0.35 point-to-point
description connection to V
ip address 192.168.101.114 255.255.255.252
pvc 1/35
  vbr-nrt 15000 15000
!
interface ATM3/0.131 point-to-point
description connection to D
ip address 192.168.100.65 255.255.255.252
pvc 3/131
  vbr-nrt 1536 1536

router eigrp 2
redistribute static
network 192.168.100.64 0.0.0.3
network 192.168.101.112 0.0.0.3
no auto-summary

!

ip route 0.0.0.0 0.0.0.0 <internal core network>

Router V:
interface ATM1/0.32 point-to-point
description ATM connection to P
ip address 192.168.101.113 255.255.255.252
pvc 1/32
  vbr-nrt 15000 15000
!
interface ATM1/0.35 point-to-point
description ATM connection to D
ip address 192.168.101.121 255.255.255.252
pvc 1/35
  vbr-nrt 1536 1536

router eigrp 2
redistribute static
network 192.168.101.112 0.0.0.3
network 192.168.101.120 0.0.0.3
no auto-summary

!

ip route 0.0.0.0 0.0.0.0 192.168.101.114

What do I have misconfigured/omitted?

Thank you, Patrick

1 Accepted Solution

Accepted Solutions

Peter Paluch
Cisco Employee
Cisco Employee

Patrick,

One thing coming to my mind is that there are perhaps problems with the multicast packet delivery. EIGRP uses multicast Hello packets sent to 224.0.0.10 to discover neighbors and maintain adjacencies. If by any obscure reason there is a problem in delivering these multicasts (especially in one direction only), this could be the reason for your problems.

Can you modify your configuration using the neighbor commands in the EIGRP configuration to define static neighbors? This will force EIGRP to use only unicast communication to speak to the defined neighbors.

So, on D, add these commands:

router eigrp 2

neighbor 192.168.100.65 Serial0/1/0.216

neighbor 192.168.101.121 Serial0/1/0.16

On P, add these commands:

router eigrp 2

neighbor 192.168.100.66 ATM3/0.131

neighbor 192.168.101.113 ATM3/0.35

On V, add these commands:

router eigrp 2

neighbor 192.168.101.114 ATM1/0.32

neighbor 192.168.101.122 ATM1/0.35

This is a disrupting operation - until the neighbors are correctly configured on both sides of a PVC, the EIGRP adjacency will be torn down.

Please do verify these commands carefully - I am not familiar with your addressing scheme and I may have made errors in the IPs and the interfaces.

Also, verify that on all routers, the show ip eigrp neighbor shows you two EIGRP neighbors over the ATM/Frame Relay interfaces, and verify that the Q Cnt column is zero for all of them (if a non-zero value persists there then with certainty, there is a communication problem between these neighbors - multicast problems as indicated earlier, MTU mismatches, possibly other issues).

Best regards,

Peter

View solution in original post

3 Replies 3

Peter Paluch
Cisco Employee
Cisco Employee

Patrick,

One thing coming to my mind is that there are perhaps problems with the multicast packet delivery. EIGRP uses multicast Hello packets sent to 224.0.0.10 to discover neighbors and maintain adjacencies. If by any obscure reason there is a problem in delivering these multicasts (especially in one direction only), this could be the reason for your problems.

Can you modify your configuration using the neighbor commands in the EIGRP configuration to define static neighbors? This will force EIGRP to use only unicast communication to speak to the defined neighbors.

So, on D, add these commands:

router eigrp 2

neighbor 192.168.100.65 Serial0/1/0.216

neighbor 192.168.101.121 Serial0/1/0.16

On P, add these commands:

router eigrp 2

neighbor 192.168.100.66 ATM3/0.131

neighbor 192.168.101.113 ATM3/0.35

On V, add these commands:

router eigrp 2

neighbor 192.168.101.114 ATM1/0.32

neighbor 192.168.101.122 ATM1/0.35

This is a disrupting operation - until the neighbors are correctly configured on both sides of a PVC, the EIGRP adjacency will be torn down.

Please do verify these commands carefully - I am not familiar with your addressing scheme and I may have made errors in the IPs and the interfaces.

Also, verify that on all routers, the show ip eigrp neighbor shows you two EIGRP neighbors over the ATM/Frame Relay interfaces, and verify that the Q Cnt column is zero for all of them (if a non-zero value persists there then with certainty, there is a communication problem between these neighbors - multicast problems as indicated earlier, MTU mismatches, possibly other issues).

Best regards,

Peter

Peter- first of all, thank you for your very informative, concise response.

Sh ip eigrp nei on router P showed the following:

P#sh ip eigrp nei
IP-EIGRP neighbors for process 2
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)                           Cnt Num
1   192.168.100.66          AT3/0.131         13 00:00:01   16  1012  1  339487

A check of the MTU settings on each of the interfaces between routers P and D did indeed show an MTU mismatch.  So, I set the MTU on the P router to 1500 (it was 4470) and all problems vanished.  Syslog errors stopped, all routing is occuring is it should.

Bravo!

Thanks again.

Patrick

Patrick,

It was a pleasure. You are heartily welcome.

Best regards,

Peter

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card