Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EIGRP contingency

hello.

there is a router run eigrp and ospf, and when redistribute from eigrp to ospf, only route learned from other neighbors, which mean didn't redistribute its own route ( directly connected ), could somebody explain what kind of situation is this ? configuration was really simple. no filtering no route-map, just has a passive-interface, but when get that way, still same situation.

3 REPLIES

Re: EIGRP contingency

Do you have your connected interfaces IP covered under the n/w command in the EIGRP AS. Do you have router condifgured as EIGRP STUB router.

It will be handy to see the config of your router.

regards,

-amit singh

New Member

Re: EIGRP contingency

with configuration as below,,, 2.2.2.2/24 and 2.2.14.0/24 is not show on the ospf side....

without passive default, same result

interface Loopback0

ip address 2.2.2.2 255.255.255.0

!

interface FastEthernet0/0

ip address 2.2.14.2 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address 2.2.235.2 255.255.255.0

encapsulation frame-relay

ip ospf message-digest-key 1 md5 cisco

ip ospf priority 0

no fair-queue

frame-relay map ip 2.2.235.3 203 broadcast

frame-relay map ip 2.2.235.5 205 broadcast

no frame-relay inverse-arp

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

!

router eigrp 2

redistribute ospf 1 metric 10000000 1000 255 1 1500

passive-interface default

no passive-interface FastEthernet0/0

network 2.2.2.2 0.0.0.0

network 2.2.14.2 0.0.0.0

no auto-summary

!

router ospf 1

router-id 2.2.2.2

log-adjacency-changes

area 0 authentication message-digest

redistribute eigrp 2 metric 100 subnets

redistribute connected metric 200 subnets route-map con

network 2.2.235.2 0.0.0.0 area 0

distance 171 0.0.0.0 255.255.255.255

!

ip http server

ip classless

!

!

Bronze

Re: EIGRP contingency

You need to add those to the OSPF configuration. You cannot pull this into EIGRP and than to OSPF because they are on the same router. EIGRP will only redistribute what it learns from it's neighbors.

So you would need to add this to your ospf configuration.

network 2.2.2.2 0.0.0.0 area x

network 2.2.14.0 0.0.0.255 area x

Daniel

114
Views
0
Helpful
3
Replies
CreatePlease login to create content