Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EIGRP customer into BGP vendor

On our 3825 C3825-IPBASEK9-M), Version 12.4(8c) router. we deployed EIRGP into the vendor's BGP.

We thought that the vendor router would pick up our eigrp network entries but it did not.

Background:

We are in the midst of deploying a new network site by site so we had all our remote site networks that are not yet transitioned to the new vedor coded in our EIRGP config so that as sites are connected to the new vendor that new router will know all the remote site networks.

We resolved it by redistribution of our static + using a IP prefix-list to limit which static were allowed to be distributed.

Were we wrong in thinking that just creating the following would be all we needed? (provided that vendor had their BGP set up correctly which we believe they did.)

router eigrp 200

network 10.x.x.x wildcard

There are about 25 networks in this list.

In addition we still had our old static list as well that are still in use until we migrate completely to the new vendor.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: EIGRP customer into BGP vendor

"So we both need to use the same routing protocol in order to make this work? "

Yes.

You are currently using static routing which is a possibility but requires manual updates during the migration.

The easiest way would be they agree to speak EIGRP with you but you have to talk to them in any case.

Laurent.

9 REPLIES
Cisco Employee

Re: EIGRP customer into BGP vendor

Hi John,

It's hard to follow you in your description.

What do you mean by:

"we deployed EIRGP into the vendor's BGP"

The following could help:

- A drawing describing your topology and your routing policy

- Router configuration

- More details about what didn't work

Thanks

Laurent.

New Member

Re: EIGRP customer into BGP vendor

Thanks for help

"we deployed EIRGP into the vendor's BGP" = we were broadcasting our networks out to the NTT router via eigrp (so we thgought)

We have router on stick topolgy.

I have included the config of the router before we made added the redistribute and prefix-list that I mentioned in previous msg.

What did not work before adding the redis and prefix-list?

The vendor told us that he could not see the networks that were in our router eigrp 200 list that we thought would be broadcast out and that his BGP would pick up.

Bronze

Re: EIGRP customer into BGP vendor

You have to broadcast out BGP for them to pick up your routes, or they have to run EIGRP.

Whenever you have two clouds using different routing protocols, they won't exchange information. One of you has to run a protocol that the other is using. Either you can put a BGP statement into your router, or they can copy your EIGRP router statement.

I'd suggest you copy their BGP and you do the redistribution into EIGRP yourself if you really need to run an internal routing protocol.

New Member

Re: EIGRP customer into BGP vendor

If your ISP manages the BGP, you don't need to do anything. Tell them your inside subnets and ask them to advertise for you. Your EIGRP should reflect your internal LAN and that's it. Your vendor is responsible for sending you the BGP to eigrp and advertising your LAN routes.

I did a similar install but with OSPF

regards

jeff

New Member

Re: EIGRP customer into BGP vendor

The vendor does manage the BGP and we agree with you, we thought that putting them in EIGRP was all that we needed to do. The issue here is that we are migrating from one vendor to another site by site. So as you can see in our router config we have all our remote networks listed under the router eigrp 200 statement.

I forgot to show this but the other vendor router is still connected to our LAN at the same time as the new vedor thus the reason we have the static routes pointing to that router and/or a firewall.

So what command does the new vendor need to apply in their router to see and publish the other routes to the site as it is brought on board?

Cisco Employee

Re: EIGRP customer into BGP vendor

John,

Configuring network statements into EIGRP process doesn't mean EIGRP will send them as new updates. Those statement are here to activate EIGRP on the desired interface. Of course if the router as an interface in each networks, they will be announced to any other EIGRP neighbors.

What you have to do is to talk to NTT and agree with them on a common routing protocol you will share to exchange updates (EIGRP, BGP,..). When it's done, each one will configure his router to apply the agreement.

HTH

Laurent.

New Member

Re: EIGRP customer into BGP vendor

So we both need to use the same routing protocol in order to make this work?

We still have about 10 more sites to migrate into the new network. \

You said:

"Of course if the router as an interface in each networks, they will be announced to any other EIGRP neighbors."

This is not the case with us as all the networks in that list are remote with one exception; the 10.49.x.x is local.

They are using BGP from CE out to MPLS cloud and we are using eirgp.

So our work around was to distr all the statics and filter out what we did not want to broadcast into the new network. But that work around was a suprise to us.

Is there an easier way to make our networks known to the new vedor network (NTT) without doing the changes I just mentioned?

New Member

Re: EIGRP customer into BGP vendor

I do something similar. I run BGP with my provider of my MPLS network but EIGRP internally. I have both Eigrp and BGP running on the routers between me and my provider. When i first set it up I forgot to include the default-metric but this has been working well in my case.

router eigrp 10

redistribute static

network 10.0.0.0

network 172.17.0.0

default-metric 10000 100 255 1 1500

no auto-summary

!

router bgp 65006

no synchronization

bgp log-neighbor-changes

bgp redistribute-internal

network 172.17.2.0 mask 255.255.254.0

redistribute connected metric 100

redistribute eigrp 10

neighbor 10.1.1.86 remote-as 13979

neighbor 10.1.1.86 soft-reconfiguration inbound

no auto-summary

The problem that I am starting to run into though is that I now need to get the default route out of BGP at some of my larger sites and into EIGRP at the same time. This is now due to me having multiple physical paths out to the internet and need the default to change facilities depending on which internet link is in production.

Cisco Employee

Re: EIGRP customer into BGP vendor

"So we both need to use the same routing protocol in order to make this work? "

Yes.

You are currently using static routing which is a possibility but requires manual updates during the migration.

The easiest way would be they agree to speak EIGRP with you but you have to talk to them in any case.

Laurent.

211
Views
0
Helpful
9
Replies