Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EIGRP default route filter

I try to filter default route by command like that

   default-information {in | out} {access-list-number | access-list-name}

   I build a default route and redistribute static route in order that default route can be learnt by other eigrp routers. Then I try to filter default route by command default-information, but it does not work. I also use other method to advertise default route and also could not filter default route by this command.

   How does this command use and why it could not be used to filter default route?

Thanks a lot

Martin

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: EIGRP default route filter

"No Default-information in" has no effect on an actual default route (0.0.0.0/0). It impacts routes with the candidate default bit set, which happens based on the "ip default-network x.x.x.x" command. Same word, but different meaning.

Sent from Cisco Technical Support iPad App

7 REPLIES
New Member

EIGRP default route filter

Hi Martin,

Do you want to prevent one of the eigrp neighbhors from learning the default route ?

did you use default information in ?


Can you post the exact configuration you made ?

To supress the candidate default route you need to use

no default-information in | out


Regards Vinayak
New Member

EIGRP default route filter

R3(F1/0)---(F1/0)R1(F0/0)—(F0/0)R2

R1

interface FastEthernet0/0

ip address 192.168.12.1 255.255.255.0

!

interface FastEthernet1/0

ip address 192.168.13.1 255.255.255.0

!

router eigrp 1

redistribute static

network 192.168.0.0 0.0.255.255

!

ip route 0.0.0.0 0.0.0.0 192.168.13.3

R2

interface FastEthernet0/0

ip address 192.168.12.2 255.255.255.0

!

router eigrp 1

network 192.168.0.0 0.0.255.255

R3

interface FastEthernet1/0

ip address 192.168.13.3 255.255.255.0

!

router eigrp 1

network 192.168.0.0 0.0.255.255

!

R2 could learn default route from R1. I do not want R2 to learn this default route. So I try following two ways, but both of them do not work.

Method 1:

R1

router eigrp 1

no default-information out

method 2:

R2

router eigrp 1

no default-information in

EIGRP default route filter

have you reset the eigrp neighbor after implementing this command ?

Thanks

Ajay

New Member

EIGRP default route filter

clear ip eigrp 1 neighbor after no default-information in|out was implemented.

Bronze

Re: EIGRP default route filter

"No Default-information in" has no effect on an actual default route (0.0.0.0/0). It impacts routes with the candidate default bit set, which happens based on the "ip default-network x.x.x.x" command. Same word, but different meaning.

Sent from Cisco Technical Support iPad App

Cisco Employee

How do we filter an actual

How do we filter an actual default route (0.0.0.0/0) then?
Matching it using 0.0.0.0/0 in a prefix-list does not work. What can we do to stop one neighbor from receiving this default route?

I have a setup with following topology:

R1 --- R2 ---- Provider --- R3


R2 has the following config:

ip route 0.0.0.0 0.0.0.0 null0

router eigrp 90
redistribute static


I want R3 to receive the default route, but not R1.


Thanks,
Varun

Cisco Employee

I think I found my problem. I

I think I found my problem. I was using "permit 0.0.0.0/0" instead of "deny 0.0.0.0/0" in the prefix list to match the default route.

It's working now.

Thanks,
Varun

2013
Views
0
Helpful
7
Replies