Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

EIGRP error message intermitten

It seems that error message keeps coming out.Any idea? Attached is the config & error message.Thanks guys!

PTPtr113#

Interface IP-Address OK? Method Status Protocol

GigabitEthernet0/0 unassigned YES NVRAM up up

GigabitEthernet0/0.1 10.204.176.252 YES NVRAM up up

GigabitEthernet0/0.2 192.168.137.58 YES NVRAM up up

GigabitEthernet0/1 192.168.204.105 YES NVRAM up up

ATM1/0 unassigned YES NVRAM up up

Loopback0 10.1.0.113 YES NVRAM up up

PTPtr113#sh run int GigabitEthernet0/1

Building configuration...

Current configuration : 190 bytes

!

interface GigabitEthernet0/1

description PTP-SEN-Global - 34Mbps

bandwidth 29500

ip address 192.168.204.105 255.255.255.252

delay 200000

duplex auto

speed auto

media-type rj45

end

-------------------------------------

sentr102#

Interface IP-Address OK? Method Status Protocol

GigabitEthernet0/0 unassigned YES NVRAM up up

GigabitEthernet0/0.1 10.204.16.7 YES NVRAM up up

GigabitEthernet0/0.2 unassigned YES unset administratively down down

GigabitEthernet0/1 192.168.204.106 YES NVRAM up up

Loopback0 10.1.0.111 YES NVRAM up up

sentr102#sh run int GigabitEthernet0/1

Building configuration...

!

interface GigabitEthernet0/1

description SEN-PTP-GLobal - 34Mbps

bandwidth 29500

ip address 192.168.204.106 255.255.255.252

delay 200000

duplex auto

speed auto

media-type rj45

end

sentr102#sh log | i GigabitEthernet0/1

Sep 10 11:45:56.564 UTC: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor

192.168.204.105 (GigabitEthernet0/1) is up: new adjacency Sep 10 21:26:37.413 UTC: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor

192.168.204.105 (GigabitEthernet0/1) is down: holding time expired Sep 10 21:27:00.093 UTC: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor

192.168.204.105 (GigabitEthernet0/1) is up: new adjacency Sep 11 03:52:16.384 UTC: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor

192.168.204.105 (GigabitEthernet0/1) is down: holding time expired Sep 11 09:44:17.577 UTC: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor

192.168.204.105 (GigabitEthernet0/1) is up: new adjacency

Everyone's tags (3)
6 REPLIES

Re: EIGRP error message intermitten

Can you show us the output of "show ip eigrp interfaces" ?

What are the hello intervals configured on each interface?

Re: EIGRP error message intermitten

as suggested look at your EIGRP timers. also i noticed you have duplex, speed set to AUTO on your interfaces!! best to set speed and duplex manually?

Hall of Fame Super Gold

Re: EIGRP error message intermitten

Sam Lee

Without knowing a bit more about the topology of the network, it is difficult to say exactly what is going on. The error message that holding time expired is an indication that your router has sent EIGRP traffic to the neighbor (probably EIGRP HELLO messages) and has not received a response and so will terminate the neighbor relationship and wait till it has received a HELLO from the neighbor before it rebuilds the neighbor relationship.

Looking at the messages and their timestamps we can see that there is this sequence:

- 11:45:56 neighbor is up

- 21:26:37 neighbor is down (so it was up for 9 hours and 40 minutes)

- 21:27:00 neighbor is up (so it was down for 23 seconds)

- 3:52:16 neighbor is down (so it was up for 6 hours 25 minutes)

- 9:44:17 neighbor is up (so it was down for 5 hours 52 minutes)

So one of the incidents was very short and one was not. Without more information it is difficult to figure out what is going on. What is the connection to this neighbor? Are there signs of similar issues on the neighbor? Are there signs that there was any problem in the connection between the neighbors (especially in the problem that lasted over 5 hours)?

[edit] and unless there is a particular reason to hard code speed and duplex I believe that with todays equipment it is usually better to set speed and duples as auto.

HTH

Rick

Re: EIGRP error message intermitten

Rick...I thought hello's were unacknowledged in EIGRP? What sort of response to a hello packet are we talking about here...

Hall of Fame Super Gold

Re: EIGRP error message intermitten

Perhaps "response" was not the optimum choice of words. In establishing the EIGRP neighbor relationship the routers establish a time interval in which they need to hear EIGRP protocol traffic from the neighbor (typically HELLO messages) and they use the holding timer to track this. If the holding timer expires before the router receives EIGRP protocol traffic then it terminates the neighbor relationship.

HTH

Rick

Hall of Fame Super Silver

Re: EIGRP error message intermitten

Hello Sam,

EIGRP timers can be different for each neighbor in a link they don't need to match.

I would focus on another aspect:

the lack of QoS configuration.

your interface has the following description

description SEN-PTP-GLobal - 34Mbps

this makes me think you are using some WAN service or EoMPLS service that is limited to 34 Mbps.

you should on both sides do the following:

shape outbound at 33000 kbps

eventually depending on platform you may need to protect EIGRP packets using a CBWFQ.

a)

police shape-all-33Mbps

class class-default

shape average 33000000

service q-eigrp

access-list 111 permit eigrp any any

class-map eigrp_traffic

match access-group 111

policy-map q-eigrp

class eigrp_traffic

bandwith 500

class class-default

fair-queue

int g0/1

service-policy out shape-all-33Mbps

do this on both ends because the problem can be on the other side.

Hope to help

Giuseppe

Edit:

Rick is on a better path:

5 hours of neighbor down cannot be explained without an out of service of provider or remote device.

267
Views
0
Helpful
6
Replies
CreatePlease to create content