Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

EIGRP filter advertise

I have 3 routers in the same LAN, say R1(10.1.1.1),R2(10.1.1.2) and R3(10.1.1.3), they are running EIGRP now, how do let r1 and r2 communication each other tp form a eigrp neighbor without send any eigrp related packet to r3?

7 REPLIES
Purple

Re: EIGRP filter advertise

Hi,

One thing you could do is to use the neighbor statement under the EIGRP process on R1 and R2:

R1:

router eigrp 100

neighbor 10.1.1.2

R2:

router eigrp 100

neighbor 10.1.1.1

Hope that helps - pls do rate the post if it does.

Paresh

New Member

Re: EIGRP filter advertise

thanks for your reply. please look at my example:

R1(router)--------R2(Cat 3750 with lay3 enabled)----R3

r1:

router eigrp

network 12.12.12.0

r2:

int vlan 1

ip addr 12.12.12.2 255.255.255.0

router eigrp 10

network 12.12.12.0

neighbor 12.12.12.1 vlan 1 (define the r1 neighbor)

r3:

router eigrp 10

network 12.12.12.0

but from the r2, I show ip eigrp neighbor, not any neighbor can be seen. If I remove the "neighbor" command, I saw 2 neighbors.

New Member

Re: EIGRP filter advertise

by the way, are there any ways to implement this except "neighbor"?

Silver

Re: EIGRP filter advertise

Hi,

"if you want the outgoing routing updates alone be suppressed but the inbound updates continue to be received (and the routers still continue to be neighbors), then use the distribute-list command"

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080093f0a.shtml

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080208748.shtml

a 'distribute-list' in on R3, with sources R1/R2 denied?

Regards

Andrea

New Member

Re: EIGRP filter advertise

it is not routing update issue, I even don't want them to form eigrp neighbor even they are runnig the same eigrp and in the same AS.

New Member

Re: EIGRP filter advertise

Hi, perhaps make the interface to R3 passive.

Silver

Re: EIGRP filter advertise

Yep, use passive interface on R3

HTH

Andrea

529
Views
0
Helpful
7
Replies
CreatePlease to create content