Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

EIGRP IP summary

Hi All,

I have a doubt about " IP summary " command ,that is configured under interface section....

Assume , 192.168.1.1 ip is configured for Gi0/1 interface and advertized under EIGRP but "10.10.10.0/24" NOT configured under any interface but it is added into Tunnel 11 and want to advertise with summary address. Does it work ?

----------------SAMPLE Config----------------------

int gi0/1

ip address 192.168.1.1 255.255.255.0

router eigrp 1

network 192.168.1.0

Int tunnel 11

ip summary address eigrp 1 10.10.10.1 255.255.255.0

Thanks in Adv.

Sri

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

EIGRP IP summary

Sri

Using eigrp stub connected summary is an important detail that was not in the original post. And as you have found out it does have an important effect on routing behavior of EIGRP. When you configure a router as eigrp stub you are instructing the router that it is not to act as a transit router. This is the reason why the EIGRP neighbors do not send querry packets to a stub, because the stub router is not transit. This means that there are not any remote routes reachable through the stub. Even though the stub router has learned the 10.10.10.0 network it will not advertise it while it is a stub router. And if you remote the eigrp stub connected sumary then the router does advertise (and summarize) the network.

HTH

Rick

7 REPLIES
Hall of Fame Super Gold

EIGRP IP summary

Sri

There are a few small issues in the config that you post but the answer to your question is that yes the summary address configured on the tunnel could work.

Here is what it would take for it to work:

- there is a small syntax issue in your summary command and it should be this

ip summary address eigrp 1 10.10.10.0 255.255.255.0

(note the fourth octet of the address which should be 0 and not 1)

- the tunnel does not have an IP address configured. Without an IP address on the tunnel interface the tunnel will not carry IP traffic.

- when you configure an IP address on the tunnel then you also need to put a network statement into EIGRP that includes the tunnel into the EIGRP processing.

- some subnet of 10.10.10.0 must be present in the routing table if EIGRP is to summarize it.

With these things then the EIGRP summary should work.

HTH

Rick

New Member

EIGRP IP summary

Sorry Rick for sytax error...

Here is my config

--------------

int gi0/1

ip address 192.168.1.1 255.255.255.0

router eigrp 1

network 192.168.1.0

network 172.16.30.0

no auto

eigrp stub connected summary

Int tunnel 11

ip address 172.16.30.1 255.255.255.0

ip summary address eigrp 1 10.10.10.0 255.255.255.0

---------------------------------

10.10.10.0/24 network coming from down stream switch ( eigrp stub configured due to SIA issue). Yes, this route is in the routing table.

I added 10.10.10.0/24 network in summary route ,but it is not seen in other distrubution switch. ( when i remove stub,it work !. ) .  I am missing somthing here .please help

Thanks in Adv.

Sri

Hall of Fame Super Gold

EIGRP IP summary

Sri

Using eigrp stub connected summary is an important detail that was not in the original post. And as you have found out it does have an important effect on routing behavior of EIGRP. When you configure a router as eigrp stub you are instructing the router that it is not to act as a transit router. This is the reason why the EIGRP neighbors do not send querry packets to a stub, because the stub router is not transit. This means that there are not any remote routes reachable through the stub. Even though the stub router has learned the 10.10.10.0 network it will not advertise it while it is a stub router. And if you remote the eigrp stub connected sumary then the router does advertise (and summarize) the network.

HTH

Rick

New Member

Re: EIGRP IP summary

Rick. I understand.

One more question !

If  "eigrp stub" configured on router,  the router advertises Connected and Summary routes..

But if we have "eigrp stub connected summary" ,, is the same as "eigrp stub"?

Thanks

Sri

Hall of Fame Super Gold

EIGRP IP summary

Sri

When you configure eigrp stub there are several optional paramters that you might configure (including receive-only and static). eigrp stub connected summary are the defaults and are the same as eigrp stub.

This link has some helpful information about eigrp stub

http://www.cisco.com/en/US/docs/ios/12_0s/feature/guide/eigrpstb.html

HTH

Rick

New Member

EIGRP IP summary

Gone through same doc and had a doubt :-) .. i am now clear . Thanks you very much Rich - Sri

Hall of Fame Super Gold

EIGRP IP summary

Sri

I am glad that you are now clear about eigrp stub and that my responses were helpful. Thank you for using the rating system to mark the question as answered. This will be useful to other readers of the forum.

HTH

Rick

329
Views
0
Helpful
7
Replies
CreatePlease to create content