Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EIGRP Neighbor flapping between Core's on VLAN 48

Hello I am looking for help with this problem i am having.  6513 vlan48 connects to 3750-e switch

I can ping each side of that vlan ip address successfully

traceroute the ip address find

I can ping each side using the source ping option

ping ip 10.200.0.13 source vlan 48 works fine

I have check each port to look for any inputs errors, crc,frame,overrun,ignored etc... all are zero

The intefaces are not passive  

This the logging information from the 6513 switch

Sep 17 14:45:05: EIGRP: Packet from ourselves ignored

Sep 17 14:45:10: EIGRP: Packet from ourselves ignored

Sep 17 14:45:16: EIGRP: Packet from ourselves ignored

Sep 17 14:45:19: EIGRP: Packet from ourselves ignored

Sep 17 14:45:25: EIGRP: Packet from ourselves ignored

Sep 17 14:45:28: EIGRP: Packet from ourselves ignored

Sep 17 14:45:32: EIGRP: Packet from ourselves ignored

Sep 17 14:45:38: EIGRP: Packet from ourselves ignored

Sep 17 14:45:43: EIGRP: Packet from ourselves ignored

Sep 17 14:45:47: EIGRP: Packet from ourselves ignored

Sep 17 14:45:50: EIGRP: Packet from ourselves ignored

Sep 17 14:45:56: EIGRP: Packet from ourselves ignored

Sep 17 14:46:01: EIGRP: Packet from ourselves ignored

Sep 17 14:46:04: EIGRP: Packet from ourselves ignored

Sep 17 14:46:10: EIGRP: Packet from ourselves ignored

Sep 17 14:46:13: EIGRP: Packet from ourselves ignored

Sep 17 14:46:18: EIGRP: Packet from ourselves ignored

Sep 17 14:46:23: EIGRP: Retransmission retry limit exceeded

Sep 17 14:46:23: EIGRP: Holdtime expired

Sep 17 14:46:23.237 CDT: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 500: Neighbor 10.200.0.13 (Vlan48) is down: retry limit exceeded

Sep 17 14:46:23: EIGRP: Neighbor 10.200.0.13 went down on Vlan48

Sep 17 14:46:24: EIGRP: Packet from ourselves ignored

Sep 17 14:46:27: EIGRP: New peer 10.200.0.13

Sep 17 14:46:27.397 CDT: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 500: Neighbor 10.200.0.13 (Vlan48) is up: new adjacency

show ip eigrp interfaces

IP-EIGRP interfaces for process 500

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending

Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes

Vl48               1        0/0         0       0/1           50          63

6513 has a loopback address

3750e does not have a loopback address

I am sure there is more i need to give but I cant think of anything right now please i will provide

Everyone's tags (3)
2 ACCEPTED SOLUTIONS

Accepted Solutions

EIGRP Neighbor flapping between Core's on VLAN 48

Packet from ourselves ignored is probably coming from your loopback address. Do you need the no passive-interface Loopback0 in there for some reason?

EIGRP Neighbor flapping between Core's on VLAN 48

What is your loopback0 specifically doing? Loopbacks are typically used for routing and management but I'm curious if your loopback is actually doing these things.

38 REPLIES

EIGRP Neighbor flapping between Core's on VLAN 48

Can you post the config from both switches?

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

EIGRP Neighbor flapping between Core's on VLAN 48

Which part of the config you need to see because the 6513 config is really long and 3750e config is not bad?

EIGRP Neighbor flapping between Core's on VLAN 48

I should have explained myself better. We only need to see the eigrp section and possibly the "show ip eigrp neigh"

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: EIGRP Neighbor flapping between Core's on VLAN 48

From the 6513

spanning-tree mode rapid-pvst

spanning-tree portfast bpduguard default

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree vlan 1-47,49-4094 priority 8192

spanning-tree vlan 48 priority 4096

router eigrp 500

redistribute static

passive-interface default

no passive-interface Loopback0

no passive-interface Vlan48

network 10.200.0.0 0.0.0.3

network 10.200.0.12 0.0.0.3

distribute-list EIGRP_DL_CORE2 out Vlan48

no auto-summary

show ip eigrp neighbors

IP-EIGRP neighbors for process 500

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

0   10.200.0.13             Vl48              10 00:00:42    1  5000  2  0

4   172.16.             Vl23              12 2w5d        8   200  0  1056

2   172.16.            Vl23              10 6w5d        1   200  0  3628

1   172.16.            Vl23              10 6w5d        1   200  0  2880

6   10.200.0.1              Vl50              12 29w3d       6   300  0  4220

3   172.16.           Vl23              10 29w3d       6   200  0  4225

From the 3750e

spanning-tree mode rapid-pvst

spanning-tree portfast default

spanning-tree portfast bpduguard default

no spanning-tree optimize bpdu transmission

spanning-tree etherchannel guard misconfig

spanning-tree extend system-id

no spanning-tree vlan 214

spanning-tree vlan 48 priority 8192

router eigrp 500

distribute-list EIGRP_DL_CORE3 out Vlan48

network 10.200.0.12 0.0.0.3

passive-interface default

no passive-interface Vlan48

show ip eigrp neighbors

EIGRP-IPv4 Neighbors for AS(500)

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

0   10.200.0.10             Vl47              13 8w5d        3   200  0  4226

I told forgot about that show ip eigrp neighbors command

Still need help fixing that

Thank you

Re: EIGRP Neighbor flapping between Core's on VLAN 48

From the looks of the log, it looks like the hello packet is being reflected back somehow. Can you post the route map for the distribute-list? From the looks of it, you don't currently have an adjacency correct?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: EIGRP Neighbor flapping between Core's on VLAN 48

Well this project was given to me yesterday the previous network engineer was working on it, but no helpful notes.

When I show route-map on the 3750e nothing, on the 6513 it shows route-map to our F5 device

What is the command to enter to get exactly what you are looking for ?

Sorry i have not said this sooner thank you for helping with this problem.

EIGRP Neighbor flapping between Core's on VLAN 48

Can you post this acl from the two switches?

EIGRP_DL_CORE3

EIGRP_DL_CORE2

And you're welcome! I hope we can get it working for you

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: EIGRP Neighbor flapping between Core's on VLAN 48

Here you go I thought this is what you wanted, i took at the routes that i know that are nothing to do with this

I would like to get this fixed and learn from it so if i see this on another network i can fixed and refer people to here for great help.

6513

ip access-list standard EIGRP_DL_CORE2

permit 0.0.0.0

permit 172.16.255.3

permit 172.16.255.2

permit 172.16.255.1

permit 172.16.255.4

permit 10.200.0.0 0.0.0.3

permit 10.200.0.4 0.0.0.3

permit 10.200.0.8 0.0.0.3

permit 10.200.0.12 0.0.0.3

permit 10.1.6.0 0.0.0.255

permit 10.20.0.0 0.1.255.255

permit 10.100.6.0 0.0.1.255

permit 172.16.1.0 0.0.0.255

permit 172.16.2.0 0.0.0.255

permit 172.16.3.0 0.0.0.255

deny   any

from the 3750e

ip access-list standard EIGRP_DL_CORE3

permit 0.0.0.0

permit 172.16.255.3

permit 172.16.255.2

permit 172.16.255.1

permit 172.16.255.4

permit 10.200.0.8 0.0.0.3

permit 10.200.0.12 0.0.0.3

permit 10.200.0.4 0.0.0.3

permit 10.200.0.0 0.0.0.3

permit 172.16.5.0 0.0.0.255

permit 10.100.6.0 0.0.1.255

permit 10.1.0.0 0.0.3.255

permit 10.1.4.0 0.0.1.255

permit 10.2.0.0 0.0.255.255

permit 10.3.0.0 0.0.255.255

permit 172.16.0.32 0.0.0.15

permit 172.16.1.0 0.0.0.255

permit 172.16.2.0 0.0.0.255

permit 172.16.3.0 0.0.0.255

deny   any

If you see something that should be there asked i will send it

Thank you again for contiuning help me with this problem

Re: EIGRP Neighbor flapping between Core's on VLAN 48

Adam,

Robert mentioned it earlier, but it didn't dawn on me until now. I'd recommend you put your loopback interface back to passive. This may very well fix your issue. You're receiving the packet back to yourself on this interface I believe. Test that and let us know...

Thanks!

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: EIGRP Neighbor flapping between Core's on VLAN 48

Well, I will try to put the loopback into passive on the 6513 i have to schedule a maintence window for this. 

6513 has the loopback0 but the 3750e does not have a loopback

Question, on the other 6513 we have here that connects to 3750e on a different vlan is not showing flapping and the loopback0 is set the same as the other 6513 that is flapping, how can i make sure that the other 6513 is not flapping to?

Thank you for keep helping me with this problem !!!

Re: EIGRP Neighbor flapping between Core's on VLAN 48

"and the loopback0 is set the same as the other 6513 that is flapping,"

This may be part of the problem....I'm going to lab this up. Are you using the loopbacks as anycast addresses by chance? The loopback interface isn't used as a source (usually) and doesn't need to be in non-passive in order to be advertised. The only thing that non-passive does is allow for hellos to be sent out of the interface. If you're advertising the loopback into eigrp, it will still work if you put the loopback in passive.

Are the loopback interfaces /32 or a different mask?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***

Re: EIGRP Neighbor flapping between Core's on VLAN 48

Adam,

I don't get the same result with two loopbacks, so I'm not sure that's your issue either. Do you have a physical loop anywhere, even if on purpose? You should still try to put your interface in passive. Can you post the interface configurating? sh run int lo

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Re: EIGRP Neighbor flapping between Core's on VLAN 48

loopback0 from the flapping 6513

interface Loopback0

ip address 172.16.255.2 255.255.255.255

end

loopback0 from no flapping 6513

interface Loopback0

ip address 172.16.255.1 255.255.255.255

end

These loopback address are used alot in the ACL lines groups

you can see there are in the

EIGRP_DL_CORE2 and 3 lists

New Member

Re: EIGRP Neighbor flapping between Core's on VLAN 48

Adam,

Is it not possible that the 3750e is on the wrong vlan connecting to the 6500?

show ip eigrp neighbors

EIGRP-IPv4 Neighbors for AS(500)

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

0   10.200.0.10             Vl47              13 8w5d        3   200  0  4226

Thanks

Tony

EIGRP Neighbor flapping between Core's on VLAN 48

Packet from ourselves ignored is probably coming from your loopback address. Do you need the no passive-interface Loopback0 in there for some reason?

New Member

Re: EIGRP Neighbor flapping between Core's on VLAN 48

Well the loopback0 that helps with routing and and testing from what i know about it.

EIGRP Neighbor flapping between Core's on VLAN 48

What is your loopback0 specifically doing? Loopbacks are typically used for routing and management but I'm curious if your loopback is actually doing these things.

New Member

Re: EIGRP Neighbor flapping between Core's on VLAN 48

Well from what i know and see about the loopback setting are for routing and management.  Robert how can i test this to make sure the loopback is working correctly besides ping the loopback interface from any switch?

Thank you for your help as well Robert

EIGRP Neighbor flapping between Core's on VLAN 48

If the loopback is created, it should be doing what is needed. As John said, it shouldn't matter to make that passive since passive just stops eigrp hellos. The loopback interfaces don't need to be included in eigrp neighbor relationships. Even if you make it passive, it won't stop other things from working.

John also asked about loops. How many connections are there between the 3 switches?  Have you looked at sh cdp neighbor to see where you have connections between the switches?

Also, have you done any debugs on eigrp?

New Member

Re: EIGRP Neighbor flapping between Core's on VLAN 48

well loopbacks are include into many lists

there is two connections per device

so there are two connections from 6513 to other 6513,  two connections from 3750e to 6513 (flapping), two connections from 3750e to 6513.  all Connections are Fiber

I have do the show cdp neighbors details and summary command to verify those connections are connected

I have not done debugs on eigrp because last network guy did it still trying to find them and plus trying to get the

maintenance window to do this, looking like the window will have to be next week

I would like to see the debugs myself as well

I am going to change the loopback to passive in the maintenance

Bronze

Re: EIGRP Neighbor flapping between Core's on VLAN 48

Any chance you have a duplicated IP address so your unicast is broken? I think the loopback interface stuff is a rabbit trail. It appears you have multicast in both directions (because of entries in neighbor tables) but unicast only working in one direction. Since the Q count is 0 on the 3750, he is receiving acks successfully, bit the retry limit exceeded with a Q count value means the 6500 isn't getting acks.

Have you tried pinging with full packet sizes in case of mtu problem?

Sent from Cisco Technical Support iPad App

Re: EIGRP Neighbor flapping between Core's on VLAN 48

Donald,

I labbed this up and was able to get the same result:

interface Loopback1

ip address 1.1.1.2 255.255.255.255

end

R2(config-router)#network 1.1.1.0 0.0.0.255

R2(config-router)#

*Mar  1 00:24:04.643: EIGRP: Packet from ourselves ignored

*Mar  1 00:24:09.315: EIGRP: Packet from ourselves ignored

*Mar  1 00:24:14.215: EIGRP: Packet from ourselves ignored

Debug those packets:

*Mar  1 00:30:04.671: EIGRP: Sending HELLO on Loopback1

*Mar  1 00:30:04.675:   AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

*Mar  1 00:30:04.683: EIGRP: Received HELLO on Loopback1 nbr 1.1.1.2

Notice that I have a /24 mask for a /32 host. If I specify the /32, the error goes away. So, the loopback could be an issue without an address conflict.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Bronze

Re: EIGRP Neighbor flapping between Core's on VLAN 48

My point was not that the packet from ourselves message is not related to the retry limit exceeded, which is the real problem

New Member

Re: EIGRP Neighbor flapping between Core's on VLAN 48

well Donald how would you test to see if the unicast is broken ?

I have ping to the 3750e to 6513 and back with mtu size 1500 repeat 1000 also used source vlan 48 all are successfully no drop packets.

Well how would you fixed retry limit exceeded problem ?

New Member

EIGRP Neighbor flapping between Core's on VLAN 48

Hi,

Configure no auto-summary on 3750 switch and also check the any multicast packet blocks on the link......

Bronze

Re: EIGRP Neighbor flapping between Core's on VLAN 48

Is the mtu the same on both ends?  Is the problem continually happening?  Is there anything between the two routers/switches or are there other devices between them that could be creating an issue?  Check the arp entries to make sure that the mac address is what is expected (looking for a duplicate).

Another thing to try is to do the extended ping with a range of sizes and payloads rather than a fixed size.

New Member

Re: EIGRP Neighbor flapping between Core's on VLAN 48

Donald
I have ping both sides with different mtu size and repeat it like 100, 1000, 10000
MTU size i have try is 64, 1000, 1100, 1500.

There is nothing between these devices

We would it matter if arp entery to a mac address is being used by more than one device?

Bronze

Re: EIGRP Neighbor flapping between Core's on VLAN 48

Maybe I don't understand your question, but if the MAC address mapping in the ARP table is incorrect, then unicast will be delivered to the wrong device.  Pings would work (the wrong guy would be answering) but EIGRP wouldn't function.

New Member

Re: EIGRP Neighbor flapping between Core's on VLAN 48

Well Donald, I am litte confused myself by (

Check the arp entries to make sure that the mac address is what is expected (looking for a duplicate). 
Question

can you show me a example of this please

Thank you

1742
Views
40
Helpful
38
Replies