Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

eigrp neighbor flapping

Hello all,

i am facing one acute eigrp problem , getting error as below ,

%DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.140.10.1 (Vlan10) is down: retry limit exceeded.

Could any one solve my problem.

Regards

MR

16 REPLIES

Re: eigrp neighbor flapping

Can you connect to the neighbor address 10.140.10.1 - from the device that is reporting the EIGRP down?

New Member

Re: eigrp neighbor flapping

yes , i can connect from 10.140.10.2.

Re: eigrp neighbor flapping

OK - so is that IP address on a SVI, physical layer 3 or loopback interface?

Can you post both devices EIGRP config for review?

New Member

Re: eigrp neighbor flapping

conf on 10.140.10.2

interface Vlan10

ip address 10.40.10.2 255.255.255.0

ip helper-address 10.40.10.9

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim sparse-dense-mode

ip cgmp

no ip mroute-cache

load-interval 60

standby 2 ip 10.140.10.3

standby 2 priority 105

standby 2 preempt

arp timeout 28800

router eigrp 100

redistribute connected

redistribute static

network 10.0.0.0

no auto-summary

ip route 0.0.0.0 0.0.0.0 10.140.10.1

conf on 10.140.10.1

#sh run int g0/0

Building configuration...

Current configuration : 248 bytes

!

interface GigabitEthernet0/0

ip address 10.140.10.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

duplex auto

speed auto

media-type rj45

service-policy input Cos_in

end

router eigrp 100

redistribute connected

redistribute static

redistribute bgp 65000

network 10.0.0.0

default-metric 2000 10000 255 1 1500

no auto-summary

no eigrp log-neighbor-changes

!

Re: eigrp neighbor flapping

The config looks OK, can you post the output of

show ip protocols

show ip eigrp nei

show ip eigrp top

on both devices?

HTH>

New Member

Re: eigrp neighbor flapping

10.140.10.1 - its a router running bgp for WAN and eigrp for lan.

101.40.10.2 - its a L3 sw , running EIGRP for lan.

both are directly connected.

neighbour flaps every 1min 20 sec.

%DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.140.10.1 (Vlan10) is down: retry limit exc

eeded

%DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.140.10.1 (Vlan10) is up: new adjacency

think this will help u out.

Re: eigrp neighbor flapping

How long has this been going on?

I noticed you have HSRP running - do you have any failovers between the L3 primary switch and the secondary?

New Member

Re: eigrp neighbor flapping

yes hsrp is running , facing this prob since 2 days.

Re: eigrp neighbor flapping

are there any significant events on the logs?

Blue

Re: eigrp neighbor flapping

Hi:

Under vlan 10's SVI, I see you have 10.40.10.2 and the neighbor is supposed to be 10.140.10.1. Is that a typo under the vlan 10 interface?

Also, I see that you have a QoS policy applied to the neighbor interface, are you sure that the eigrp hellos are not being dropped to allow higher prority traffic to use that link?

You may want to isolate the problem to either a network issue or a higher layer problem with the hellos themselves. If it fails every 120 seconds, can you run an extended PING between routers to see if it fails?

HTH

New Member

Re: eigrp neighbor flapping

If you hello timer are different your adj will flap. Try hardcoding them on both sides. Check your cables if you haven't already

New Member

Re: eigrp neighbor flapping

Ping response is ok from router to switch. mtu is 1500 on both the side.

New Member

Re: eigrp neighbor flapping

observing SRTT 0, Any clues?

#SH IP EIGRP INTerfaces G0/0

IP-EIGRP interfaces for process 100

Xmit Queue Mean Pacing Time Multicast Pending

Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes

Gi0/0 2 0/0 0 0/1 50 0

New Member

Re: eigrp neighbor flapping

On 101.40.10.2 what is the system MTU set to?

Re: eigrp neighbor flapping

You said it started to do this 2 days ago - but before this everything was OK.

So what changed 2 days ago - EIGRP after being configured and forms a good neighbour does not suddenly stop working unless something has changed, either in config or physical or connectivity.

Check the logs to see what happend the time it started to flap.

New Member

Re: eigrp neighbor flapping

veriried, But didnt get any clue.

Then suspected Lan cable as it was about 50m long. chanbged it,then its started working fine.

looks strange, as i didn't see any packet drops on the interfaces , mtu fine, ping response was fine .

Lost option was to change the cable.

any way thanks every one.

Regards

Anil.

1116
Views
4
Helpful
16
Replies