Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

EIGRP Neighbors are flapping

I have a Cisco 7206 router connected to (2) Cisco 6513 Switches:  Basically,

7206----G1/1---------------------------G9/4---6513A

7206----G1/2---------------------------G9/4---6513B

Both interfaces are running eigrp and every couple of days or week, the eigrp neighbor relationships between them take hit.  See the output below for today

7206 Eigrp Config:

router eigrp 1075
redistribute bgp 65230 metric 10000 100 255 1 1500 route-map BGP_TO_IGP
passive-interface GigabitEthernet0/3
passive-interface GigabitEthernet1/0
passive-interface GigabitEthernet1/0.520
network 172.24.200.44 0.0.0.3
network 172.24.200.48 0.0.0.3
network 172.24.254.160 0.0.0.0
network 172.24.0.0
no auto-summary

----------------------------------------------------------------------------------------------

6513A

router eigrp 1075
passive-interface default
no passive-interface Vlan508
no passive-interface Vlan512
no passive-interface Vlan556
no passive-interface Vlan564
no passive-interface Vlan612
no passive-interface Vlan620
no passive-interface GigabitEthernet4/14
no passive-interface GigabitEthernet5/11
no passive-interface GigabitEthernet5/14
no passive-interface GigabitEthernet5/15
no passive-interface GigabitEthernet9/1
no passive-interface GigabitEthernet9/2
no passive-interface GigabitEthernet9/3
no passive-interface GigabitEthernet9/4
network 172.24.0.0
no auto-summary

-------------------------------------------------------------------------------------------------------

6513B

router eigrp 1075
passive-interface default
no passive-interface Vlan504
no passive-interface Vlan516
no passive-interface Vlan552
no passive-interface Vlan560
no passive-interface Vlan608
no passive-interface Vlan616
no passive-interface GigabitEthernet4/14
no passive-interface GigabitEthernet5/15
no passive-interface GigabitEthernet9/1
no passive-interface GigabitEthernet9/2
no passive-interface GigabitEthernet9/3
no passive-interface GigabitEthernet9/4
network 172.24.0.0
network 172.30.0.0
no auto-summary

---------------------------------------------------------------------------------------------------------

7206

Feb  5 07:10:13.808 PST: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1075: Neighbor 172.24.200.45 (GigabitEthernet0/2) is up: new adjacency
Feb  5 07:10:13.812 PST: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1075: Neighbor 172.24.200.49 (GigabitEthernet0/1) is up: new adjacency
Feb  5 07:10:13.876 PST: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1075: Neighbor 172.24.200.49 (GigabitEthernet0/1) is down: peer restarted
Feb  5 07:10:13.884 PST: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1075: Neighbor 172.24.200.45 (GigabitEthernet0/2) is down: peer restarted
Feb  5 07:10:13.912 PST: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1075: Neighbor 172.24.200.49 (GigabitEthernet0/1) is up: new adjacency
Feb  5 07:10:13.920 PST: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1075: Neighbor 172.24.200.45 (GigabitEthernet0/2) is up: new adjacency

6513A and 6513B

Feb  5 07:09:06 PST: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1075: Neighbor 172.24.200.50 (GigabitEthernet9/4) is down: holding time expired
Feb  5 07:09:09 PST: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1075: Neighbor 172.24.200.50 (GigabitEthernet9/4) is up: new adjacency
Feb  5 07:09:24 PST: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1075: Neighbor 172.24.200.50 (GigabitEthernet9/4) is down: holding time expired
Feb  5 07:09:46 PST: %SNMP-3-AUTHFAIL: Authentication failure for SNMP req from host 172.24.160.63
Feb  5 07:10:13 PST: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1075: Neighbor 172.24.200.50 (GigabitEthernet9/4) is up: new adjacency
Feb  5 07:10:13 PST: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1075: Neighbor 172.24.200.50 (GigabitEthernet9/4) is down: peer restarted
Feb  5 07:10:18 PST: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1075: Neighbor 172.24.200.50 (GigabitEthernet9/4) is up: new adjacency

I don't see any configurations errors, but don't know it is flapping?

1 REPLY

Re: EIGRP Neighbors are flapping

Hello

It could be due to various reasons as to why your EIGRP neighbors are flapping.. Taken from EIGRP guide:

  • Underlying link flaps. When an interface goes down, EIGRP takes down the neighbors that are reachable through that interface and flushes all routes learned through that neighbor.

  • Misconfigured hello and hold intervals. The EIGRP hold interval can be set independently of the hello interval if you issue the ip hold-time eigrp command. If you set a hold interval smaller than the hello interval, it results in the neighbors flapping continuously. Cisco recommends that the hold time be at least three times the hello interval. If the value is set less than 3 times the hello interval, there is the chance for link flapping or neighborship flapping.

  • Loss of hello packets: Hello packets can be lost on overly congested links or error-prone links (CRC errors, Frame errors, or excessive collisions).

  • Existence of unidirectional links. A router on a unidirectional link can be able to receive hello packets, but the hello packets sent out are not received at the other end. The existence of this state is usually indicated by the retry limit exceeded messages on one end. If the routers generating retry limit exceeded messages has to form neighborship, then make the link bidirectional for both unicast and multicast. In case tunnel interfaces are used in the topology make sure that the interfaces are advertised properly.

  • Route goes stuck-in-active. When a router enters the stuck-in-active state, the neighbors from which the reply was expected are reinitialized, and the router goes active on all routes learned from those neighbors.

  • Provision of insufficient bandwidth for the EIGRP process. When sufficient bandwidth is not available, packets can be lost, which causes neighbors to go down.

  • Bad serial lines.

  • Improperly set bandwidth statements.

  • One-way multicast traffic.

  • Stuck in active routes.

  • Query storms

  • See if you have any of these symptoms..

    Raj

    8798
    Views
    0
    Helpful
    1
    Replies
    CreatePlease to create content