Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

eigrp neighbors

Hi all,

could some one explain me how eigrp neighbors form. for ex. i have 2 routers and 2 l3 switches interconnected dia enclosed.

7 REPLIES
Hall of Fame Super Silver

Re: eigrp neighbors

raahi

There are several steps that happen when you make an interface active in EIGRP.

- when you configure an EIGRP network statement (configuring a mask on the network statement is optional) EIGRP evaluates the network statement (what network/subnet does it include) and scans all of the active interfaces looking for all interfaces that are included within that network statement.

- EIGRP becomes active on those interfaces.

- EIGRP sends hello messages on all interfaces which have become active.

- EIGRP listens for hello messages on the interfaces which have become active.

- when EIGRP receives an EIGRP hello on one of these interface it checks for several conditions: is the neighbor in the same EIGRP AS; is the neighbor source address in the same subnet of this interface.

- if the parameters in the EIGRP hello message are compatible then the neighbor process is initiated which will lead the neighbors to share their routing information and to become active neighbors.

HTH

Rick

New Member

Re: eigrp neighbors

fine, my problem : my routers are unable to form neighbor each other but swithces can .any static route is req. from both the routers ?

Re: eigrp neighbors

You router interfaces seem to be having different subnet ip adddress and hence will not form adjacencies between each other

Narayan

New Member

Re: eigrp neighbors

static routes will solve my prob. or ip address needs to be changed ?

Bronze

Re: eigrp neighbors

It will be great to see your configuration. But, take a look below.

left side:

router eigrp 2

network 1.1.1.0 0.0.0.255

network 1.1.2.0 0.0.0.255

network 1.1.4.0 0.0.0.255

network 1.1.5.0 0.0.0.255

Right side

router eigrp 2

network 1.1.1.0 0.0.0.255

network 1.1.2.0 0.0.0.255

network 1.1.4.0 0.0.0.255

network 1.1.3.0 0.0.0.255

New Member

Re: eigrp neighbors

router eigrp 51

redistribute connected

redistribute static

redistribute bgp as#

network 1.0.0.0

default-metric 2000 10000 255 1 1500

no auto-summary

no eigrp log-neighbor-changes

Hall of Fame Super Silver

Re: eigrp neighbors

raahi

There is not quite enough information here for us to find the problem. Would you post the output of show ip interface brief, and of show ip eigrp interface of the router of this post?

Also would you post the output of the EIGRP configuration, and of show ip interface brief and of show ip eigrp interface from the router that you want to be an EIGRP neighbor?

HTH

Rick

165
Views
0
Helpful
7
Replies
CreatePlease to create content