Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

EIGRP Network Advertising

Hi All,

Another EIGRP one.

On a router, If I only want to turn on EIGRP so an Interface listens for updates do I just use the following command.

EIGRP xxx

network interfaceIP 0.0.0.0

Does this then allow that Interface to form an adjacency and receive updates, but not actually advertise them?

While I'm here, is the same true for OSPF?

Thanks

4 REPLIES

EIGRP Network Advertising

In EIGRP, you can advertise on one interface, but it takes the network of that interface:

router eigrp 100

network 192.168.1.1 0.0.0.0

This would advertise whatever the 192.168.1.1 address/subnet mask is. If you have a /30 that's attached to 192.168.1.1, it will advertise that network.

If you do:

router eigrp 100

network 0.0.0.0

It will send hello packets out of every interface that is up/up.

OSPF is the same in regards of advertising, but you use areas on where  you want to send hello packets to.

router ospf 1

network 192.168.1.1 0.0.0.0 area 0

If you use:

router ospf 1

network 0.0.0.0 255.255.255.255 area 0

It will send hellos out of all of your interfaces that are up/up. You may not want that because you may want an interface adjacency in one area and another interface on the same router in another.

If you have two addresses 192.168.1.1 and 192.168.2.1, you could put them in separate areas under the same process:

router ospf 1

network 192.168.1.1 0.0.0.0 area 0

network 192.168.2.1 0.0.0.0 area 1

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Bronze

EIGRP Network Advertising

Hi John,

Thanks again!

If I use the network 0.0.0.0 this turns on hello packets to every interface, but still will only advertise the routes those interfaces are attached to?

If on Router A I have some routes which have been learned from another source somewhere up the network, can I advertise these routes via EIRP / OSPF, even though they are not directly attached?

Also, can static routes be advertised via EIGRP/OSPF using the network command under the process, or do these need to be redistributed?

EIGRP Network Advertising

Yes and yes for your first two questions. You will need to redistribute the static routes. The network command is primarily to establish a neighbor relationship and secondly to advertise the network configured on that interface as John described earlier.

EIGRP Network Advertising

I agree with Kwillacey. You'll need to redistribute your statics. The network 0.0.0.0 command sends hello packets out every interface, sometimes it's best to specify the actual address of the interface instead of doing this "catchall." So, yes, the addressing information that you have will be advertised.

If you have R1 ---- R2 ---- R3, and R2 has a neighborship to R1 and R3, R1 will know about R3's network on the interface that leads to 2 because it's now in the RIB. You can get into filtering and things to keep certain networks from getting into the routing table if needed though.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
144
Views
13
Helpful
4
Replies
CreatePlease login to create content