Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EIGRP network command

eigrp_2.jpg       

R0

====

interface Serial0/3/0

ip address 10.1.24.1 255.255.255.252

clock rate 64000

!

interface Serial0/3/1

ip address 10.1.34.1 255.255.255.252

clock rate 64000

!

interface Vlan1

no ip address

shutdown

!

router eigrp 25

network 10.1.34.1 0.0.0.0

network 10.1.24.1 0.0.0.0

network 172.16.0.0

auto-summary

R1

=====

interface FastEthernet0/0

ip address 10.1.2.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/3/0

ip address 10.1.34.2 255.255.255.252

!

router eigrp 25

network 10.1.34.2 0.0.0.0

network 10.1.2.0 0.0.0.255

auto-summary

R2

======

interface FastEthernet0/0

ip address 10.1.2.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 10.1.25.2 255.255.255.0

duplex auto

speed auto

!

interface Serial0/3/0

ip address 10.1.24.2 255.255.255.252

!

router eigrp 25

network 10.1.24.2 0.0.0.0

network 10.1.2.0 0.0.0.255

auto-summary

!

Now thank you for your patience since you are reading this now after going through all my network diagram.

R2 Routes

========

     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

C       10.1.2.0/24 is directly connected, FastEthernet0/0

C       10.1.24.0/30 is directly connected, Serial0/3/0

C       10.1.25.0/24 is directly connected, FastEthernet0/1

D       10.1.34.0/30 [90/2172416] via 10.1.2.1, 00:24:47, FastEthernet0/0  <-------why this is not 10.0.0.0/8

D    172.16.0.0/16 [90/2297856] via 10.1.24.1, 00:21:11, Serial0/3/0

Question: Please let me know

1> D route is not summarized to 10.0.0.0/8 as eigrp is known for auto-summarizaing to classful network

2> Please let me know if you have any doc which describes exact explanation of the network command

Thanks in advance

4 REPLIES
Cisco Employee

Re: EIGRP network command

Hello,

The auto-summary feature kicks in only when you are traversing different

major networks. EIGRP supports VLSM natively. So, it will not summarize when

you are using the same major network everywhere.

http://www.cisco.com/en/US/docs/ios/iproute_eigrp/command/reference/ire_i1.h

tml#wp1035205

Hope this helps.

Regards,

NT

Re: EIGRP network command

And as you can see in

D    172.16.0.0/16 [90/2297856] via 10.1.24.1, 00:21:11, Serial0/3/0

case, it does summarize to 172.16.0.0/16 when crossing a major network border (received via 10.1.24.1).

See also http://www.cisco.com/en/US/tech/tk365/technologies_white_paper09186a0080094cb7.shtml#auto

for an explanation.

BR,

Milan

New Member

Re: EIGRP network command

hmmm.....this makes sense...thank you very much

Cisco Employee

Re: EIGRP network command

Ravindra,

Regarding the network command itself: the network command essentially specifies a range of addresses, for example:

network 10.0.0.0 = a range of addresses from 10.0.0.0 to 10.255.255.255

network 172.16.0.64 0.0.0.31 = a range of addresses from 172.16.0.64 to 172.16.0.95

network 192.168.1.21 0.0.0.0 = a range of a single address, 192.168.1.21

Now, if any of your interfaces' IP address falls into any of these ranges specified by network commands then that particular interface will be added to the routing protocol and its real subnet/mask will be advertised to other routers. Note that the mask or the address specified in the network command itself is not advertised - its only purpose is to select an interface on which a particular routing protocol shall be activated. It may be confusing but it is the way it is. For example, if my interface is configured as 192.168.1.21/28 then I can include it into a routing protocol using the command network 192.168.1.21 0.0.0.0 and the router will subsequently advertise the network 192.168.1.16/255.255.255.248 which is the real network of this interface, despite the network command itself being different.

The difference between network 192.168.1.21 0.0.0.0 and 192.168.1.16 0.0.0.15 is obvious: the first way activates the routing protocol on that interface only if the interface has exactly the address 192.168.1.21. If the IP address of the interface changes, it won't be included in the routing protocol anymore. The second option allows the interface to have any IP address in the range of 192.168.1.16 up to 192.168.1.31 and the network from that interface will still be advertised. Note also that the subnet mask of that interface is not compared at all to the wildcard mask specified in the network statement.

IS-IS, OSPF and all IPv6 routing protocols make this issue far more comprehensible: they are activated directly on interfaces and not using the network statement, thereby not suffering from all this mess.

Best regards,

Peter

541
Views
0
Helpful
4
Replies