Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Eigrp on nbma network

frame-realy eigrp.jpeg.jpeg

hello,

eigrp running on frame relay topology(multipoint hub and spoke), i have assign loopback address on all three routers eigrp can form neighbor 172.16.124.0 netowrk but in hub router it don't have entry to both spoke loop address and i know split horizon stop  spoke to spoke advertise my point is about hub router has no entry to spoke loop address

here is my config

Router 1

interface Loopback1

ip address 10.1.1.1 255.255.255.0

!        

interface Loopback2

ip address 10.1.2.1 255.255.255.0

!        

interface Loopback3

ip address 10.1.3.1 255.255.255.0

!        

interface FastEthernet0/0

no ip address

shutdown

duplex half

!        

interface Serial1/0

ip address 172.16.124.1 255.255.255.248

encapsulation frame-relay

serial restart-delay 0

frame-relay map ip 172.16.124.3 103 broadcast

frame-relay map ip 172.16.124.2 102 broadcast

no frame-relay inverse-arp

!        

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

!        

interface Serial1/3

no ip address

shutdown

router eigrp 25

network 10.0.0.0

network 172.16.124.0 0.0.0.255

auto-summary

!        

ip forward-protocol nd

no ip http server

no ip http secure-server

R1#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks

D       172.16.0.0/16 is a summary, 00:05:45, Null0

C       172.16.124.0/29 is directly connected, Serial1/0

     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

C       10.1.3.0/24 is directly connected, Loopback3

C       10.1.2.0/24 is directly connected, Loopback2

C       10.1.1.0/24 is directly connected, Loopback1

D       10.0.0.0/8 is a summary, 00:04:34, Null0

Router 2

interface Loopback1

ip address 10.2.1.1 255.255.255.0

!        

interface Loopback2

ip address 10.2.2.1 255.255.255.0

!        

interface Loopback3

ip address 10.2.3.1 255.255.255.0

!        

interface FastEthernet0/0

no ip address

shutdown

duplex half

!        

interface Serial1/0

ip address 172.16.124.2 255.255.255.248

encapsulation frame-relay

serial restart-delay 0

frame-relay map ip 172.16.124.3 201 broadcast

frame-relay map ip 172.16.124.1 201 broadcast

no frame-relay inverse-arp

interface Serial1/4

!        

router eigrp 25

network 10.0.0.0

network 172.16.124.0 0.0.0.255

auto-summary

!        

ip forward-protocol nd

no ip http server

R2#sh ip rou

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks

D       172.16.0.0/16 is a summary, 00:05:35, Null0

C       172.16.124.0/29 is directly connected, Serial1/0

     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

C       10.2.1.0/24 is directly connected, Loopback1

C       10.2.2.0/24 is directly connected, Loopback2

D       10.0.0.0/8 is a summary, 00:05:34, Null0

C       10.2.3.0/24 is directly connected, Loopback3

Router 3

interface Loopback1

ip address 10.3.1.1 255.255.255.0

!

interface Loopback2

ip address 10.3.2.1 255.255.255.0

!

interface Loopback3

ip address 10.3.3.1 255.255.255.0

!

interface FastEthernet0/0

no ip address

shutdown

duplex half

!

interface Serial1/0

ip address 172.16.124.3 255.255.255.248

encapsulation frame-relay

serial restart-delay 0

frame-relay map ip 172.16.124.2 301 broadcast

frame-relay map ip 172.16.124.1 301 broadcast

no frame-relay inverse-arp

!

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

!

!

interface Serial1/5

no ip address

shutdown

router eigrp 25

network 10.0.0.0

network 172.16.124.0 0.0.0.255

auto-summary

!

ip forward-protocol nd

no ip http server

R3#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks

D       172.16.0.0/16 is a summary, 00:05:35, Null0

C       172.16.124.0/29 is directly connected, Serial1/0

     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

C       10.3.1.0/24 is directly connected, Loopback1

C       10.3.3.0/24 is directly connected, Loopback3

D       10.0.0.0/8 is a summary, 00:05:35, Null0

C       10.3.2.0/24 is directly connected, Loopback2

2 ACCEPTED SOLUTIONS

Accepted Solutions
Purple

Eigrp on nbma network

Hi,

On all routers:

router eigrp 25

no auto

After that you'll see the spokes networks on the hub and the hub networks on the spokes.

You'll also need to configure static frame-relay maps for the other spoke on the spokes if you want to ping the spoke networks without specifying the loopbacks as source interface.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Eigrp on nbma network

Auto-Summary in the EIGRP process will summarise your networks as they cross classful bondaries.

So when your 10.x.x.x loopbacks cross a classful boundary (the serial interface 172.16.xx.xx) they become back to there classful summary - 10.0.0.0/8.

3 REPLIES
Purple

Eigrp on nbma network

Hi,

On all routers:

router eigrp 25

no auto

After that you'll see the spokes networks on the hub and the hub networks on the spokes.

You'll also need to configure static frame-relay maps for the other spoke on the spokes if you want to ping the spoke networks without specifying the loopbacks as source interface.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Re:Eigrp on nbma network

What is the reason I have to mention no auto summary, it should send tht update to any obe spoke also I have entered wildcard mask. If I do summary like ip route summary eigrp25 can it send tht network update to spoke ?


Sent from Cisco Technical Support Android App

New Member

Eigrp on nbma network

Auto-Summary in the EIGRP process will summarise your networks as they cross classful bondaries.

So when your 10.x.x.x loopbacks cross a classful boundary (the serial interface 172.16.xx.xx) they become back to there classful summary - 10.0.0.0/8.

295
Views
0
Helpful
3
Replies
CreatePlease to create content