Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

EIGRP problem. I can´t install a static route into eigrp topology table

Hi all,

I have a problem to insert into EIGRP a per-user static route via RADIUS.

When RADIUS send av-pair to router the router install routes into routing table but, and this is my problem, EIGRP dont install into topology table only in certain case.

I can see that.


sh ip route static
U       82.199.35.1/32 [1/0] via 82.199.32.1
U       192.168.21.5 [1/0] via 82.199.36.238

both routes are assigned via user in RADIUS

userpp        Auth-Type := local, User-Password == "pass"
                Framed-IP-Address = 82.199.36.238,
                cisco-avpair += "ip:route#1=82.199.35.1 255.255.255.255 82.199.32.1",
                cisco-avpair += "ip:route#2=192.168.21.5 255.255.255.255 82.199.36.238",
                Service-Type = Framed-User,
                Framed-Protocol = PPP

but only the route that his nexthop is different to the user IP works.

sh ip eigrp topolo 82.199.35.1/32
IP-EIGRP (AS 10): Topology entry for 82.199.35.1/32
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2816
  Routing Descriptor Blocks:
  82.199.32.1, from Rstatic, Send flag is 0x0
      Composite metric is (2816/0), Route is External
      Vector metric:
        Minimum bandwidth is 1000000 Kbit
        Total delay is 10 microseconds
        Reliability is 255/255
        Load is 15/255
        Minimum MTU is 1500
        Hop count is 0
      External data:
        Originating router is 82.199.34.1 (this system)
        AS number of route is 0
        External protocol is Static, external metric is 0
        Administrator tag is 0 (0x00000000)

sh ip eigrp topology 192.168.21.5/32
% IP-EIGRP (AS 10): Route not in topology table

I am using IOS c7200-adventerprisek9-mz.124-24.T1.bin

But the same configuration (at least I think that) works well for both routes in other router

Somebody can help me?

thanks in advance.

El mensaje fue editado por: david.knet

3 REPLIES
Community Member

Re: EIGRP problem. I can´t install a static route into eigrp to

I found the solution.

I don´t know why but in this case EIGRP can't take the metric for static routes automatically. So as, i set into redistribution route the set metric command and the route start to appear into EIGRP topology table.

Somebody know some debug where i could see this behavior?

Hall of Fame Super Silver

Re: EIGRP problem. I can´t install a static route into eigrp to

Hello David,

now that I see it, it is a reasonable solution and you have been kind to provide feedback

about debug commands

may be the FSM debug may be of help

debug ip eigrp ?
  <1-65535>      AS number
  <1-65535>      Autonomous System
  neighbor       IP-EIGRP neighbor debugging
  notifications  IP-EIGRP event notifications
  summary        IP-EIGRP summary route processing
  vrf            Select a VPN Routing/Forwarding instance

debug eigrp ? 
  fsm        EIGRP Dual Finite State Machine events/actions
  neighbors  EIGRP neighbors
  nsf        EIGRP Non-Stop Forwarding events/actions
  packets    EIGRP packets
  transmit   EIGRP transmission events

note that there are two series of debug commands one with ip keyword and one without

Hope to help

Giuseppe

Community Member

Re: EIGRP problem. I can´t install a static route into eigrp to

Thank you Giuseppe,

I will try "debug eigrp fsm". I am sure that DUAL is the responsable for that.

I did try different debugs, including some "debug eigrp" but for some reason i didn't view fsm...

458
Views
5
Helpful
3
Replies
CreatePlease to create content