Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

EIGRP questions

We have a primary site and a backup site. EIGRP is running between our remote offices and our primary and backup sites. I followed cisco's preferred methond of setting a preferred route so that EIGRP routes to our primary site and the backup is just that, a backup. I followed the instructions located at http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800c2d96.shtml

and set the subinterfaces at our backup site with a higher delay (2500 vs 2000). However, traffic from the remote sites are still preferring that route, even after I increased the delay.

Second, I did enable stub routing at the remote sites, but there is a problem. Each remote site has 5 static routes (default route back to primary site, 2 default routes as backups to our backup site, 1 to the remote site LAN, and 1 to the remote site DMZ). There is a firewall between the remote site router and the remote site LAN/DMZ so those static routes will need to be redistributed. Can I do an 'eigrp stub connected summary static' and use a distribution-list out static with an ACL to limit the redistribution to just the LAN and DMZ routes?

Thanks for all the help. It's much appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: EIGRP questions

Glad that helped. I don't see 'redistribute static' under the EIGRP process and that's why it isn't getting advertised.

12 REPLIES

Re: EIGRP questions

Jake,

For question 1, EIGRP, by default, uses a combination of min bandwidth + total delay to calculate the composite metric. If the remote is preferring the backup route then it can be due to either it's not learning the route from the primary site or the metric is still preferred over the back up path and further tweaking of bandwidth/delay may be needed. Can you post the output of following command for any one network that's being learnt from the hub site, eg. show ip eigrp topology (192.168.1.0 255.255.255.0), where the network subnet mask has to be accurate. This would tell us why the router is preferring the backup path.

For question 2, your approach should work.

HTH

Sundar

New Member

Re: EIGRP questions

I currently have EIGRP turned off at our backup location due to the preferred route not working correctly. I will re-anable tomorrow during our maintenance window and post then unless you have any other ideas.

Thanks again,

Jake

Re: EIGRP questions

In the meantime, if you can upload the configuration of the two hub routers and one remote router then we might be able to spot the issue.

New Member

Re: EIGRP questions

You bet.

Main Hub:

router eigrp 64

redistribute static

network 10.0.0.0

network 192.168.168.0

distribute-list 70 out static

no auto-summary

access-list 70 remark EIGRP ACL for Static Route Distribution

access-list 70 remark The following is DMZ

access-list 70 permit 192.168.10.0 0.0.0.255

Backup Hub:

router eigrp 64

network 10.0.0.0

network 192.168.168.0

network 192.168.170.0

no auto-summary

Remote Site:

router eigrp 64

network 10.0.0.0

network 192.168.168.0

network 192.168.170.0

no auto-summary

eigrp stub connected summary static

distribute-list 70 out static

access-list 70 remark The following is LAN/DMZ

access-list 70 permit 10.64.65.0 0.0.0.255

Here is the config (note the delay) on the interface on the main hub connected to the remote site:

Serial2/0.99 is up, line protocol is up

Hardware is M1T-T3 pa

Description: connection to Remote Office

Internet address is 192.168.168.57/30

MTU 4470 bytes, BW 9000 Kbit, DLY 200 usec,

reliability 255/255, txload 6/255, rxload 2/255

Encapsulation FRAME-RELAY

And now the backup hub:

Serial0/0.66 is up, line protocol is up

Hardware is QUICC with integrated T1 CSU/DSU

Description: connection to Remote Office

Internet address is 192.168.170.29/30

MTU 1500 bytes, BW 1536 Kbit, DLY 25000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation FRAME-RELAY

And yet for some reason traffic from the remote site will prefer the route over the backup hub even though I've upped the delay. Hmm....

Re: EIGRP questions

Did you change the delay on the remote router's interface(s) as well?

New Member

Re: EIGRP questions

No, only on the backup hub. Is that where I messed up?

Re: EIGRP questions

Yes. Metric calculation is done based on the delay configured on the local int.

New Member

Re: EIGRP questions

So would I need to adjust the delay on just the remote site router or both the remote site and the backup site?

Thank you again.

Re: EIGRP questions

Set the delay to an identical value on either side of the WAN link and that way the return traffic from the hub to the remote site would be routed accordingly.

HTH

Sundar

New Member

Re: EIGRP questions

Sorry for the delay. I need to rate the posts. I got the delay working so the routes are preferred the way i want them. However, I have a problem with the eigrp stub connected summary static. Here is the config:

router eigrp 64

network 10.0.0.0

network 192.168.168.0

network 192.168.170.0

distribute-list 70 out static

no auto-summary

eigrp stub static

!

ip classless

ip route 10.64.65.0 255.255.255.128 10.64.65.129 name PHX-LAN

ip route 10.64.65.192 255.255.255.192 10.64.65.129 name PHX-DMZ

access-list 70 remark The following is PHX LAN/DMZ

access-list 70 permit 10.64.65.0 0.0.0.255

But the routes aren't being redistributed. What am I doing wrong?

Re: EIGRP questions

Glad that helped. I don't see 'redistribute static' under the EIGRP process and that's why it isn't getting advertised.

New Member

Re: EIGRP questions

That worked. Thanks a million. I may be back with more questions when we get into the BGP/EIGRP redistribution and sending EIGRP across a firewall :)

142
Views
8
Helpful
12
Replies
CreatePlease to create content