Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

EIGRP "Flapping" every few days

I've noticed that our eigrp routes are dropping and reestablishing every few days. I'm currently running a 2911 on MoE with our core router being a 3845. We have some MPLS circuits still up, which are on BGP with a redirect to the EIGRP.

Anyone find anything similar to this? I've looked around and tried debugging, but I've found nothing. Everything is set to default for hold times, and I'm not dropping any hello packets when I can check.

This is the constant message we get

000055: Jul  8 22:59:10.352: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 10.250.0.18 (GigabitEthernet0/0) is down: holding time expired.

The 2911's eigrp config

!

router eigrp 100

network 10.0.0.0

The 3845

!

router eigrp 100

redistribute connected

redistribute static

redistribute bgp 65400 metric 1500 10 255 25 1500

network 10.0.0.0

no auto-summary

!

router bgp 65400

no synchronization

bgp log-neighbor-changes

network 0.0.0.0

network 10.0.0.0

redistribute static

redistribute eigrp 100

neighbor 67.134.156.41 remote-as 209

no auto-summary

Thanks!!

Everyone's tags (4)
6 REPLIES
Community Member

Re:EIGRP "Flapping" every few days

Debug ip eigrp



Sent from Cisco Technical Support Android App

Re:EIGRP "Flapping" every few days

Hello Anthony,

Did you check link between routers? Maybe there is problem which cause EIGRP flaps.

You can temporarily configure IP SLA with low frequency (5s like EIGRP hello). Then configure tracking of IP SLA so you can see tracking changes in logs and compare them with EIGRP flaps.

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions
Community Member

Re:EIGRP "Flapping" every few days

How to configure IP SLA...

Re:EIGRP "Flapping" every few days

ip sla 10                                                        ! New IP SLA Instance #10   udp-jitter 10.1.1.1 16800 source-ip 10.2.2.2 codec g711ulaw    ! udp jitter w/Voice codec   tos 184                                                        ! TOS bit, using EF here   frequency 300                                                  ! testing interval ip sla schedule 10 life forever start-time now    - See more at:  http://routerjockey.com/2011/05/06/ip-sla-basics/#sthash.e6olXBbO.dpuf
ip sla 10                                                        ! New IP SLA Instance #10   udp-jitter 10.1.1.1 16800 source-ip 10.2.2.2 codec g711ulaw    ! udp jitter w/Voice codec   tos 184                                                        ! TOS bit, using EF here   frequency 300                                                  ! testing interval ip sla schedule 10 life forever start-time now    - See more at:  http://routerjockey.com/2011/05/06/ip-sla-basics/#sthash.e6olXBbO.dpuf
ip sla 10                                                        ! New IP SLA Instance #10   udp-jitter 10.1.1.1 16800 source-ip 10.2.2.2 codec g711ulaw    ! udp jitter w/Voice codec   tos 184                                                        ! TOS bit, using EF here   frequency 300                                                  ! testing interval ip sla schedule 10 life forever start-time now    - See more at:  http://routerjockey.com/2011/05/06/ip-sla-basics/#sthash.e6olXBbO.dpuf
ip sla 10
! ip address of neighbor
icmp-echo 1.1.1.1 frequency 5 ip sla schedule 10 life forever start-time now
track 1 ip sla 1 state

If EIGRP neighborship is flapping because of problem on link, you will see these messages in log output ->

%TRACKING-5-STATE: Up->Down
%TRACKING-5-STATE: Down->Up

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions
Community Member

Re:EIGRP "Flapping" every few days

same msg me too getting... Hold down time expired... What are the reason for expiring hold down time...

VIP Purple

Re:EIGRP "Flapping" every few days

Hello,

Can you show the output of  debug eigrp packet hello to see if the router is sending or/and recieiving eigrp hello messages

Ping the neigbour interfaces with small and then larger packets - Is this successful? ( possible congestion?

Ping 244.0.0.10 ( this is the Multicast address for eigrp hellos)

You can also try increasing the hold time to a higher value between neighbors, the default on broadcast interfaces 15 secs

interface x/x

ip hold-time eigrp xxx 60

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.
933
Views
0
Helpful
6
Replies
CreatePlease to create content