cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1196
Views
0
Helpful
2
Replies

EIGRP redistribute static and routes to Null0

joan.luque
Level 1
Level 1

Hi all, 

I have encountered some weird behaviour in a Cisco router regarding the eigrp redistribution when I have static redistribution and static routes to Null0 at the same time. I will explain:

Some days ago I used routes to Null0 in order to advertise some routes in our LAB EIGRP domain and test some NAT options:

router eigrp 10
 network 1.1.1.0 0.0.0.255
!
ip nat pool Pool_Customer_A 1.1.1.10 1.1.1.20 prefix-length 24
ip nat inside source list ACL_NAT_Customer_A pool Pool_Customer_A
ip route 1.1.1.0 255.255.255.0 Null0
!
ip access-list standar ACL_NAT_Customer_A
 permit 10.1.1.0 0.0.0.255

With the configuration above all work as expected.

Some days later I tried with the same router to rise other customer traffic. I have used static routes to reach this traffic across a second router and redistribute these static routes via EIGRP to enable the return path. I have use the following configuration:

router eigrp 10
 network 1.1.1.0 0.0.0.255
 redistribute static route-map MAP_STATIC_TO_EIGRP
!
ip nat pool Pool_Customer_A 1.1.1.10 1.1.1.20 prefix-length 24
ip nat inside source list ACL_NAT_Customer_A pool Pool_Customer_A
ip route 1.1.1.0 255.255.255.0 Null0
ip route 2.2.2.0 255.255.255.0 3.3.3.1
!
ip access-list standar ACL_NAT_Customer_A
 permit 10.1.1.0 0.0.0.255
!
ip access-list standard ACL_REDISTRIBUTE_STATIC
permit 2.2.2.0 0.0.0.255
!
route-map MAP_STATIC_TO_EIGRP permit 10
 match ip address ACL_REDISTRIBUTE_STATIC
!

When I added the configuration above the router stop redistribute the static route to Null0. The only way that I found to solve that was defining a loopback interface with an ip in the range that I would redistribute:

interface loopback 1
 ip address 1.1.1.1 255.255.255.0
!

From my point of view this is a really strange behaviour. Maybe I miss something importanta ...
Someone can bring some clue about this?

 

Regards,

 

1 Accepted Solution

Accepted Solutions

Hello

As you may know, When  specifying a network command associated with an active interface eigrp would indeed advertises it.

However if you redistribute static pertaining to a null interface(virtual interface) and you have an active interface with the same subnet address eigrp wont advertise it as it is now NOT a NUL interface.

Also if you redistribute static via route-map it will only advertise what  statics are associate with the route-map and acl

Try removing the network statement from eigrp and the loopback interface and adding the subnet to the exiting acl, which should advertise the two statics as external eigrp routes.

 

no int lo0

router eigrp 10
no network 1.1.1.0 0.0.0.255

ip access-list standard ACL_REDISTRIBUTE_STATIC
permit 1.1.1.0 0.0.0.255


res

Paul

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

2 Replies 2

Richard Burts
Hall of Fame
Hall of Fame

It seems fairly straightforward to me. You are redistributing static routes into EIGRP using a route map to control the redistribution. The route map uses an access list to identify the routes to redistribute. The access list has a permit only for 2.2.2.0 and not for 1.1.1.0. So 1.1.1.0 is no longer redistributed.

 

HTH

 

Rick

HTH

Rick

Hello

As you may know, When  specifying a network command associated with an active interface eigrp would indeed advertises it.

However if you redistribute static pertaining to a null interface(virtual interface) and you have an active interface with the same subnet address eigrp wont advertise it as it is now NOT a NUL interface.

Also if you redistribute static via route-map it will only advertise what  statics are associate with the route-map and acl

Try removing the network statement from eigrp and the loopback interface and adding the subnet to the exiting acl, which should advertise the two statics as external eigrp routes.

 

no int lo0

router eigrp 10
no network 1.1.1.0 0.0.0.255

ip access-list standard ACL_REDISTRIBUTE_STATIC
permit 1.1.1.0 0.0.0.255


res

Paul

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Review Cisco Networking products for a $25 gift card