Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

EIGRP: Redistributed static route as internal EIGRP routes

Is it possible to redistribute a static route into EIGRP and make it appear as Internal EIGRP route instead of External EIGRP route ?

12 REPLIES

Re: EIGRP: Redistributed static route as internal EIGRP routes

Hi,

Please try this, a network command configured under EIGRP that covers a directly connected static routes (a static route with the outgoing interface only in the ip route command - which is seen as directly connected in the routing table), this will include that subnet for advertisement without the need of redistribute static or connected (advertised as an internal route not as an external route since no redistribution was used) - the outgoing interface needs not be running any routing protocol or included with any network command.

BR,

Mohammed Mahmoud.

Re: EIGRP: Redistributed static route as internal EIGRP routes

Hi,

To practically illustrate my suggestion:

R5(config)#router eigrp 1

R5(config-router)#no aut

R5(config-router)#no auto-summary

R5(config-router)#network 192.168.56.5 0.0.0.0

R5(config-router)#

Rack#r6

Trying R6 (192.168.1.17, 2038)... Open

R6>

R6>

R6>

R6>en

R6#sh ip int br

R6#sh ip int brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 192.168.56.6 YES NVRAM up up

FastEthernet0/1 unassigned YES NVRAM administratively down down

Loopback0 6.6.6.6 YES NVRAM up up

Loopback6 66.66.66.66 YES NVRAM up up

R6#ping 192.168.56.5

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.56.5, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

R6#conf

Configuring from terminal, memory, or network [terminal]?

Enter configuration commands, one per line. End with CNTL/Z.

R6(config)#

R6(config)#router eigrp 1

R6(config-router)#network 192.168.56.6 0.0.0.0

R6(config-router)#no auto-summary

*Apr 23 22:53:52.398: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.56.5 (FastEthernet0/0) is up: new adjacency

R6(config-router)#exit

R6(config)#ip route 192.66.66.0 255.255.255.0 Loopback6

R6(config)#router eigrp 1

R6(config-router)#net

R6(config-router)#network 192.66.66.0 0.0.0.0

R6(config-router)#

Rack#1

[Resuming connection 1 to r5 ... ]

*Apr 23 23:19:18.654: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.56.6 (GigabitEthernet0/0) is up: new adjacency

R5(config-router)#

R5(config-router)#

R5(config-router)#do sh ip route eigrp

D 192.66.66.0/24 [90/156160] via 192.168.56.6, 00:00:09, GigabitEthernet0/0

R5(config-router)#

BR,

Mohammed Mahmoud.

New Member

Re: EIGRP: Redistributed static route as internal EIGRP routes

You can restribute static into eigrp and then on the interface through which the routing update goes through, there u need to configure a summary address which has the route which is being restributed.

New Member

EIGRP: Redistributed static route as internal EIGRP routes

Pneelaka,

Working through a problem where eigrp won't redistribute some static routes. Here is what I have.

The FD Inaccessible is puzzling because the static route is on that specific switch. Other routes work fine. Those are not included but configured the same as below. No other routing protocols being used.

switch-1#sh ip eigrp top | inc 10.209.
P 10.209.32.0/20, 0 successors, FD is Inaccessible

switch-1# sh ip route 10.209.32.0
Routing entry for 10.209.32.0/20, supernet
  Known via "static", distance 1, metric 0
  Redistributing via eigrp 706
  Routing Descriptor Blocks:
  * 10.214.176.2
      Route metric is 0, traffic share count is 1


router eigrp 106
redistribute static
network 10.214.0.0 0.0.255.255
distribute-list 11 out static

ip route 10.209.32.0 255.255.240.0 10.214.176.2

access-list 11 permit 10.209.32.0 0.0.15.255

Purple

EIGRP: Redistributed static route as internal EIGRP routes

Hi,

You didn't configure a seed metric  under the redistribute command, by default routes redistributed into EIGRP have an infinite metric:

eg redistribute static metric 1 1 1 1 1

Regards.

Alain.

Don't forget to rate helpful posts.
New Member

EIGRP: Redistributed static route as internal EIGRP routes

Thanks, but I have 25 static routes and only 5 of the static routes do not redistribute with its current configuration.

Bronze

Re: EIGRP: Redistributed static route as internal EIGRP routes

You should always provide a redistribution metric when redistributing static routes. Theoretically, you don't have to, but I've always told folks that you should only leave the metric off if you don't care whether it works or not. The process of deriving the metric automatically is buggy and not to be trusted.

Sent from Cisco Technical Support iPad App

New Member

Re: EIGRP: Redistributed static route as internal EIGRP routes

Great tip. Looking at a few examples here is what I came up with:

redistribute static metric 1000000 100 250 100 1500

Thoughts?

Re: EIGRP: Redistributed static route as internal EIGRP routes

Should be ok.

Note that the bandwidth is expressed in kilobits, delay as configured on the interface and only bandwidth and delay are taken into consideration by default.

http://www.cisco.com/en/US/partner/tech/tk365/technologies_white_paper09186a0080094cb7.shtml#eigrpmetrics

Note the delay is configured in tens of microseconds and displayed in microsecs:

R1(config)#int fa0/0
R1(config-if)#del
R1(config-if)#delay ?
  <1-16777215>  Throughput delay (tens of microseconds)

R1(config-if)#delay 10
R1(config-if)#^Z
R1#
R1#sh int fa0/0
FastEthernet0/0 is administratively down, line protocol is down
  Hardware is Gt96k FE, address is c400.11bc.0000 (bia c400.11bc.0000)
  MTU 1500 bytes, BW 10000 Kbit, DLY 100 usec,

regards,

Leo

Bronze

EIGRP: Redistributed static route as internal EIGRP routes

This may or may not work in your case, but see this doc:

http://www.cisco.com/en/US/tech/tk365/technologies_white_paper09186a0080094cb7.shtml#statictointerface

Redistribution of Static Routes to Interfaces

When you install a static route to an interface, and configure a network statement using router eigrp, which includes the static route, EIGRP redistributes this route as if it were a directly connected interface.

Example:

router eigrp 1

  network 192.168.1.0

ip route 192.168.1.0 255.255.255.0 Null0 name STATIC-ADVERTISED-AS-EIGRP-INTERNAL

Since a) the route matches a network statement, and b) it routes to a interface (not a next hop IP), it will be internal.

sh eig topology 192.168.1.0 255.255.255.0

EIGRP-IPv4 (AS 5): Topology Default-IP-Routing-Table(0) entry for 192.168.1.0 255.255.255.0

  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 51456

  Routing Descriptor Blocks:

  1.1.1.1 (GigabitEthernet0/1), from 1.1.1.1, Send flag is 0x0

      Composite metric is (51456/51200), Route is Internal

New Member

EIGRP: Redistributed static route as internal EIGRP routes

I'm hoping you are someone is still watching this thread.  I have a question regarding the last tip.

If I create a null0 route for a static route that I already had, then I now have 2 equal cost routes to the target subnet (192.168.1.0 in your example).

Could this cause problems with some traffic getting sent to the null0 interface and other traffic getting sent to the next-hop IP? 

I too have the need to advertise static routes as internal, but I'm concerned that load balancing may occur and I may end up dropping some packets to null0 unintentionally as others try to route traffic through the advertising router.

Hall of Fame Super Silver

EIGRP: Redistributed static route as internal EIGRP routes

Casey

My take on this discussion is that you are correct. It looks to me like the example given by Thiland was created as an easy example of a static pointed to an interface. If you do configure a static route this way it may succeed in getting EIGRP to advertise the route to its neighbors as an Internal route but it will also put a route in the local routing table pointing this prefix to null0 and the result would be some packets get dropped.

HTH

Rick

5919
Views
0
Helpful
12
Replies